summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-08 08:53:47 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-08 08:54:26 +0200
commit2bddf9af95636782bf6326b913abf8ca4d02d348 (patch)
tree746b1b7038babd8517eea69eb0902266ee90d4d7 /net-im
parentapp-crypt/tpm2-tools: Remove old (diff)
downloadgentoo-2bddf9af95636782bf6326b913abf8ca4d02d348.tar.gz
gentoo-2bddf9af95636782bf6326b913abf8ca4d02d348.tar.bz2
gentoo-2bddf9af95636782bf6326b913abf8ca4d02d348.zip
net-im/rocketchat-desktop-bin: add version 3.5.1
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 270ee5a7de37..06b9ee805e1b 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.5.0.x86_64.rpm 58607404 BLAKE2B 6ec72bf04e94dbfb42e9a573c010443052fc8b8d1248856bc4889bb00c1bffe2a1e27b7ec10826f48e5f2e7c73915f4b469333e933adc41e505460b7149d4305 SHA512 677a4bc50a64a6a7f961ed609acdf03f28230b8c7df028083f073e2a8e61897416dbc4cc396410bc9a243e532cc9c46a1b8533c129f729de44953892d9ebdf01
+DIST rocketchat-3.5.1.x86_64.rpm 58589732 BLAKE2B 692fb8b413d2fbd26443916381fdb1a547b153b3c037ee10de8555b8f0f1d0d41c4ea59e8d3cbe8729e2808a22a71360c5c55e06bf44311c51a6a251f29ce772 SHA512 cc26b4c918447164693e3db00f9c0ce53dd5f0673d5fba06a52479661f10b0fd3c1e8d0f0930d98c9371a15804315f0a4dedd3c917cd5c80bcccf7eb13ac1797
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.1.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.1.ebuild
new file mode 100644
index 000000000000..46fc3d26d958
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}