summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2017-11-03 03:10:25 +0100
committerMaciej Mrozowski <reavertm@gentoo.org>2017-11-03 03:10:44 +0100
commit2c5a02cd1cf4f6ccec3b0317b1d4b867f107448c (patch)
tree2339a68edb8e8d244834761315214bc0f0244916 /net-im
parentsys-kernel/ck-sources: v.bump (4.9.60 & 4.13.11) (diff)
downloadgentoo-2c5a02cd1cf4f6ccec3b0317b1d4b867f107448c.tar.gz
gentoo-2c5a02cd1cf4f6ccec3b0317b1d4b867f107448c.tar.bz2
gentoo-2c5a02cd1cf4f6ccec3b0317b1d4b867f107448c.zip
net-im/kadu: Update gtk icon cache, bug 630464. Remove custom handling of ccache, bug 622610.
Package-Manager: Portage-2.3.8, Repoman-2.3.4
Diffstat (limited to 'net-im')
-rw-r--r--net-im/kadu/files/kadu-4.3-do-not-force-ccache.patch17
-rw-r--r--net-im/kadu/kadu-4.3-r1.ebuild10
2 files changed, 26 insertions, 1 deletions
diff --git a/net-im/kadu/files/kadu-4.3-do-not-force-ccache.patch b/net-im/kadu/files/kadu-4.3-do-not-force-ccache.patch
new file mode 100644
index 000000000000..2511f3c42b99
--- /dev/null
+++ b/net-im/kadu/files/kadu-4.3-do-not-force-ccache.patch
@@ -0,0 +1,17 @@
+diff -ruN kadu-4.3/CMakeLists.txt my/CMakeLists.txt
+--- kadu-4.3/CMakeLists.txt 2017-01-24 22:36:21.000000000 +0100
++++ my/CMakeLists.txt 2017-11-03 03:00:07.005162047 +0100
+@@ -75,13 +75,6 @@
+ endif ()
+ endif ()
+
+-## CCache is cool stuff to improve compilation time
+-find_program (CCACHE_FOUND ccache)
+-if (CCACHE_FOUND)
+- set_property (GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
+- set_property (GLOBAL PROPERTY RULE_LAUNCH_LINK ccache)
+-endif (CCACHE_FOUND)
+-
+ # Look above, DEBUG_ENABLED is always enabled in Debug configuration.
+ # Enable it in all configurations when ENABLE_DEVELOPER_BUILD is on.
+ if (ENABLE_DEVELOPER_BUILD)
diff --git a/net-im/kadu/kadu-4.3-r1.ebuild b/net-im/kadu/kadu-4.3-r1.ebuild
index b3e45cf121e7..a2dbc88c32f0 100644
--- a/net-im/kadu/kadu-4.3-r1.ebuild
+++ b/net-im/kadu/kadu-4.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
-inherit cmake-utils flag-o-matic
+inherit cmake-utils flag-o-matic gnome2-utils
MY_P="${P/_/-}"
@@ -100,6 +100,10 @@ tabs
word_fix
'
+PATCHES=(
+ "${FILESDIR}/${PN}-4.3-do-not-force-ccache.patch"
+)
+
src_configure() {
# Filter out dangerous flags
filter-flags -fno-rtti
@@ -128,3 +132,7 @@ src_configure() {
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}