summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-09 09:53:28 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-09 09:53:28 +0200
commit2d37180caada2d8b4d2f227585be658300d6eaa4 (patch)
treef40762450f6e469aecd3ba8f32b0c311ab57d72b /net-im
parentdev-python/nototools: Bump to 0.2.16 (diff)
downloadgentoo-2d37180caada2d8b4d2f227585be658300d6eaa4.tar.gz
gentoo-2d37180caada2d8b4d2f227585be658300d6eaa4.tar.bz2
gentoo-2d37180caada2d8b4d2f227585be658300d6eaa4.zip
net-im/rocketchat-desktop-bin: add version 3.5.2
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 9c32162110b2..e980c5e11dd2 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.5.1.x86_64.rpm 58589732 BLAKE2B 692fb8b413d2fbd26443916381fdb1a547b153b3c037ee10de8555b8f0f1d0d41c4ea59e8d3cbe8729e2808a22a71360c5c55e06bf44311c51a6a251f29ce772 SHA512 cc26b4c918447164693e3db00f9c0ce53dd5f0673d5fba06a52479661f10b0fd3c1e8d0f0930d98c9371a15804315f0a4dedd3c917cd5c80bcccf7eb13ac1797
+DIST rocketchat-3.5.2.x86_64.rpm 58600396 BLAKE2B abc2896ede173b3c1df6f9877cf1e629c5618eec50c4974b2fe5602d054ae412b910d06c601a02dd3c27466e86e4076ca76372b2f2553d9677e2f2e8b9ab63eb SHA512 adb0dfd51f4e63f1dbc471ac32627537ccd10780b81cae05d07b94a5cbacb4694f1278c49e9399eefe695fef1b8f3e2e75a7114b3711b5487b5bada2e339f433
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.2.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.2.ebuild
new file mode 100644
index 000000000000..46fc3d26d958
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}