summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorCasper Hanegreefs <casinvictusgentoo@proton.me>2023-05-07 09:24:11 +0200
committerBen Kohler <bkohler@gentoo.org>2023-05-15 15:26:45 -0500
commit5598fa50bd775a68d6ff6222d6e8e4611bfd8dbf (patch)
tree3c124c49006123fe210a825091f5008ca6680905 /net-im
parentdev-python/pdm-pep517: Stabilize 1.1.4 ALLARCHES, #906479 (diff)
downloadgentoo-5598fa50bd775a68d6ff6222d6e8e4611bfd8dbf.tar.gz
gentoo-5598fa50bd775a68d6ff6222d6e8e4611bfd8dbf.tar.bz2
gentoo-5598fa50bd775a68d6ff6222d6e8e4611bfd8dbf.zip
net-im/gajim: add 1.7.3
Closes: https://bugs.gentoo.org/876511 Closes: https://bugs.gentoo.org/876226 Signed-off-by: Casper Hanegreefs <casinvictusgentoo@proton.me> Closes: https://github.com/gentoo/gentoo/pull/30910 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gajim/Manifest1
-rw-r--r--net-im/gajim/gajim-1.7.3.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-im/gajim/Manifest b/net-im/gajim/Manifest
index e7330a5df0bb..ee06ad45b259 100644
--- a/net-im/gajim/Manifest
+++ b/net-im/gajim/Manifest
@@ -1 +1,2 @@
DIST gajim-1.4.7.tar.gz 7184866 BLAKE2B 9be0ae485a372683623eff1f9ed1d209800c3088bf01c134bb5c6f1770e8ded1ebe6c2b301ad648c6cfb1793e2be43aade1410a701f7d0490f2ab1b0a4c3fdd5 SHA512 5988f6b7aa46166208b1693b9e1a5fe982cea2987f3f4170bcb14e4bb9be1154b1c6ceed020a949131a498db43d2dffee30bd3167cd56889c1cbb5641ed960f4
+DIST gajim-1.7.3.tar.gz 3753831 BLAKE2B c7b8b1dc47b1faf9f1c0803e7931cb00bfbf31075fe481d557ec0f308c79e7580d0054d224781a67eaeea24dba40e40de5faf55d633d71f759022a1ac113f6e4 SHA512 66135e88784350bab79b61debc1b65144a82f8eee2c1841d21e4f511b3792361e57b60304d2478654e563687e8302426d76063e748236f4e1c959511c7c28665
diff --git a/net-im/gajim/gajim-1.7.3.ebuild b/net-im/gajim/gajim-1.7.3.ebuild
new file mode 100644
index 000000000000..125c2e7bd15e
--- /dev/null
+++ b/net-im/gajim/gajim-1.7.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="sqlite,xml(+)"
+DISTUTILS_USE_PEP517=standalone
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="https://gajim.org/"
+SRC_URI="https://gajim.org/downloads/$(ver_cut 1-2)/${P/_p/-}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="+crypt geolocation jingle omemo remote rst +spell upnp +webp"
+
+COMMON_DEPEND="
+ dev-libs/gobject-introspection[cairo(+)]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ x11-libs/gtksourceview:4[introspection]"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17-r1"
+RDEPEND="${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/idna[${PYTHON_USEDEP}]
+ >=dev-python/nbxmpp-4.2.2[${PYTHON_USEDEP}]
+ <dev-python/nbxmpp-5.0.0[${PYTHON_USEDEP}]
+ dev-python/precis-i18n[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ x11-libs/libXScrnSaver
+ app-crypt/libsecret[crypt,introspection]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ >=dev-python/secretstorage-3.1.1[${PYTHON_USEDEP}]
+ dev-python/css-parser[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ net-libs/libsoup:3.0[introspection]
+ media-libs/gsound[introspection]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ crypt? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/python-gnupg-0.4.0[${PYTHON_USEDEP}] )
+ geolocation? ( app-misc/geoclue[introspection] )
+ jingle? (
+ net-libs/farstream:0.2[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-gtk
+ )
+ omemo? (
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/python-axolotl[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ remote? (
+ >=dev-python/dbus-python-1.2.0[${PYTHON_USEDEP}]
+ sys-apps/dbus[X]
+ )
+ rst? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ spell? (
+ app-text/gspell[introspection]
+ app-text/hunspell
+ )
+ upnp? ( net-libs/gupnp-igd:0[introspection] )
+ ')"
+
+src_install() {
+ distutils-r1_src_install
+ doman data/*.1
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+# Tests are unfortunately regularly broken
+RESTRICT="test"