summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-02-16 21:35:02 +0100
committerUlrich Müller <ulm@gentoo.org>2017-02-16 21:41:25 +0100
commit7cdb9364b6aff42a5f8d05e4bc258bd721a5a22c (patch)
tree64ca89cea65459cb4fc7246ca1e1905ba35ac1b0 /net-im
parentsys-boot/grub: RESTRICT="!test? ( test )" (diff)
downloadgentoo-7cdb9364b6aff42a5f8d05e4bc258bd721a5a22c.tar.gz
gentoo-7cdb9364b6aff42a5f8d05e4bc258bd721a5a22c.tar.bz2
gentoo-7cdb9364b6aff42a5f8d05e4bc258bd721a5a22c.zip
net-im/openmittsu: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-im')
-rw-r--r--net-im/openmittsu/Manifest1
-rw-r--r--net-im/openmittsu/openmittsu-0.9.2_p82.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-im/openmittsu/Manifest b/net-im/openmittsu/Manifest
index 74fdc2efa293..c847b403d4da 100644
--- a/net-im/openmittsu/Manifest
+++ b/net-im/openmittsu/Manifest
@@ -1 +1,2 @@
DIST openMittsu-0.9.2_p78.tar.xz 1304908 SHA256 9be2d1e35a5995786f0c02383e0aaccd67f8848743417020f70d814f464ecc85 SHA512 4969667bd7430dc5b7d0d756ae5f8f8f64ebd717645a6288a46f49f9b03930d6aceac3a9b3d507e12d0a35b69226e19ec65792af23e5e402cf6c7f693bae145c WHIRLPOOL 4903f37a7ea9addc1739940138d50a6caf716810016900edc107b0f02538f10322040ef734e6159cd099347ac2a988bafc778c3c8a0accd26d3bace4a0930a2c
+DIST openMittsu-0.9.2_p82.tar.xz 1313600 SHA256 3fefd9c9a67cede57e9f310c39d7547cd622a859511d5e7af12261d2fd4b337b SHA512 c50e5618a282833d472c1d176d928dc2902d2d0a5e65bf4524af48ae17ba45e002fac5d3bceefaf8a4007eee3749976c680fd168c865c4b5e2e2e2c532d5f600 WHIRLPOOL f3290289aa0f8a59c391f127561418a0103c00a664fff27db67c73125ba772f675e71db17fa7a3fa8a25c127527f66339e2d0cd4fa095d2746a13b9b905a6908
diff --git a/net-im/openmittsu/openmittsu-0.9.2_p82.ebuild b/net-im/openmittsu/openmittsu-0.9.2_p82.ebuild
new file mode 100644
index 000000000000..f7e91f3c0199
--- /dev/null
+++ b/net-im/openmittsu/openmittsu-0.9.2_p82.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils eutils
+
+MY_PN="openMittsu"
+DESCRIPTION="An open source chat client for Threema-style end-to-end encrypted chat networks"
+HOMEPAGE="https://www.openmittsu.de/"
+# git-archive-all.sh snapshot of https://github.com/blizzard4591/${MY_PN}.git
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${MY_PN}-${PV}.tar.xz"
+
+LICENSE="GPL-2+ BitstreamVera OFL-1.1 Apache-2.0 CC0-1.0 MIT BSD-2 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-libs/libsodium-1.0.11:=
+ >=dev-qt/qtcore-5.7.1:5=
+ >=dev-qt/qtgui-5.7.1:5=
+ >=dev-qt/qtmultimedia-5.7.1:5=
+ >=dev-qt/qtnetwork-5.7.1:5=
+ >=dev-qt/qtwidgets-5.7.1:5=
+ >=media-gfx/qrencode-3.4.4-r1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=(
+ README.md
+ Example-client-configuration-file.ini
+ Example-contacts-file.txt
+)
+
+src_prepare() {
+ # set version manually, since autodetection works only with git
+le sed -i "/git_describe_checkout/\
+ s/.*/set(OPENMITTSU_GIT_VERSION_STRING \"${PV/_p/-}-00000000\")/" \
+ CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=("-DOPENMITTSU_DISABLE_VERSION_UPDATE_CHECK=ON")
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon resources/icon.png ${MY_PN}.png
+ make_desktop_entry ${MY_PN} ${MY_PN} ${MY_PN}
+}