summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:12:40 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:17 +0100
commit846777413dbbdbd292d82d3e42b49a06dbcfceef (patch)
tree0c393a4b7250e75b3b85ec60847dd6c483554121 /net-im
parentnet-im/jabber-base: drop 0.01-r2 (diff)
downloadgentoo-846777413dbbdbd292d82d3e42b49a06dbcfceef.tar.gz
gentoo-846777413dbbdbd292d82d3e42b49a06dbcfceef.tar.bz2
gentoo-846777413dbbdbd292d82d3e42b49a06dbcfceef.zip
net-im/libcommuni: add 3.7.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/libcommuni/Manifest1
-rw-r--r--net-im/libcommuni/libcommuni-3.7.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/net-im/libcommuni/Manifest b/net-im/libcommuni/Manifest
index 86cab5b573ba..0718ccc334b2 100644
--- a/net-im/libcommuni/Manifest
+++ b/net-im/libcommuni/Manifest
@@ -1 +1,2 @@
DIST libcommuni-3.6.0.tar.gz 472634 BLAKE2B 0d3d68e27f75cd59ebd61532261e2d3d2c0c2d61d6e08e5b4ed2b21bbf75572f4ce1763fbc4f66c8d5f7c8f9859240ddff5daceeb548d82e2efe936a265031b7 SHA512 cf872d0cdc281a452129a05f5a903eeec3661a4d0d56bdc61bdf95ea969c7b1bcb68534d3d8999fb85ef2b81f17c067b5cd3437351d4635efae3c714567518c0
+DIST libcommuni-3.7.0.tar.gz 475364 BLAKE2B d5bc6deac50b403c7423ab3f9953f94fa3db522f67740a62095700f45c8ee9c35a84aba35f48ff3104a8ffdadaf904f96b625dd1882fa89f49e31731f97e96c0 SHA512 ed1182256899f6be4b492e20958de2edf557b744362701f031ede279c7464b031a57a50e3d7174ae61e313e43564dbf0b04eb382af6bcda71eb96d3405f168c1
diff --git a/net-im/libcommuni/libcommuni-3.7.0.ebuild b/net-im/libcommuni/libcommuni-3.7.0.ebuild
new file mode 100644
index 000000000000..fe3ceeeab068
--- /dev/null
+++ b/net-im/libcommuni/libcommuni-3.7.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="A cross-platform IRC framework written with Qt"
+HOMEPAGE="https://communi.github.io/"
+SRC_URI="https://github.com/communi/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples qml test +uchardet"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ examples? ( || (
+ dev-qt/qtgui:5[X(-)]
+ dev-qt/qtgui:5[xcb(-)]
+ ) )
+ uchardet? ( app-i18n/uchardet )
+ !uchardet? ( dev-libs/icu:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+src_configure() {
+ local myqmakeargs=( libcommuni.pro
+ # Disables compile run-time benchmarks, as they don't make any sense
+ -config no_benchmarks
+ # Is needed for fixing the QA Notice: The following files contain insecure RUNPATHs
+ -config no_rpath
+ # Compile libcommuni always in Release mode, as Debug seems to do nothing
+ -config release
+ # Don't silence all compile messages
+ -config verbose
+ -config $(usex examples '' 'no_')examples
+ -config $(usex qml '' 'no_')qml
+ -config $(usex test '' 'no_')tests
+ -config $(usex uchardet 'no_' '')icu
+ -config $(usex uchardet '' 'no_')uchardet )
+
+ eqmake5 "${myqmakeargs[@]}"
+}
+
+src_test() {
+ # This is a hack to delete the existing LD_LIBRARY_PATH and set a new one,
+ # otherwise a test will fail, because it uses the system installed lib instead of the new compiled lib.
+ # The test will fail, when libcommuni is emerged with USE="uchardet" and
+ # libcommuni is already installed with USE="-uchardat", or the other way around.
+ find "${S}" -type f -name 'target_wrapper.sh' -exec sed -i -e "/.*LD_LIBRARY_PATH.*/d" {} \; || die
+ local -x LD_LIBRARY_PATH="${S}/lib"
+
+ default
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ if use examples; then
+ local examples=( "bot" "client" "minimal" "qmlbot" "quick" )
+ for example in ${examples[@]}; do
+ newbin examples/"${example}"/"${example}" libcommuni."${example}"
+ done
+ fi
+
+ einstalldocs
+}