summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorEthan Kiang <chocopuff298@gmail.com>2017-09-09 09:50:40 +0200
committerJohannes Huber <johu@gentoo.org>2017-09-09 09:51:24 +0200
commit925bff0f3338826cd0b011aee974503b7b5d6a8b (patch)
treef5c67aafc43860c3139102fa137ac261aa47b884 /net-im
parentxfce-extra/xfce4-xkb-plugin: Bump to 0.8.1 (diff)
downloadgentoo-925bff0f3338826cd0b011aee974503b7b5d6a8b.tar.gz
gentoo-925bff0f3338826cd0b011aee974503b7b5d6a8b.tar.bz2
gentoo-925bff0f3338826cd0b011aee974503b7b5d6a8b.zip
net-im/discord-bin: Version bump 0.0.2
Closes: https://bugs.gentoo.org/show_bug.cgi?id=627368 Closes: https://github.com/gentoo/gentoo/pull/5373 Package-Manager: Portage-2.3.8, Repoman-2.3.3 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/discord-bin/Manifest1
-rw-r--r--net-im/discord-bin/discord-bin-0.0.2.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/net-im/discord-bin/Manifest b/net-im/discord-bin/Manifest
index 3bcdba26ee4e..0ec14c75694f 100644
--- a/net-im/discord-bin/Manifest
+++ b/net-im/discord-bin/Manifest
@@ -1 +1,2 @@
DIST discord-0.0.1.deb 36757016 SHA256 b202ce5475544605816f4145481ac7d12640b45599dea3118b521e99656e9366 SHA512 e7013a95ee6be4eea9cec94be5546a4ebd51295fb8e83a0fd436ccf261480caa891454946f08c3d23e23e6ad7201675e3e934dba1173b1ecc291c8e8d911b27f WHIRLPOOL ef13d695a66c72316fa90b82c7e312a0ce16b1dec4a0da6648d9e8b0840af43474b31aae1987e66507c3dcb34a54b090b70b2f44f072db4f434c7268d5781dc4
+DIST discord-0.0.2.deb 46975796 SHA256 2500c1f0e3bf51dd45983fb693b3f5efdd31b0edffc947fec7160fad098dc815 SHA512 ca31952e4eba88c0a40a31eb5671ae71641f8575b298557ff0f1bc1d99d12b1cf282f4178650af594562831a31961aa8cd27ae70e301831190ff6647c3561bd2 WHIRLPOOL 13a5967a9b86aca0ec6be991905968d17da16edb119356a7ccd95eb311c0b5d53cd26e27dfe9978a67fd9260008104c0b08ccf115b62934bfdf79be6495af39f
diff --git a/net-im/discord-bin/discord-bin-0.0.2.ebuild b/net-im/discord-bin/discord-bin-0.0.2.ebuild
new file mode 100644
index 000000000000..248c86bc7c3f
--- /dev/null
+++ b/net-im/discord-bin/discord-bin-0.0.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN/-bin/}
+inherit eutils gnome2-utils unpacker
+
+DESCRIPTION="All-in-one voice and text chat for gamers"
+HOMEPAGE="https://discordapp.com"
+SRC_URI="https://dl.discordapp.net/apps/linux/${PV}/${MY_PN}-${PV}.deb"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gconf:2
+ media-libs/alsa-lib
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/libcxx
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+S=${WORKDIR}
+
+RESTRICT="mirror bindist"
+
+QA_PREBUILT="
+ opt/discord/share/discord/Discord
+ opt/discord/share/discord/libnode.so
+ opt/discord/share/discord/libffmpeg.so
+"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:/usr/share/discord/Discord:discord:g" \
+ usr/share/${MY_PN}/${MY_PN}.desktop || die
+}
+
+src_install() {
+ insinto /opt/${MY_PN}
+ doins -r usr/.
+
+ fperms +x /opt/${MY_PN}/bin/${MY_PN}
+ dosym "${D}/opt/${MY_PN}/bin/${MY_PN}" /usr/bin/${MY_PN}
+ dosym "${D}/opt/${MY_PN}/share/applications/${MY_PN}.desktop" \
+ /usr/share/applications/${MY_PN}.desktop
+ dosym "${D}/opt/${MY_PN}/share/pixmaps/${MY_PN}.png" \
+ /usr/share/pixmaps/${MY_PN}.png
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}