summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-02-06 21:58:59 +0100
committerUlrich Müller <ulm@gentoo.org>2017-02-06 21:59:30 +0100
commit9ac7564f1d45119ce95ceee33a04d946ff45a08d (patch)
treefa230ae5697599874012987377b9df5dd2911796 /net-im
parentapp-benchmarks/sysbench: bump to 1.0.1 (diff)
downloadgentoo-9ac7564f1d45119ce95ceee33a04d946ff45a08d.tar.gz
gentoo-9ac7564f1d45119ce95ceee33a04d946ff45a08d.tar.bz2
gentoo-9ac7564f1d45119ce95ceee33a04d946ff45a08d.zip
net-im/openmittsu: Install icon and desktop file.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-im')
-rw-r--r--net-im/openmittsu/openmittsu-0.9.2_p75-r1.ebuild (renamed from net-im/openmittsu/openmittsu-0.9.2_p75.ebuild)22
1 files changed, 14 insertions, 8 deletions
diff --git a/net-im/openmittsu/openmittsu-0.9.2_p75.ebuild b/net-im/openmittsu/openmittsu-0.9.2_p75-r1.ebuild
index f7ee98dd1625..da92298ceef7 100644
--- a/net-im/openmittsu/openmittsu-0.9.2_p75.ebuild
+++ b/net-im/openmittsu/openmittsu-0.9.2_p75-r1.ebuild
@@ -4,13 +4,13 @@
EAPI=6
-inherit cmake-utils
+inherit cmake-utils eutils
-MY_P="openMittsu-${PV}"
+MY_PN="openMittsu"
DESCRIPTION="An open source chat client for Threema-style end-to-end encrypted chat networks"
HOMEPAGE="https://github.com/blizzard4591/openMittsu"
-# git-archive-all.sh snapshot of https://github.com/blizzard4591/openMittsu.git
-SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${MY_P}.tar.xz"
+# git-archive-all.sh snapshot of https://github.com/blizzard4591/${MY_PN}.git
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${MY_PN}-${PV}.tar.xz"
LICENSE="GPL-2+ BitstreamVera OFL-1.1 Apache-2.0 CC0-1.0 MIT"
SLOT="0"
@@ -25,12 +25,12 @@ DEPEND=">=dev-libs/libsodium-1.0.11:=
>=media-gfx/qrencode-3.4.4-r1"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}"
+S="${WORKDIR}/${MY_PN}-${PV}"
DOCS=(
- "README.md"
- "Example-client-configuration-file.ini"
- "Example-contacts-file.txt"
+ README.md
+ Example-client-configuration-file.ini
+ Example-contacts-file.txt
)
src_prepare() {
@@ -47,3 +47,9 @@ src_configure() {
local mycmakeargs=("-DOPENMITTSU_DISABLE_VERSION_UPDATE_CHECK=ON")
cmake-utils_src_configure
}
+
+src_install() {
+ cmake-utils_src_install
+ newicon resources/icon.png ${MY_PN}.png
+ make_desktop_entry ${MY_PN} ${MY_PN} ${MY_PN}
+}