summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-07-14 01:10:19 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-07-14 01:11:07 +1000
commit9b8473a9f3330ca71b4fc6edfb9ff50bc0bc102e (patch)
tree3b18b66af4c58eb7a80a21301b2e3de597b32bee /net-im
parentnet-im/kadu: amd64/x86 stable (diff)
downloadgentoo-9b8473a9f3330ca71b4fc6edfb9ff50bc0bc102e.tar.gz
gentoo-9b8473a9f3330ca71b4fc6edfb9ff50bc0bc102e.tar.bz2
gentoo-9b8473a9f3330ca71b4fc6edfb9ff50bc0bc102e.zip
net-im/kadu: remove old
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-im')
-rw-r--r--net-im/kadu/kadu-2.1.ebuild145
1 files changed, 0 insertions, 145 deletions
diff --git a/net-im/kadu/kadu-2.1.ebuild b/net-im/kadu/kadu-2.1.ebuild
deleted file mode 100644
index 8e0dc7108782..000000000000
--- a/net-im/kadu/kadu-2.1.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit cmake-utils flag-o-matic
-
-MY_P="${P/_/-}"
-
-DESCRIPTION="An open source Gadu-Gadu and Jabber/XMPP protocol Instant Messenger client"
-HOMEPAGE="http://www.kadu.net"
-SRC_URI="http://download.kadu.im/stable/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~x86"
-SLOT="0"
-IUSE="+gadu mpd otr phonon sdk speech spell xmpp"
-REQUIRED_USE="
- || (
- gadu
- xmpp
- )
-"
-COMMON_DEPEND="
- app-crypt/qca:2[openssl,qt5]
- >=dev-libs/injeqt-1.0.0
- >=dev-qt/qtcore-5.2.0:5
- >=dev-qt/qtdbus-5.2.0:5
- >=dev-qt/qtgui-5.2.0:5
- >=dev-qt/qtmultimedia-5.2.0:5
- >=dev-qt/qtnetwork-5.2.0:5
- >=dev-qt/qtquick1-5.2.0:5
- >=dev-qt/qtscript-5.2.0:5
- >=dev-qt/qtsql-5.2.0:5
- >=dev-qt/qtsvg-5.2.0:5
- >=dev-qt/qtwebkit-5.2.0:5
- >=dev-qt/qtwidgets-5.2.0:5
- >=dev-qt/qtx11extras-5.2.0:5
- >=dev-qt/qtxml-5.2.0:5
- >=dev-qt/qtxmlpatterns-5.2.0:5
- >=app-arch/libarchive-2.6[lzma]
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXScrnSaver
- gadu? ( >=net-libs/libgadu-1.11.1[threads] )
- mpd? ( media-libs/libmpdclient )
- otr? (
- >=dev-libs/libgcrypt-1.2.2:0
- >=net-libs/libotr-4.1.0
- )
- phonon? (
- || (
- media-libs/phonon[qt5]
- >=dev-qt/qtphonon-4.7.0:4
- )
- )
- spell? ( app-text/enchant )
- xmpp? (
- net-dns/libidn
- sys-libs/zlib
- )
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-qt/linguist-tools-5.2.0:5
- x11-proto/scrnsaverproto
- x11-proto/xextproto
- x11-proto/xproto
-"
-RDEPEND="${COMMON_DEPEND}
- speech? ( app-accessibility/powiedz )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-qt5-compilation.patch"
-)
-
-PLUGINS='
-antistring
-auto_hide
-autoaway
-autoresponder
-autostatus
-cenzor
-chat_notify
-config_wizard
-desktop_docking
-docking
-emoticons
-encryption_ng
-encryption_ng_simlite
-exec_notify
-ext_sound
-falf_mediaplayer
-filedesc
-firewall
-freedesktop_notify
-hints
-history
-idle
-imagelink
-last_seen
-mediaplayer
-mprisplayer_mediaplayer
-pcspeaker
-qt4_docking
-qt4_docking_notify
-screenshot simpleview
-single_window
-sms
-sound
-sql_history
-tabs
-word_fix
-'
-
-src_configure() {
- # Filter out dangerous flags
- filter-flags -fno-rtti
- strip-unsupported-flags
-
- # Ensure -DQT_NO_DEBUG is added
- append-cppflags -DQT_NO_DEBUG
-
- # Plugin selection
- use gadu && PLUGINS+=' gadu_protocol history_migration profiles_import'
- use mpd && PLUGINS+=' mpd_mediaplayer'
- use otr && PLUGINS+=' encryption_otr'
- use phonon && PLUGINS+=' phonon_sound'
- use speech && PLUGINS+=' speech'
- use spell && PLUGINS+=' spellchecker'
- use xmpp && PLUGINS+=' jabber_protocol'
-
- # Configure package
- local mycmakeargs=(
- -DBUILD_DESCRIPTION='Gentoo Linux'
- -DCOMPILE_PLUGINS="${PLUGINS}"
- -DNETWORK_IMPLEMENTATION="Qt"
- $(cmake-utils_use sdk INSTALL_SDK)
- $(cmake-utils_use_with spell ENCHANT)
- )
- unset PLUGINS
-
- cmake-utils_src_configure
-}