summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2022-08-21 18:40:04 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-08-31 11:39:14 +0300
commit9c85489fe25a2cb24ac97e52af5a9118af326c03 (patch)
tree72f0424af53527cd62be3d078d5bc19c786b39ce /net-im
parentnet-im/slack: drop old ebuild (diff)
downloadgentoo-9c85489fe25a2cb24ac97e52af5a9118af326c03.tar.gz
gentoo-9c85489fe25a2cb24ac97e52af5a9118af326c03.tar.bz2
gentoo-9c85489fe25a2cb24ac97e52af5a9118af326c03.zip
net-im/slack: version bump to 4.27.156, wrt #836874, #772137, #853964
Closes: https://bugs.gentoo.org/836874 Closes: https://bugs.gentoo.org/772137 Closes: https://bugs.gentoo.org/853964 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/26950 Closes: https://github.com/gentoo/gentoo/pull/26744 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/slack/Manifest1
-rw-r--r--net-im/slack/slack-4.27.156.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/net-im/slack/Manifest b/net-im/slack/Manifest
index 4d3ec67f0e85..6d318d8ec972 100644
--- a/net-im/slack/Manifest
+++ b/net-im/slack/Manifest
@@ -1 +1,2 @@
DIST slack-desktop-4.23.0-amd64.deb 65626830 BLAKE2B a4b49e71b956e74a915ea9f2e26272d8ef15191c92479b1ed2615108569cc4c6cb97de53ff8d4099e4348b81c97447c0edfc1b0fbeacda3833953de9463e877f SHA512 f7885d78f712624ec8c3a26787a1876f4c6a35fedeec824ed4b1d7cc57dd23b9402254a7cfa9f585c3869a920d6fcfc868b9875a477fde1eab9d42a01d43d550
+DIST slack-desktop-4.27.156-amd64.deb 66938030 BLAKE2B b7d457fcb6a2518eaea7efc4d7b43f01f8c1da8a1218d3c2c2c14e195004102be344c6f4e2b60dd4f4677e53ea976cb7b0b102e3e0eec385df881eecdee4a7cd SHA512 b7aa66136a330536393a157843e02e4cfec5eca74431304b1b166e80eaadf41e8b12ad69af8616032042237cb9a38414f9bf1b76701def1985edd0a5570781f9
diff --git a/net-im/slack/slack-4.27.156.ebuild b/net-im/slack/slack-4.27.156.ebuild
new file mode 100644
index 000000000000..456821a8ac4a
--- /dev/null
+++ b/net-im/slack/slack-4.27.156.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop multilib-build optfeature pax-utils unpacker xdg
+
+DESCRIPTION="Team collaboration tool"
+HOMEPAGE="https://slack.com"
+SRC_URI="https://downloads.slack-edge.com/releases/linux/${PV}/prod/x64/${PN}-desktop-${PV}-amd64.deb"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="appindicator +seccomp suid wayland"
+RESTRICT="bindist mirror"
+
+RDEPEND="app-accessibility/at-spi2-atk:2[${MULTILIB_USEDEP}]
+ app-accessibility/at-spi2-core:2[${MULTILIB_USEDEP}]
+ dev-libs/atk:0[${MULTILIB_USEDEP}]
+ dev-libs/expat:0[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr:0[${MULTILIB_USEDEP}]
+ dev-libs/nss:0[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib:0[${MULTILIB_USEDEP}]
+ media-libs/mesa:0[${MULTILIB_USEDEP}]
+ net-print/cups:0[${MULTILIB_USEDEP}]
+ sys-apps/dbus:0[${MULTILIB_USEDEP}]
+ x11-libs/cairo:0[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libdrm:0[${MULTILIB_USEDEP}]
+ x11-libs/libX11:0[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:0/1.12[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite:0[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage:0[${MULTILIB_USEDEP}]
+ x11-libs/libXext:0[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes:0[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon:0[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:0[${MULTILIB_USEDEP}]
+ x11-libs/pango:0[${MULTILIB_USEDEP}]
+ appindicator? ( dev-libs/libappindicator:3[${MULTILIB_USEDEP}] )"
+
+QA_PREBUILT="opt/slack/chrome-sandbox
+ opt/slack/chrome_crashpad_handler
+ opt/slack/libEGL.so
+ opt/slack/libGLESv2.so
+ opt/slack/libffmpeg.so
+ opt/slack/libvk_swiftshader.so
+ opt/slack/libvulkan.so.1
+ opt/slack/resources/app.asar.unpacked/node_modules/*
+ opt/slack/slack
+ opt/slack/swiftshader/libEGL.so
+ opt/slack/swiftshader/libGLESv2.so"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # remove hardcoded path, logging noise (wrt 694058, 711494)
+ sed -i -e '/Icon/s|/usr/share/pixmaps/slack.png|slack|' \
+ -e '/Exec/s|slack|slack -s|' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed in Icon for slack.desktop"
+
+ if use appindicator ; then
+ sed -i '/Exec/s|=|=env XDG_CURRENT_DESKTOP=Unity |' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed for appindicator"
+ fi
+
+ if ! use seccomp ; then
+ sed -i '/Exec/s/%U/%U --disable-seccomp-filter-sandbox/' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed for seccomp"
+ fi
+
+ if use wayland ; then
+ sed -i '/Exec/s/%U/%U --enable-features=WebRTCPipeWireCapturer/' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed for wayland"
+ fi
+
+ rm usr/lib/slack/LICENSE{,S-linux.json} \
+ || die "rm licenses failed"
+}
+
+src_install() {
+ doicon usr/share/pixmaps/slack.png
+ doicon -s 512 usr/share/pixmaps/slack.png
+ domenu usr/share/applications/slack.desktop
+
+ insinto /opt # wrt 720134
+ cp -a usr/lib/slack "${ED}"/opt || die "cp failed"
+
+ use suid && fperms u+s /opt/slack/chrome-sandbox # wrt 713094
+ dosym ../../opt/slack/slack usr/bin/slack
+
+ pax-mark -m "${ED}"/opt/slack/slack
+}
+
+pkg_postinst() {
+ optfeature "storing passwords via gnome-keyring" app-crypt/libsecret
+
+ xdg_pkg_postinst
+}