summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-20 19:30:45 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-20 20:07:09 +0100
commitb673344dc16de1ef5b6661db19492b45eb0262ab (patch)
tree5efd17f6d98c6ee7daa9d09e35f57843f71d58aa /net-im
parentdev-python/httpx: Stabilize 0.21.3 sparc, #831583 (diff)
downloadgentoo-b673344dc16de1ef5b6661db19492b45eb0262ab.tar.gz
gentoo-b673344dc16de1ef5b6661db19492b45eb0262ab.tar.bz2
gentoo-b673344dc16de1ef5b6661db19492b45eb0262ab.zip
net-im/rocketchat-desktop-bin: add version 3.7.6
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 72297308a4ec..14ecc00a5098 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.7.5.x86_64.rpm 72083048 BLAKE2B 136b0a1051d52b5a9c3c5d66eba8e0cde809bf5086bf6d0dbeb1dc319cbe73ff26c5d33f0a0e989b18c18f38406dedcad344f14ba532953679c7da53aebf4d74 SHA512 48fb9ce3602e7b3ebd2e049975941795cd00a1c89987b267988357af48bdaad958f2c1976c848a7be7e29f4726619531fbb6994cab927d39f13f50f182519818
+DIST rocketchat-3.7.6.x86_64.rpm 72058676 BLAKE2B adc5dcf4366c679cda4e55fdcffefa3284f82e4e0616229ee3fbece519da81a9e71f24c3a04a7301d4b754292a09e09c13221c9e3b2ece65d2ba266655da5b43 SHA512 2d29cbdf9fa1e18eec7687edaea1ebe1b8005aa550df68cec91bb04f91f7fa65dd54b08b3de2ff1f5442fcf97d5b12e5d134123bed6c3e9cbaf6069ffc7a1e5f
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.6.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.6.ebuild
new file mode 100644
index 000000000000..f29cf9d59bde
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}