summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-02-13 23:22:19 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-02-13 23:30:35 -0800
commitb874bcd2d812eca72729978b20a778b6d7e20738 (patch)
tree09263191b20e03c652be655935fa5038be2f52a6 /net-im
parentdev-ruby/yard: add ruby27 (diff)
downloadgentoo-b874bcd2d812eca72729978b20a778b6d7e20738.tar.gz
gentoo-b874bcd2d812eca72729978b20a778b6d7e20738.tar.bz2
gentoo-b874bcd2d812eca72729978b20a778b6d7e20738.zip
net-im/telegram-desktop: use snapcraft api creds
Closes: https://bugs.gentoo.org/706386 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telegram-desktop/telegram-desktop-1.9.13-r1.ebuild (renamed from net-im/telegram-desktop/telegram-desktop-1.9.13.ebuild)27
1 files changed, 14 insertions, 13 deletions
diff --git a/net-im/telegram-desktop/telegram-desktop-1.9.13.ebuild b/net-im/telegram-desktop/telegram-desktop-1.9.13-r1.ebuild
index fbc0c464b1db..620b15ce23a9 100644
--- a/net-im/telegram-desktop/telegram-desktop-1.9.13.ebuild
+++ b/net-im/telegram-desktop/telegram-desktop-1.9.13-r1.ebuild
@@ -104,19 +104,20 @@ src_configure() {
-DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
)
else
- mycmakeargs+=( -DTDESKTOP_API_TEST=ON )
- ewarn
- ewarn "Building ${PN} with test API credentials."
- ewarn "Connectivity to API servers will be throttled."
- ewarn "To build ${PN} custom API credentials cancel build now and obtain"
- ewarn "credentials here: https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md"
- ewarn "After getting credentials you can export variables:"
- ewarn "export MY_TDESKTOP_API_ID=\"17349\""
- ewarn "export MY_TDESKTOP_API_HASH=\"344583e45741c457fe1862106095a5eb\""
- ewarn "and restart the build"
- ewarn "you can save variables in /etc/portage/env/${CATEGORY}/${PN}"
- ewarn "portage will use the file every build automatically"
- ewarn
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+ # Building with snapcraft API credentials by default
+ # Custom API credentials can be obtained here:
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+ # After getting credentials you can export variables:
+ # export MY_TDESKTOP_API_ID="17349""
+ # export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+ # and restart the build"
+ # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+ # portage will use custom variable every build automatically
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="611335"
+ -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+ )
fi
cmake_src_configure