summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.bugzilla.2012@r123.de>2019-02-06 10:38:50 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-02-06 23:36:44 +0100
commitd36cab125f3cc3021b0de4a7c0fd55104f08d153 (patch)
treeee6e5a57b9572ed274b7184d5f25e5fdd56ca500 /net-im
parentprofiles/package.mask: mask mail-filter/dovecot-antispam (diff)
downloadgentoo-d36cab125f3cc3021b0de4a7c0fd55104f08d153.tar.gz
gentoo-d36cab125f3cc3021b0de4a7c0fd55104f08d153.tar.bz2
gentoo-d36cab125f3cc3021b0de4a7c0fd55104f08d153.zip
net-im/signal-desktop-bin: new version 1.21.0.
Signed-off-by: Robert Siebeck <gentoo.bugzilla.2012@r123.de> Closes: https://github.com/gentoo/gentoo/pull/10991 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/signal-desktop-bin/Manifest1
-rw-r--r--net-im/signal-desktop-bin/signal-desktop-bin-1.21.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-im/signal-desktop-bin/Manifest b/net-im/signal-desktop-bin/Manifest
index bbaa54f1c2f6..4bb81eac6c3b 100644
--- a/net-im/signal-desktop-bin/Manifest
+++ b/net-im/signal-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST signal-desktop_1.20.0_amd64.deb 74354598 BLAKE2B 66978f55c273220974b1f078adc8da265250f352f427b587cb4f5fe5d2a72e5de7dbb1550b0d762f64a294a22dc7e27d3a277c60b554e147c15164168ef1784b SHA512 c94af56947aa792b072eb7f150b68fce4fdd363162c634b5438ba56fc5b859104d0ad0c11f66aca27f75da56d3395dc02cc74bb058ab6f15c28898742a90ed9c
+DIST signal-desktop_1.21.0_amd64.deb 74766112 BLAKE2B 16f46a291a6e3ae43f75cc4f85cd47a8faea5c343b77ea7d8b12f7ef40c11abcefddffcbd5c27e6ae9ace6eb44055886150a6c668d3d89cd449c084f697251fa SHA512 7e20e8e511ee3d90ac809dd28c17b08898a7fd0a707bb2a2381ba558af4d8f9f52deb6127cf2dd2ad001714b339ac8e3b2fd1d40f179192f0c0b0aef8d4d2996
diff --git a/net-im/signal-desktop-bin/signal-desktop-bin-1.21.0.ebuild b/net-im/signal-desktop-bin/signal-desktop-bin-1.21.0.ebuild
new file mode 100644
index 000000000000..e4a362f0ca50
--- /dev/null
+++ b/net-im/signal-desktop-bin/signal-desktop-bin-1.21.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin/}"
+
+inherit gnome2-utils pax-utils unpacker xdg-utils
+
+DESCRIPTION="Allows you to send and receive messages of Signal Messenger on your computer"
+HOMEPAGE="https://signal.org/
+ https://github.com/WhisperSystems/Signal-Desktop"
+SRC_URI="https://updates.signal.org/desktop/apt/pool/main/s/${MY_PN}/${MY_PN}_${PV}_amd64.deb"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+RDEPEND="
+ gnome-base/gconf:2
+ dev-libs/nss
+ x11-libs/gtk+:3[X]
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ net-print/cups
+ "
+
+QA_PREBUILT="opt/Signal/signal-desktop
+ opt/Signal/libnode.so
+ opt/Signal/libffmpeg.so"
+
+S="${WORKDIR}"
+
+src_prepare(){
+ default
+ sed -e 's|\("/opt/Signal/signal-desktop"\)|\1 --start-in-tray|g' \
+ -i usr/share/applications/signal-desktop.desktop || die
+ unpack usr/share/doc/signal-desktop/changelog.gz
+}
+
+src_install() {
+ insinto /
+ dodoc changelog
+ doins -r opt
+ insinto /usr/share
+ doins -r usr/share/applications
+ doins -r usr/share/icons
+ fperms +x /opt/Signal/signal-desktop
+ pax-mark m opt/Signal/signal-desktop
+
+ dosym ../../opt/Signal/${MY_PN} /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}