summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2017-07-20 14:42:04 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2017-09-09 14:33:40 +0200
commitd576e38aec358c2742223e2fd6efaf2a33eaaf7a (patch)
tree5a1f9e1515763e2fbe6b2c4ca5c89e0754617190 /net-im
parentx11-misc/dunst: Fix src_install(). (diff)
downloadgentoo-d576e38aec358c2742223e2fd6efaf2a33eaaf7a.tar.gz
gentoo-d576e38aec358c2742223e2fd6efaf2a33eaaf7a.tar.bz2
gentoo-d576e38aec358c2742223e2fd6efaf2a33eaaf7a.zip
net-im/qutim: fix build with gcc 6.1.0 and above
Gentoo-Bug: 623572 Closes: https://github.com/gentoo/gentoo/pull/5147
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qutim/files/qutim-0.3.3-fix-build-with-gcc-6.1.0-and-above.patch26
-rw-r--r--net-im/qutim/qutim-0.3.3_p1.ebuild4
2 files changed, 29 insertions, 1 deletions
diff --git a/net-im/qutim/files/qutim-0.3.3-fix-build-with-gcc-6.1.0-and-above.patch b/net-im/qutim/files/qutim-0.3.3-fix-build-with-gcc-6.1.0-and-above.patch
new file mode 100644
index 000000000000..955fd0dc5e17
--- /dev/null
+++ b/net-im/qutim/files/qutim-0.3.3-fix-build-with-gcc-6.1.0-and-above.patch
@@ -0,0 +1,26 @@
+Fix issues caused by turning on -std=c++14 by default in gcc.6.1+.
+See Gentoo-Bug #623572.
+Upstream commit 7453ef49e8fb64b05cfe7b8c0622bf00eba3080f "Turned on -std=c++11 by default " does the same changes.
+
+diff --git a/protocols/irc/src/irccommandalias.cpp b/protocols/irc/src/irccommandalias.cpp
+index cfe8a620e..41282f15f 100644
+--- a/protocols/irc/src/irccommandalias.cpp
++++ b/protocols/irc/src/irccommandalias.cpp
+@@ -148,7 +148,7 @@ QString IrcPingAlias::generate(IrcCommandAlias::Type aliasType, const QStringLis
+ }
+
+ #define ADD_BAN_CMD(MODE, TYPE, NAME, TITLE, ADDITIONALCMD) \
+- cmd = new IrcCommandAlias(NAME, "MODE %n +b "MODE ADDITIONALCMD, IrcCommandAlias::Participant); \
++ cmd = new IrcCommandAlias(NAME, "MODE %n +b " MODE ADDITIONALCMD, IrcCommandAlias::Participant); \
+ gen = new IrcActionGenerator(QIcon(), TITLE, cmd); \
+ gen->setType(TYPE); \
+ MenuController::addAction<IrcChannelParticipant>(gen, kickBanGroup);
+@@ -172,7 +172,7 @@ QString IrcPingAlias::generate(IrcCommandAlias::Type aliasType, const QStringLis
+ REGISTER_CTCP_CMD(TITLE)
+
+ #define ADD_MODE(MODE, PRIORITY, NAME, TITLE)\
+- cmd = new IrcCommandAlias(NAME, "MODE %n "MODE" %o", IrcCommandAlias::Participant);\
++ cmd = new IrcCommandAlias(NAME, "MODE %n " MODE " %o", IrcCommandAlias::Participant);\
+ gen = new IrcActionGenerator(QIcon(), TITLE, cmd);\
+ gen->setPriority(PRIORITY);\
+ MenuController::addAction<IrcChannelParticipant>(gen, modesGroup);\
diff --git a/net-im/qutim/qutim-0.3.3_p1.ebuild b/net-im/qutim/qutim-0.3.3_p1.ebuild
index 073f594fa873..0a867366a10a 100644
--- a/net-im/qutim/qutim-0.3.3_p1.ebuild
+++ b/net-im/qutim/qutim-0.3.3_p1.ebuild
@@ -87,9 +87,11 @@ RDEPEND="${CDEPEND}
kde-frameworks/oxygen-icons
"
-DOCS=( AUTHORS INSTALL ChangeLog )
+DOCS=( AUTHORS ChangeLog )
+
PATCHES=(
"${FILESDIR}/${PN}-0.3.2-astral-migrate-qt-telepaphy.patch"
+ "${FILESDIR}/${PN}-0.3.3-fix-build-with-gcc-6.1.0-and-above.patch"
)
S="${WORKDIR}/${PN}-${MY_PV}"