summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-04-07 17:35:11 +0200
committerUlrich Müller <ulm@gentoo.org>2020-04-07 18:09:22 +0200
commitea657c535c7ee57bbbef3236781658c5910e7acd (patch)
tree16ab80ef6973fefd7bc65469d86781d876875f2e /net-im
parentnet-im/zoom: Fix dependencies on x86. (diff)
downloadgentoo-ea657c535c7ee57bbbef3236781658c5910e7acd.tar.gz
gentoo-ea657c535c7ee57bbbef3236781658c5910e7acd.tar.bz2
gentoo-ea657c535c7ee57bbbef3236781658c5910e7acd.zip
net-im/zoom: Version bump to 3.5.382995.0407.
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/zoom/Manifest2
-rw-r--r--net-im/zoom/zoom-3.5.382995.0407.ebuild98
2 files changed, 100 insertions, 0 deletions
diff --git a/net-im/zoom/Manifest b/net-im/zoom/Manifest
index cdc31852c2c2..3f6534909a3a 100644
--- a/net-im/zoom/Manifest
+++ b/net-im/zoom/Manifest
@@ -1,2 +1,4 @@
DIST zoom-3.5.374815.0324_i686.tar.xz 48481420 BLAKE2B 5c40be4c5cf1e72766f35ea971384c514a49f8ed882af6791b7681c84082830ee120147fcd138b382509b4ebf5dc84a479f2ad40e7eed0dd332a02d4bc141d8c SHA512 354e7e8af733dad1483e138621574f675822fe9f5739092a11495f6f584917413012866d171e076b7156c6097e71c85f8e53dba1fd9db2de59af55256ab8479e
DIST zoom-3.5.374815.0324_x86_64.tar.xz 72609300 BLAKE2B 2f51eecd88cc636f03778c68101b2c5919982025232da5cd6a378a2e681ad76d39d9db201ff14d5601498495909dfb934ebf21752cd7658ada6edc28379bed90 SHA512 632002b6942f15e1f22ba147de9a9463253c2b374e4382b4c2ce21e5685ad4fd688929141095d09e2fa0ed2adb5b0dc6ba9aba2e4fa54ae69fea24b95bf474c4
+DIST zoom-3.5.382995.0407_i686.tar.xz 48494772 BLAKE2B 13d678c36bac7e5705cc0608d0ca49d943e56b492cce802f41ffe6bbb307336fef4e710346f33e596faa84a449b1f69ef944e462b694aff016051a834e1d2a89 SHA512 339abb803cd08e6835404ff2f1140b9ee73294a8820828d833b64e3bfe619fd24eb18c475b78a0f795a63dadc8ffd6593563710d6e8ba606fcbf3ffd7a007c33
+DIST zoom-3.5.382995.0407_x86_64.tar.xz 72616840 BLAKE2B 3a20f9346305ec84c6b14233724dce6ab285810e7c59ed482139e902f088e2cf7f1f48d769fe0f0990128f92aa4221f7fe5f69e9d5859fc5bf6d57378ec25507 SHA512 d0612f83d23e93e84db5dd18c55ebc6b3cba17b9479ff812276e0d1fb21fb9fbe2fe5f38329f5e30cd7acf6c7f88fdf09d6dd31d223e3edec0bc1142b358bb8b
diff --git a/net-im/zoom/zoom-3.5.382995.0407.ebuild b/net-im/zoom/zoom-3.5.382995.0407.ebuild
new file mode 100644
index 000000000000..15de2f97fc13
--- /dev/null
+++ b/net-im/zoom/zoom-3.5.382995.0407.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+DESCRIPTION="Video conferencing and web conferencing service"
+HOMEPAGE="https://zoom.us/"
+SRC_URI="amd64? ( https://zoom.us/client/${PV}/${PN}_x86_64.tar.xz -> ${P}_x86_64.tar.xz )
+ x86? ( https://zoom.us/client/${PV}/${PN}_i686.tar.xz -> ${P}_i686.tar.xz )"
+S="${WORKDIR}/${PN}"
+
+LICENSE="all-rights-reserved Apache-2.0" # Apache-2.0 for icon
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="pulseaudio"
+RESTRICT="mirror bindist strip"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/icu
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtscript:5
+ dev-qt/qtwidgets:5
+ media-libs/libglvnd
+ media-libs/libjpeg-turbo
+ media-sound/mpg123
+ sys-apps/dbus
+ sys-apps/util-linux
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-keysyms
+ amd64? (
+ dev-qt/qtpositioning:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwebchannel:5
+ dev-qt/qtwebengine:5
+ )
+ x86? (
+ dev-qt/qtwebkit:5
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ !pulseaudio? ( media-libs/alsa-lib )"
+
+BDEPEND="!pulseaudio? ( dev-util/bbe )"
+
+QA_PREBUILT="opt/zoom/*"
+
+src_prepare() {
+ default
+ if ! use pulseaudio; then
+ # For some strange reason, zoom cannot use any ALSA sound devices if
+ # it finds libpulse. This causes breakage if media-sound/apulse[sdk]
+ # is installed. So, force zoom to ignore libpulse.
+ bbe -e 's/libpulse.so/IgNoRePuLsE/' zoom >zoom.tmp || die
+ mv zoom.tmp zoom || die
+ fi
+}
+
+src_install() {
+ insinto /opt/zoom
+ exeinto /opt/zoom
+ doins -r json sip timezones translations
+ doins *.pcm *.pem *.sh Embedded.properties version.txt
+ use amd64 && doins icudtl.dat
+ doexe zoom{,.sh,linux} zopen ZoomLauncher
+ dosym {"../../usr/$(get_libdir)",/opt/zoom}/libmpg123.so
+ dosym {"../../usr/$(get_libdir)",/opt/zoom}/libturbojpeg.so #715106
+
+ make_wrapper zoom ./zoom /opt/zoom
+ make_desktop_entry "zoom %U" Zoom zoom-videocam "" \
+ "MimeType=x-scheme-handler/zoommtg;application/x-zoom;"
+ # The tarball doesn't contain an icon, so take a generic camera icon
+ # from https://github.com/google/material-design-icons, modified to be
+ # white on a blue background
+ doicon -s scalable "${FILESDIR}"/zoom-videocam.svg
+ doicon -s 24 "${FILESDIR}"/zoom-videocam.xpm
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}