summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-05-06 21:18:27 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-05-06 21:19:45 -0700
commitf11fab16f7061f4537677e90f2148a596bfb8006 (patch)
tree40d4d3d0891426b6ddb9f31456d5167f42a44714 /net-im
parentmedia-video/mediainfo: remove old (diff)
downloadgentoo-f11fab16f7061f4537677e90f2148a596bfb8006.tar.gz
gentoo-f11fab16f7061f4537677e90f2148a596bfb8006.tar.bz2
gentoo-f11fab16f7061f4537677e90f2148a596bfb8006.zip
net-im/slack: fix installation on new systems
this is just a hack, should be done properly Bug: https://bugs.gentoo.org/720134 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/slack/slack-4.4.2.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/net-im/slack/slack-4.4.2.ebuild b/net-im/slack/slack-4.4.2.ebuild
index c36c8da0ee24..48b3a778dd01 100644
--- a/net-im/slack/slack-4.4.2.ebuild
+++ b/net-im/slack/slack-4.4.2.ebuild
@@ -84,7 +84,17 @@ src_install() {
insinto /opt/slack
doins -r usr/lib/slack/.
- for i in $(echo -n "${QA_PREBUILT}") ; do fperms +x "$i" ; done
+
+ # this really should be done a better way than trying to parse
+ # the QA_PREBUILT variable
+ local path
+ for path in ${QA_PREBUILT}; do
+ local -a paths=(${D}/${path})
+ for path in "${paths[@]}"; do
+ fperms +x "${path#${D}/}"
+ done
+ done
+
use suid && fperms u+s /opt/slack/chrome-sandbox # wrt 713094
dosym ../../opt/slack/slack usr/bin/slack