summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-05-15 00:58:17 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-05-15 00:58:17 +0200
commitfa72ef00ab576e9364e81282eb230e89977f3cb6 (patch)
treeb24259556cf4b5c4193d0003903c3d777699155f /net-im
parentsys-apps/xinetd: drop 2.3.15.3, 2.3.15.3-r2 (diff)
downloadgentoo-fa72ef00ab576e9364e81282eb230e89977f3cb6.tar.gz
gentoo-fa72ef00ab576e9364e81282eb230e89977f3cb6.tar.bz2
gentoo-fa72ef00ab576e9364e81282eb230e89977f3cb6.zip
net-im/prosody-modules: bump to newest snapshot 20210515
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/prosody-modules/Manifest1
-rw-r--r--net-im/prosody-modules/prosody-modules-0_pre20210515.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/net-im/prosody-modules/Manifest b/net-im/prosody-modules/Manifest
index 7ae3229da7b3..1ef11d7f3993 100644
--- a/net-im/prosody-modules/Manifest
+++ b/net-im/prosody-modules/Manifest
@@ -1 +1,2 @@
DIST prosody-modules-0_pre20210105.tar.xz 1166992 BLAKE2B 02bf4ea4521194db51716c2716370e1b38e747da000dc8d27ce93b5f81d53b9e0367e96f3e18aee74c858ae86474bcaccb0ef944325f508337882acf3cd9e960 SHA512 c0739a309b66c958e205989988c6e7118c0385156d7ebc2a4825646af366fe5665ff6e7e98aab24cf3cc5530fe40c8e9a3440afff196a96624242c00861a308e
+DIST prosody-modules-0_pre20210515.tar.xz 1196276 BLAKE2B 66e9dddeba1e139b16ecc1ea0b786a85cb9181e0bfa0123a9c9ce99f1aa64cc12ba92ffa6b83d63cbc0f45962a13ac8ec508030d99c5e58d645c708a1078dab3 SHA512 1cd48cfa66e72de843db2a593a524636aaa0f36cb5b848e19238d4c2951525882fb30a354e503d71e0fb4b6c8efe0aa09acc16285ac3357d4c8d353a2f48b120
diff --git a/net-im/prosody-modules/prosody-modules-0_pre20210515.ebuild b/net-im/prosody-modules/prosody-modules-0_pre20210515.ebuild
new file mode 100644
index 000000000000..ff13c951991f
--- /dev/null
+++ b/net-im/prosody-modules/prosody-modules-0_pre20210515.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig
+
+DESCRIPTION="A collection of community-maintained modules for Prosody"
+HOMEPAGE="https://modules.prosody.im"
+SRC_URI="https://dev.gentoo.org/~conikost/distfiles/${P}.tar.xz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="net-im/prosody"
+
+src_prepare() {
+ default
+
+ # Exclude 'misc' folder from install, since it does not provide any modules.
+ echo "# Remove all modules from this list, which you don't want to install." > prosody-modules.conf || die
+ find * -maxdepth 0 -type d ! -name misc >> prosody-modules.conf || die
+
+ use savedconfig && restore_config prosody-modules.conf
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/prosody/community-modules"
+ while read prosody_module; do
+ if ! [[ "${prosody_module}" = \#* ]]; then
+ if [[ -f "${prosody_module}/README.markdown" ]]; then
+ newdoc "${prosody_module}/README.markdown" "README.${prosody_module}"
+ rm "${prosody_module}/README.markdown" || die
+ fi
+
+ doins -r "${prosody_module}"
+ fi
+ done <prosody-modules.conf
+
+ save_config prosody-modules.conf
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ savedconfig_pkg_postinst
+
+ einfo "In order to use the community modules on an existing instance, you have to add"
+ einfo "'/usr/$(get_libdir)/prosody/community-modules' into 'plugin_paths'"
+ einfo "into your prosody configuration file '/etc/jabber/prosody.cfg.lua.'"
+ einfo ""
+ einfo "Example: plugin_paths = { /usr/$(get_libdir)/prosody/community-modules };"
+}