summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-01-19 06:42:02 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-01-19 06:42:02 +0100
commitfedf87c94bd1c080e014a2ac2da35f4458d26a3e (patch)
treee7ada11f415fc161b68f1d58906f2b8c4d56b127 /net-im
parentnet-im/discord-bin: rewrite ebuild (diff)
downloadgentoo-fedf87c94bd1c080e014a2ac2da35f4458d26a3e.tar.gz
gentoo-fedf87c94bd1c080e014a2ac2da35f4458d26a3e.tar.bz2
gentoo-fedf87c94bd1c080e014a2ac2da35f4458d26a3e.zip
net-im/discord-bin: bump to v0.0.8
Closes: https://bugs.gentoo.org/675674 Closes: https://bugs.gentoo.org/675554 Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/discord-bin/Manifest2
-rw-r--r--net-im/discord-bin/discord-bin-0.0.8.ebuild (renamed from net-im/discord-bin/discord-bin-0.0.5-r1.ebuild)31
-rw-r--r--net-im/discord-bin/metadata.xml3
3 files changed, 21 insertions, 15 deletions
diff --git a/net-im/discord-bin/Manifest b/net-im/discord-bin/Manifest
index 7a63d83145da..a2b4dab167ba 100644
--- a/net-im/discord-bin/Manifest
+++ b/net-im/discord-bin/Manifest
@@ -1 +1 @@
-DIST discord-0.0.5.deb 52100102 BLAKE2B d8b28386d83fd63e47f11af06bc9858a3877565785c97588dad0ade197d70a8d3635137a66024a3b82c4c65acc6e806981a2d9e0e5f20b17745d9123a2cf5d4a SHA512 8b2ef353d393644e450452060449c633487ff344f2e9e0711029bbb3012c364211edc30507976ec218f8a573aefd603ea1681b4e37fe9561f39c5eaa5fd6e29a
+DIST discord-0.0.8.deb 44221304 BLAKE2B 3b40f03a3398e1041c0b532df8bc1326df2564a2744d05529db9ba9191bb647eed4ebc28e08cdfa69b98336b2b0619f5898367c3497a704a7bec4309f7f2eb36 SHA512 5d228f0d36306d35ae8d76385a82cbfef32da2ee405292062972c4c2df453f0d329d91127d55ce81e79fa398de9be839b77125fc8a7e9958fa3409c29ee4880a
diff --git a/net-im/discord-bin/discord-bin-0.0.5-r1.ebuild b/net-im/discord-bin/discord-bin-0.0.8.ebuild
index 4f5af1205dcf..190284c78c90 100644
--- a/net-im/discord-bin/discord-bin-0.0.5-r1.ebuild
+++ b/net-im/discord-bin/discord-bin-0.0.8.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="6"
MY_PN=${PN/-bin/}
MY_BIN="D${MY_PN/d/}"
-inherit eutils gnome2-utils unpacker desktop xdg-utils
+
+inherit desktop gnome2-utils pax-utils unpacker xdg-utils
DESCRIPTION="All-in-one voice and text chat for gamers"
HOMEPAGE="https://discordapp.com"
@@ -14,7 +15,8 @@ SRC_URI="https://dl.discordapp.net/apps/linux/${PV}/${MY_PN}-${PV}.deb"
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="pax_kernel"
+RESTRICT="mirror bindist"
RDEPEND="
dev-libs/atk
@@ -48,18 +50,17 @@ RDEPEND="
S=${WORKDIR}
-RESTRICT="mirror bindist"
-
QA_PREBUILT="
opt/discord/${MY_BIN}
+ opt/discord/libEGL.so
+ opt/discord/libGLESv2.so
+ opt/discord/swiftshader/libEGL.so
+ opt/discord/swiftshader/libGLESv2.so
+ opt/discord/libVkICD_mock_icd.so
opt/discord/libnode.so
opt/discord/libffmpeg.so
"
-src_unpack() {
- unpack_deb ${A}
-}
-
src_prepare() {
default
@@ -69,13 +70,15 @@ src_prepare() {
}
src_install() {
- domenu opt/${MY_PN}/${MY_PN}.desktop
- doicon opt/${MY_PN}/${MY_PN}.png
+ doicon usr/share/${MY_PN}/${MY_PN}.png
+ domenu usr/share/${MY_PN}/${MY_PN}.desktop
- insinto /opt
- doins -r usr/share/${MY_PN}
+ insinto /opt/${MY_PN}
+ doins -r usr/share/${MY_PN}/.
fperms +x /opt/${MY_PN}/${MY_BIN}
dosym ../../opt/${MY_PN}/${MY_BIN} usr/bin/${MY_PN}
+
+ use pax_kernel && pax-mark -m "${ED%/}"/opt/${MY_PN}/${MY_PN}
}
pkg_postinst() {
diff --git a/net-im/discord-bin/metadata.xml b/net-im/discord-bin/metadata.xml
index 15fd2f3a22be..6fc119fa9d04 100644
--- a/net-im/discord-bin/metadata.xml
+++ b/net-im/discord-bin/metadata.xml
@@ -5,4 +5,7 @@
<email>johu@gentoo.org</email>
<name>Johannes Huber</name>
</maintainer>
+ <use>
+ <flag name="pax_kernel">Triggers a paxmarking of the binary</flag>
+ </use>
</pkgmetadata>