summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/atheme-services/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/atheme-services/files')
-rw-r--r--net-irc/atheme-services/files/atheme-services-6.0.8-configure-disable.patch116
-rw-r--r--net-irc/atheme-services/files/atheme-services.initd37
2 files changed, 153 insertions, 0 deletions
diff --git a/net-irc/atheme-services/files/atheme-services-6.0.8-configure-disable.patch b/net-irc/atheme-services/files/atheme-services-6.0.8-configure-disable.patch
new file mode 100644
index 000000000000..ac671956ee48
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services-6.0.8-configure-disable.patch
@@ -0,0 +1,116 @@
+From be144253c54b41d9b2f3929f12025457f66ce288 Mon Sep 17 00:00:00 2001
+From: Nathan Phillip Brink <ohnobinki@ohnopublishing.net>
+Date: Mon, 13 Jun 2011 22:25:47 -0400
+Subject: [PATCH] Fix remaining AC_ARG_ENABLEs so that --disable-<feature> does not produce the same effect as --enable-<feature>.
+
+Fixes --disable-warnings, --disable-propolice, and --disable-profile. (Problems with --disable-profile resulted in https://bugs.gentoo.org/371119).
+---
+ configure | 21 +++++++++++++++++----
+ configure.ac | 18 ++++++++++++------
+ 2 files changed, 29 insertions(+), 10 deletions(-)
+
+diff --git a/configure b/configure
+index a3337e0..9bd0428 100755
+--- a/configure
++++ b/configure
+@@ -8360,7 +8360,11 @@ $as_echo "no" >&6; }
+
+ # Check whether --enable-warnings was given.
+ if test "${enable_warnings+set}" = set; then :
+- enableval=$enable_warnings;
++ enableval=$enable_warnings; enable_warnings=no
++fi
++
++if test "x$enable_warnings" = "xyes"; then :
++
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking GCC flag(s) -Wall" >&5
+ $as_echo_n "checking GCC flag(s) -Wall... " >&6; }
+@@ -9335,10 +9339,15 @@ $as_echo "no" >&6; }
+
+ fi
+
+-
+ # Check whether --enable-propolice was given.
+ if test "${enable_propolice+set}" = set; then :
+ enableval=$enable_propolice;
++else
++ enable_propolice=no
++fi
++
++if test "x$enable_propolice" = "xyes"; then :
++
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking GCC flag(s) -fno-stack-protector-all" >&5
+ $as_echo_n "checking GCC flag(s) -fno-stack-protector-all... " >&6; }
+@@ -9546,10 +9555,15 @@ $as_echo "no" >&6; }
+
+ fi
+
+-
+ # Check whether --enable-profile was given.
+ if test "${enable_profile+set}" = set; then :
+ enableval=$enable_profile;
++else
++ enable_profile=no
++fi
++
++if test "x$enable_profile" = "xyes"; then :
++
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking GCC flag(s) -pg" >&5
+ $as_echo_n "checking GCC flag(s) -pg... " >&6; }
+@@ -9606,7 +9620,6 @@ LDFLAGS=${ac_save_LDFLAGS}
+
+ fi
+
+-
+ ac_save_CPPFLAGS="${CFLAGS} ${orig_CFLAGS} ${CWARNS} -DPREFIX=\\\"\${prefix}\\\" -DLOCALEDIR=\\\"\${LOCALEDIR}\\\" -DMODDIR=\\\"\${MODDIR}\\\" -DSHAREDIR=\\\"${SHAREDIR}\\\" -DSYSCONFDIR=\\\"${sysconfdir}\\\" -DLOGDIR=\\\"${LOGDIR}\\\" -DRUNDIR=\\\"${RUNDIR}\\\" -DDATADIR=\\\"${DATADIR}\\\""
+ CPPFLAGS=${ac_save_CPPFLAGS}
+
+diff --git a/configure.ac b/configure.ac
+index a8baa2e..36195ce 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -484,8 +484,10 @@ AC_SUBST(PICFLAGS)
+ ATHEME_C_GCC_TRY_FLAGS([-std=gnu99], atheme_cv_c_gcc_std_gnu99)
+ ATHEME_C_GCC_TRY_FLAGS([-Werror-implicit-function-declaration], atheme_cv_c_gcc_w_error_implicit_function_declaration)
+
+-AC_ARG_ENABLE(warnings,
+-AC_HELP_STRING([--enable-warnings],[ Enable compiler warnings]),
++AC_ARG_ENABLE([warnings],
++ [AS_HELP_STRING([--enable-warnings],[ Enable compiler warnings])],
++ [enable_warnings=no])
++AS_IF([test "x$enable_warnings" = "xyes"],
+ [
+ dnl See what warnings we can get away with
+ ATHEME_C_GCC_TRY_FLAGS([-Wall], atheme_cv_c_gcc_w_all)
+@@ -519,8 +521,10 @@ dnl ATHEME_C_GCC_TRY_FLAGS([-Wwrite-strings], atheme_cv_c_gcc_w_strings)
+ dnl ATHEME_C_GCC_TRY_FLAGS([-Werror], atheme_cv_c_gcc_w_error)
+ ])
+
+-AC_ARG_ENABLE(propolice,
+-AC_HELP_STRING([--disable-propolice],[ Disable propolice protections (for debugging.)]),
++AC_ARG_ENABLE([propolice],
++ [AS_HELP_STRING([--disable-propolice],[ Disable propolice protections (for debugging.)])],
++ [], [enable_propolice=no])
++AS_IF([test "x$enable_propolice" = "xyes"],
+ [
+ ATHEME_C_GCC_TRY_FLAGS([-fno-stack-protector-all], atheme_cv_nspa)
+ ATHEME_C_GCC_TRY_FLAGS([-fno-pie], atheme_cv_npie)
+@@ -528,8 +532,10 @@ ATHEME_C_GCC_TRY_FLAGS([-nonow], atheme_cv_nonow)
+ ATHEME_C_GCC_TRY_FLAGS([-norelro], atheme_cv_no_relro)
+ ])
+
+-AC_ARG_ENABLE(profile,
+-AC_HELP_STRING([--enable-profile],[ Enable profiling extensions]),
++AC_ARG_ENABLE([profile],
++ [AS_HELP_STRING([--enable-profile],[ Enable profiling extensions])],
++ [], [enable_profile=no])
++AS_IF([test "x$enable_profile" = "xyes"],
+ [
+ ATHEME_C_GCC_TRY_FLAGS([-pg], atheme_cv_pg)
+ ac_save_LDFLAGS="${LDFLAGS} -pg"
+--
+1.7.3.4
+
diff --git a/net-irc/atheme-services/files/atheme-services.initd b/net-irc/atheme-services/files/atheme-services.initd
new file mode 100644
index 000000000000..53996f386385
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services.initd
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+extra_started_commands="reload"
+
+depend() {
+ need net
+ use ircd
+ provide irc-services
+}
+
+start() {
+ ATHEME_SERVICES_RUNDIR=/var/run/atheme
+ if ! [ -d "${ATHEME_SERVICES_RUNDIR}" ]; then
+ ebegin "Creating \`${ATHEME_SERVICES_RUNDIR}'"
+ install -o atheme-services -d "${ATHEME_SERVICES_RUNDIR}"
+ eend $?
+ fi
+
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --pidfile=/var/run/atheme/atheme.pid --user atheme-services --exec /usr/bin/atheme-services
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ start-stop-daemon --signal HUP --pidfile /var/run/atheme/atheme.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --quiet --pidfile /var/run/atheme/atheme.pid
+ eend $?
+}