summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-12-30 16:09:44 +0100
committerLouis Sautier <sbraz@gentoo.org>2018-12-30 16:14:18 +0100
commit62eee4d233f05ec0ebb48d952b15a858f9b061cb (patch)
tree17351c972953aee14ccdcd0cdeee82864de81b03 /net-irc/eggdrop/eggdrop-1.8.4.ebuild
parentmedia-gfx/digikam: 6.0.0_beta3 version bump (diff)
downloadgentoo-62eee4d233f05ec0ebb48d952b15a858f9b061cb.tar.gz
gentoo-62eee4d233f05ec0ebb48d952b15a858f9b061cb.tar.bz2
gentoo-62eee4d233f05ec0ebb48d952b15a858f9b061cb.zip
net-irc/eggdrop: bump to 1.8.4, fixes build issues
https://github.com/eggheads/eggdrop/issues/526 and https://github.com/eggheads/eggdrop/issues/527 have been fixed in this release so we can remove the associated workarounds. Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-irc/eggdrop/eggdrop-1.8.4.ebuild')
-rw-r--r--net-irc/eggdrop/eggdrop-1.8.4.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/net-irc/eggdrop/eggdrop-1.8.4.ebuild b/net-irc/eggdrop/eggdrop-1.8.4.ebuild
new file mode 100644
index 000000000000..c629643aa509
--- /dev/null
+++ b/net-irc/eggdrop/eggdrop-1.8.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="An IRC bot extensible with C or TCL"
+HOMEPAGE="https://www.eggheads.org/"
+SRC_URI="https://ftp.eggheads.org/pub/eggdrop/source/${PV:0:3}/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~sparc ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug doc ipv6 ssl static"
+
+DEPEND="
+ dev-lang/tcl:0=
+ ssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="
+ sys-apps/gentoo-functions
+ ${DEPEND}
+"
+
+DOCS=( AUTHORS FEATURES INSTALL NEWS README THANKS UPGRADING )
+
+src_configure() {
+ econf $(use_enable ssl tls) \
+ $(use_enable ipv6 ipv6)
+
+ emake config
+}
+
+src_compile() {
+ local target
+
+ if use static && use debug; then
+ target="sdebug"
+ elif use static; then
+ target="static"
+ elif use debug; then
+ target="debug"
+ fi
+
+ emake ${target}
+}
+
+src_install() {
+ emake DEST="${D}"/opt/eggdrop install
+
+ use doc && HTML_DOCS=( doc/html/. )
+ rm -r "${D}"/opt/eggdrop/doc/html || die
+ DOC_CONTENTS="
+ Additional documentation can be found
+ in ${EPREFIX}/opt/eggdrop/doc
+ "
+ readme.gentoo_create_doc
+ einstalldocs
+
+ dobin "${FILESDIR}"/eggdrop-installer
+ doman doc/man1/eggdrop.1
+}
+
+pkg_postinst() {
+ # Only display this for new installs
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please run ${EPREFIX}/usr/bin/eggdrop-installer to install your eggdrop bot."
+ fi
+}