summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-03-04 11:36:29 +0100
committerAmy Winston <amynka@gentoo.org>2016-03-04 18:43:28 +0100
commitd2a5fee2955b5ea8854c4a27fd3e527e9c2c9129 (patch)
treea8429079bcd36b46e22e22fa0e00d11a05ada75d /net-irc/eggdrop
parentprofiles/prefix/parent: switch order to restore things, bug #576412 (diff)
downloadgentoo-d2a5fee2955b5ea8854c4a27fd3e527e9c2c9129.tar.gz
gentoo-d2a5fee2955b5ea8854c4a27fd3e527e9c2c9129.tar.bz2
gentoo-d2a5fee2955b5ea8854c4a27fd3e527e9c2c9129.zip
net-irc/eggdrop: fix compilation with gcc-5 #571004
Backport patch from https://github.com/eggheads/eggdrop/issues/123 Package-Manager: portage-2.2.27
Diffstat (limited to 'net-irc/eggdrop')
-rw-r--r--net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild3
-rw-r--r--net-irc/eggdrop/files/eggdrop-1.6.21-fix-gcc5-remove-inline.patch52
2 files changed, 54 insertions, 1 deletions
diff --git a/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild b/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild
index 22df039dcd96..f761a3ba3ae0 100644
--- a/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild
+++ b/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -35,6 +35,7 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-gcc5-remove-inline.patch" # bug 571004
if use vanilla; then
rm -f "${WORKDIR}"/patch/[1-6]*.patch || die
fi
diff --git a/net-irc/eggdrop/files/eggdrop-1.6.21-fix-gcc5-remove-inline.patch b/net-irc/eggdrop/files/eggdrop-1.6.21-fix-gcc5-remove-inline.patch
new file mode 100644
index 000000000000..f7bcd8b80bca
--- /dev/null
+++ b/net-irc/eggdrop/files/eggdrop-1.6.21-fix-gcc5-remove-inline.patch
@@ -0,0 +1,52 @@
+diff --git a/src/net.c b/src/net.c
+index 68c245c..e48fb76 100644
+--- a/src/net.c
++++ b/src/net.c
+@@ -564,7 +564,7 @@ int open_address_listen(IP addr, int *port)
+ /* Returns a socket number for a listening socket that will accept any
+ * connection -- port # is returned in port
+ */
+-inline int open_listen(int *port)
++int open_listen(int *port)
+ {
+ return open_address_listen(myip[0] ? getmyip() : INADDR_ANY, port);
+ }
+diff --git a/src/proto.h b/src/proto.h
+index 117347e..e80e30b 100644
+--- a/src/proto.h
++++ b/src/proto.h
+@@ -271,7 +271,7 @@ int getsock(int);
+ void killsock(int);
+ void killtclsock(int);
+ int answer(int, char *, unsigned long *, unsigned short *, int);
+-inline int open_listen(int *);
++int open_listen(int *);
+ int open_address_listen(IP addr, int *);
+ int open_telnet(char *, int);
+ int open_telnet_dcc(int, char *, char *);
+diff --git a/src/tclhash.c b/src/tclhash.c
+index 822f920..7281ceb 100644
+--- a/src/tclhash.c
++++ b/src/tclhash.c
+@@ -109,7 +109,7 @@ static inline void tcl_bind_list_delete(tcl_bind_list_t *tl)
+ nfree(tl);
+ }
+
+-inline void garbage_collect_tclhash(void)
++void garbage_collect_tclhash(void)
+ {
+ tcl_bind_list_t *tl, *tl_next, *tl_prev;
+ tcl_bind_mask_t *tm, *tm_next, *tm_prev;
+diff --git a/src/tclhash.h b/src/tclhash.h
+index 4069014..3bd85a7 100644
+--- a/src/tclhash.h
++++ b/src/tclhash.h
+@@ -75,7 +75,7 @@ typedef struct tcl_bind_list_b {
+
+ #ifndef MAKING_MODS
+
+-inline void garbage_collect_tclhash(void);
++void garbage_collect_tclhash(void);
+
+ void init_bind(void);
+ void kill_bind(void);