summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Vinson <nvinson234@gmail.com>2016-10-15 13:24:12 -0700
committerDavid Seifert <soap@gentoo.org>2016-10-16 19:24:04 +0200
commit9c77065a52897026dc3cd4c16e8eec9273befc5c (patch)
tree31b9a683c10169ab9154fcf3c6199ccf002e8f5e /net-irc/hexchat/hexchat-9999.ebuild
parentnet-misc/connman: add keepdir call (diff)
downloadgentoo-9c77065a52897026dc3cd4c16e8eec9273befc5c.tar.gz
gentoo-9c77065a52897026dc3cd4c16e8eec9273befc5c.tar.bz2
gentoo-9c77065a52897026dc3cd4c16e8eec9273befc5c.zip
net-irc/hexchat: fix libgdiplus.so & Werror errors
Fixes the System.DllNotFounException: libgdiplus.so error when the theme-manager USE flag is set. The problem is that only mono[minimal] is buildable right now, so mono[-minimal] does not work. However, mono[minimal] does not pull in libgdiplus.so. Therefore, the "fix" is to pull in libgdiplus as a dependency if the user is using mono[minimal]. Unfortunately, this doesn't fix the mono[-minimal] use case. Additionally, removes all Werror* flags from configure.ac. Gentoo-bug: 578290 Gentoo-bug: 597126 Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2563 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-irc/hexchat/hexchat-9999.ebuild')
-rw-r--r--net-irc/hexchat/hexchat-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-irc/hexchat/hexchat-9999.ebuild b/net-irc/hexchat/hexchat-9999.ebuild
index 530b1572184d..21b0714eae56 100644
--- a/net-irc/hexchat/hexchat-9999.ebuild
+++ b/net-irc/hexchat/hexchat-9999.ebuild
@@ -40,7 +40,13 @@ COMMON_DEPEND="dev-libs/glib:2
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
)
- theme-manager? ( dev-lang/mono )"
+ theme-manager? (
+ || (
+ ( dev-lang/mono[minimal] dev-dotnet/libgdiplus )
+ dev-lang/mono[-minimal]
+ )
+ )"
+
RDEPEND="${COMMON_DEPEND}
spell? ( app-text/enchant )"
DEPEND="${COMMON_DEPEND}