summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWade Cline <wadecline@hotmail.com>2021-12-31 19:19:42 -0800
committerFlorian Schmaus <flow@gentoo.org>2022-01-03 19:44:15 +0100
commit87e8bb4372a10477bbda61a459cbd185e1e72e55 (patch)
tree1501debad25215c056655bd29c1bc4ba7151f842 /net-irc/inspircd
parentnet-wireless/bluez-tools: remove old version (diff)
downloadgentoo-87e8bb4372a10477bbda61a459cbd185e1e72e55.tar.gz
gentoo-87e8bb4372a10477bbda61a459cbd185e1e72e55.tar.bz2
gentoo-87e8bb4372a10477bbda61a459cbd185e1e72e55.zip
net-irc/inspircd: Add 3.12.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Wade Cline <wadecline@hotmail.com> Closes: https://github.com/gentoo/gentoo/pull/23609 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-irc/inspircd')
-rw-r--r--net-irc/inspircd/Manifest2
-rw-r--r--net-irc/inspircd/inspircd-3.12.0.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/net-irc/inspircd/Manifest b/net-irc/inspircd/Manifest
index 91e291f50d89..df29aae4e49e 100644
--- a/net-irc/inspircd/Manifest
+++ b/net-irc/inspircd/Manifest
@@ -1,2 +1,4 @@
DIST inspircd-3.11.0-fix-path-builds.patch.bz2 4564 BLAKE2B 5414c6bff651f179bb7f214198d13c08ce1e92b6946729d617a56a2dd451a239520bc946823603b2e3ab0a78577f077c1d566bfa6771d6c9866ef5249269653c SHA512 92feddfa23acac2f1813539f9fae0e1c6c7332565c5d63df02e6f800b4457ed1ac1eff4f3aee8fb155dbae5b6d1d16536b435734549f740ae294382330837d5c
DIST inspircd-3.11.0.tar.gz 859767 BLAKE2B a0924d302577dcb471e22c0df21b7259c5b68b1ee2080233c31e84bc5cf8c32fbe134a359bf4d7f7541f512e078a9e75717df2dc7178670b3e3d7c7dfb2930b7 SHA512 59a277de041f1b0d44204c36190b6bd728f981997ba377f5bf9b7745fce122271e3df35223ff11d8d31d70f1f378977ea6603963ff2bb1a4fbaac958903b0da3
+DIST inspircd-3.12.0-fix-path-builds.patch.bz2 4570 BLAKE2B 2c2cea615f9e170c249868a60dcf698ba130b33e6e0553bb8c3070698332e643f3d58fc823fe92621e5498c8606b8334afe1536c9772a24f389010a93b72bc09 SHA512 e20171d6c94c163c414c0aa2a02a22ec2de02ec20a00542ada0181abc46e229f7e9d9108b88895a1ad6134b72e3fdab6e80b6c6b33e10b8be73f3a28130c0adb
+DIST inspircd-3.12.0.tar.gz 864630 BLAKE2B eb8fc009347777bdd1e1b119465a6e9f7b6f563c855607905ae256dd0f433d460872d185d2b17ca5033dad7fc07d1e049ce714bf92b91033e5157f796c1451ed SHA512 b8ad5bef5c4ea493bb77976cf75861efb445792696b536eab875c7c5e1a5fa679a5ad48c73a2bcb448871b4398f8370cde326abf389fc21db7e5fd24cfcdca59
diff --git a/net-irc/inspircd/inspircd-3.12.0.ebuild b/net-irc/inspircd/inspircd-3.12.0.ebuild
new file mode 100644
index 000000000000..ffef87177d73
--- /dev/null
+++ b/net-irc/inspircd/inspircd-3.12.0.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Inspire IRCd - The Stable, High-Performance Modular IRCd"
+HOMEPAGE="https://www.inspircd.org/"
+SRC_URI="https://github.com/inspircd/inspircd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://github.com/clinew/gentoo-distfiles/raw/master/inspircd-${PV}-fix-path-builds.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug gnutls ldap maxminddb mbedtls mysql pcre postgres re2 regex-posix regex-stdlib sqlite ssl sslrehashsignal tre"
+
+RDEPEND="
+ acct-group/inspircd
+ acct-user/inspircd
+ dev-lang/perl
+ gnutls? ( net-libs/gnutls:= dev-libs/libgcrypt:0 )
+ ldap? ( net-nds/openldap )
+ maxminddb? ( dev-libs/libmaxminddb )
+ mbedtls? ( net-libs/mbedtls:= )
+ mysql? ( dev-db/mysql-connector-c:= )
+ pcre? ( dev-libs/libpcre )
+ postgres? ( dev-db/postgresql:= )
+ re2? ( dev-libs/re2:= )
+ sqlite? ( >=dev-db/sqlite-3.0 )
+ ssl? ( dev-libs/openssl:= )
+ tre? ( dev-libs/tre )"
+DEPEND="${RDEPEND}"
+
+DOCS=( docs/. )
+PATCHES=( "${WORKDIR}"/${PF}-fix-path-builds.patch )
+
+src_prepare() {
+ default
+
+ # Patch the inspircd launcher with the inspircd user
+ sed -i -e "s/@UID@/${PN}/" "make/template/${PN}" || die
+}
+
+src_configure() {
+ local extras=""
+
+ use gnutls && extras+="m_ssl_gnutls.cpp,"
+ use ldap && extras+="m_ldap.cpp,"
+ use maxminddb && extras+="m_geo_maxmind.cpp,"
+ use mbedtls && extras+="m_ssl_mbedtls.cpp,"
+ use mysql && extras+="m_mysql.cpp,"
+ use pcre && extras+="m_regex_pcre.cpp,"
+ use postgres && extras+="m_pgsql.cpp,"
+ use re2 && extras+="m_regex_re2.cpp,"
+ use regex-posix && extras+="m_regex_posix.cpp,"
+ use regex-stdlib && extras+="m_regex_stdlib.cpp,"
+ use sqlite && extras+="m_sqlite3.cpp,"
+ use ssl && extras+="m_ssl_openssl.cpp,"
+ use sslrehashsignal && extras+="m_sslrehashsignal.cpp,"
+ use tre && extras+="m_regex_tre.cpp,"
+
+ # The first configuration run enables certain "extra" InspIRCd
+ # modules, the second run generates the actual makefile.
+ if [[ -n "${extras}" ]]; then
+ ./configure --disable-interactive --enable-extras=${extras%,}
+ fi
+
+ local myconf=(
+ --disable-interactive
+ --disable-auto-extras
+ --prefix="/usr/$(get_libdir)/${PN}"
+ --config-dir="/etc/${PN}"
+ --data-dir="/var/lib/${PN}/data"
+ --log-dir="/var/log/${PN}"
+ --binary-dir="/usr/bin"
+ --module-dir="/usr/$(get_libdir)/${PN}/modules"
+ --manual-dir="/usr/share/man")
+ CXX="$(tc-getCXX)" ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CXXFLAGS="${CXXFLAGS}" $(usex debug 'INSPIRCD_DEBUG=2' '') INSPIRCD_VERBOSE=1
+}
+
+src_install() {
+ default
+
+ insinto "/usr/include/${PN}"
+ doins -r include/.
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ keepdir "/var/log/${PN}"
+
+ diropts -o"${PN}" -g"${PN}" -m0700
+ keepdir "/var/lib/${PN}/data"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You will find example configuration files under "
+ elog "/usr/share/doc/${PN}"
+ elog "Read the ${PN}.conf.example file carefully before "
+ elog "starting the service."
+ fi
+ local pv
+ for pv in ${REPLACING_VERSIONS}; do
+ if ver_test "${pv}" -lt "3.0.0"; then
+ elog "Version 3.0 is a major upgrade which contains breaking"
+ elog "changes. You will need to update your configuration files."
+ elog "See: https://docs.inspircd.org/3/configuration-changes"
+ fi
+ done
+}