summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-02-06 07:37:26 -0600
committerBen Kohler <bkohler@gentoo.org>2019-02-06 07:38:53 -0600
commitaf3b54acb0a34f1bf62a6083918f9702912ad7c4 (patch)
treee7182b6835734b84bea84d3ac43378e19df28278 /net-irc/ircii
parentapp-admin/mcelog: bump to 162 (diff)
downloadgentoo-af3b54acb0a34f1bf62a6083918f9702912ad7c4.tar.gz
gentoo-af3b54acb0a34f1bf62a6083918f9702912ad7c4.tar.bz2
gentoo-af3b54acb0a34f1bf62a6083918f9702912ad7c4.zip
net-irc/ircii: bump to 20190117
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-irc/ircii')
-rw-r--r--net-irc/ircii/Manifest1
-rw-r--r--net-irc/ircii/ircii-20190117.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-irc/ircii/Manifest b/net-irc/ircii/Manifest
index 35bbc28664bd..fa58d1b970e3 100644
--- a/net-irc/ircii/Manifest
+++ b/net-irc/ircii/Manifest
@@ -1,3 +1,4 @@
DIST ircii-20110228.tar.bz2 558483 BLAKE2B 52c83503bf258aaf27635d5ac525da61894486681069f7ff56d571f387567ba964976770b1a1e647aae1b0b18416ccc37c7498bc7cfca5c1c26247796638654e SHA512 df27f098ad9c134335b7d97a25a07ef5fd9d14063b2e079a707a472d2582a1451d7697f3123508296c76afdb78257ad6dc358a2ec5af584ab53872c765b01782
DIST ircii-20111115.tar.bz2 555731 BLAKE2B 8715b5d84cbca98005b3c3bf426f632737be2f4a121f673c3d7d76a5f4204c603594779c15a9fe5e886fb33b96cfc149f690508b546752cd4f7c4f9ad8aaf36a SHA512 6f282debbd27865414a2ef9148b23373f83a051b2917432d9fdc2f153c111f8e592286d42a5ad34fd0cdc155e39938094e140910fbf38be494e3ed3da4cd0b6e
DIST ircii-20170704.tar.bz2 596535 BLAKE2B 780b9bc74e80d622df3686d3234ce69c62c0d9ae43322addfc545de76854ba30ec25546921cff449556f9e6b14b7dc00f3b15437789bea8bfa9b3df44d5b7e6c SHA512 a0cdc5603fab040fa2f7d2b3d7a564e9eeac4b402329cba5c6f1a97aa6e587a53ffc4141420dde97dc2cadf22581e74058a0357c6b4b0d0b03f5dea7fa8cbc3a
+DIST ircii-20190117.tar.bz2 606327 BLAKE2B f7ee5c98f6106f07fec8feb0840aba87a052e5927c5e591f34ea28a9a017fb64c711983e472ae001465cbe29b6b9d88ab65d67c4bb303b9e01dde853aba66bf4 SHA512 08ca96cd62bae35245b40791c8588752b96136b53e5c9434d0f7976d03841fca80e8c83cf8608aad79c381820b06e00167447c6dc0c6294c6b3dfd91a9fdb6d4
diff --git a/net-irc/ircii/ircii-20190117.ebuild b/net-irc/ircii/ircii-20190117.ebuild
new file mode 100644
index 000000000000..03366ecd3a1a
--- /dev/null
+++ b/net-irc/ircii/ircii-20190117.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
+SRC_URI="https://ircii.warped.com/${P}.tar.bz2
+ https://ircii.warped.com/old/${P}.tar.bz2"
+HOMEPAGE="http://eterna.com.au/ircii/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="ipv6"
+
+DEPEND="sys-libs/ncurses:0=
+ virtual/libiconv"
+# This and irc-client both install /usr/bin/irc #247987
+RDEPEND="${DEPEND}
+ !net-irc/irc-client"
+
+PATCHES=( "${FILESDIR}/${PN}-manpage-path.patch" )
+
+src_configure() {
+ tc-export CC
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc ChangeLog INSTALL NEWS README \
+ doc/Copyright doc/crypto doc/VERSIONS doc/ctcp
+}