summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-08-16 00:02:48 +1200
committerKent Fredric <kentnl@gentoo.org>2019-08-16 00:04:25 +1200
commit27eac7b8fc3da678ed259599e7bdd4ad2d3180a9 (patch)
tree0a8107ba07aa1801b340ca2168eb4384e9a49385 /net-irc/ircmap/ircmap-0.99-r1.ebuild
parentx11-libs/pango: fix CVE-2019-1010238 (diff)
downloadgentoo-27eac7b8fc3da678ed259599e7bdd4ad2d3180a9.tar.gz
gentoo-27eac7b8fc3da678ed259599e7bdd4ad2d3180a9.tar.bz2
gentoo-27eac7b8fc3da678ed259599e7bdd4ad2d3180a9.zip
net-irc/ircmap: Fix swathe of QA issues
- Using the perl privlib trick was both wrong, and unneeded, as the modules in question are inherently 'private to this package' and are not intended for general use by other tools on CPAN. - Subsequently, this changes to stashing them in /usr/share/ircmap - Upstreams homepage has moved - Upstreams existing SRC_URI's were unresolvable - Added conversion of upstreams tarball from "ircmap.tar.gz" to "ircmap-0.99.tar.gz". Upstream don't actually version their releases properly it seems, but its been so long since a release its hard to imagine there will be more. - Convert to EAPI7, though its probably incomplete and this probably needs some EPREFIX/DEPEND/BDEPEND/BROOT love, but eh. - Keyworded ~amd64 as it mostly appears to work for me, but no way to test functionality. - --straight-to-stable'd simply because these are all QA fixups, and no point waiting a month to silence the warnings. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'net-irc/ircmap/ircmap-0.99-r1.ebuild')
-rw-r--r--net-irc/ircmap/ircmap-0.99-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-irc/ircmap/ircmap-0.99-r1.ebuild b/net-irc/ircmap/ircmap-0.99-r1.ebuild
new file mode 100644
index 000000000000..05d3f133fb3d
--- /dev/null
+++ b/net-irc/ircmap/ircmap-0.99-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Scripts to treate diagrams of IRC networks using the LINKS command"
+HOMEPAGE="http://pasky.or.cz/irc/"
+SRC_URI="http://pasky.or.cz/irc/${PN}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="
+ media-gfx/graphviz
+ dev-lang/perl
+"
+BDEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+"
+DEPEND=""
+
+S="${WORKDIR}"/${PN}
+
+src_compile() {
+ sed -i \
+ -e "s:/home/pasky/ircmap:/usr/share/ircmap:" \
+ {ircmapC,ircmapR-aa,ircmapR-gvdot,ircmapR-ircnet,ircmapS}.pl
+}
+
+src_install () {
+ dodoc README
+ dobin ircmapS.pl ircmapC.pl ircmapR-aa.pl ircmapR-gvdot.pl ircmapR-ircnet.pl
+
+ insinto /usr/share/ircmap
+ doins IHash.pm
+}
+
+pkg_postinst() {
+ elog 'Usage:'
+ elog 'IRCSERVER="irc.generic.com ircmapS.pl [-options parameters] \'
+ elog '| tee /tmp/sendmethisifitdoesntwork \'
+ elog '| ircmapC.pl \'
+ elog '| tee /tmp/coredump \'
+ elog '| ircmapR-aa.pl > ${IRCSERVER}.txt'
+ elog ''
+ elog 'cat /tmp/coredump \'
+ elog '| ircmapR-gvdot.pl \'
+ elog '| dot -Tgif -o ${IRCSERVER}.gif'
+}