summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-02-14 23:56:48 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-02-16 00:11:47 +0100
commitefb3647a77f0436c4bf4008b9f97aabf53212fdf (patch)
treee4b95a8a27547c755592e02490c6f4295eb4233a /net-irc/ircstats/ircstats-1.2.ebuild
parentnet-news/quiterss: Disable build-time git repo detection (diff)
downloadgentoo-efb3647a77f0436c4bf4008b9f97aabf53212fdf.tar.gz
gentoo-efb3647a77f0436c4bf4008b9f97aabf53212fdf.tar.bz2
gentoo-efb3647a77f0436c4bf4008b9f97aabf53212fdf.zip
net-irc/ircstats: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-irc/ircstats/ircstats-1.2.ebuild')
-rw-r--r--net-irc/ircstats/ircstats-1.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/ircstats/ircstats-1.2.ebuild b/net-irc/ircstats/ircstats-1.2.ebuild
new file mode 100644
index 000000000000..d50345072372
--- /dev/null
+++ b/net-irc/ircstats/ircstats-1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+MY_P="IRCStats-${PV}"
+
+DESCRIPTION="IRCStats is a Linux log analyzer"
+HOMEPAGE="https://humdi.net/ircstats/"
+SRC_URI="https://humdi.net/ircstats/${MY_P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ default
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ircstats
+ insinto /usr/share/ircstats
+ doins -r html languages colors
+ dodoc CHANGES README TODO ircstats.cfg
+}
+
+pkg_postinst() {
+ elog "The IRCStats files have been installed in /usr/share/ircstats"
+ elog "You can find an example ircstats.cfg in /usr/share/doc/${PF}"
+}