summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2021-05-19 16:41:20 +0300
committerSergey Popov <pinkbyte@gentoo.org>2021-05-19 16:43:31 +0300
commit185c49ba6c1ee3ffa79ccb4a4f8f6894eab8608f (patch)
tree166155ee0468bfc4f2de08e32ce2375529920a20 /net-irc/iroffer-dinoex/iroffer-dinoex-3.32-r1.ebuild
parentacct-user/iroffer: new user (187) (diff)
downloadgentoo-185c49ba6c1ee3ffa79ccb4a4f8f6894eab8608f.tar.gz
gentoo-185c49ba6c1ee3ffa79ccb4a4f8f6894eab8608f.tar.bz2
gentoo-185c49ba6c1ee3ffa79ccb4a4f8f6894eab8608f.zip
net-irc/iroffer-dinoex-3.32-r1: revision bump
Bump EAPI to 7, migrate away from user eclass Drop old revision Closes: https://bugs.gentoo.org/781392 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'net-irc/iroffer-dinoex/iroffer-dinoex-3.32-r1.ebuild')
-rw-r--r--net-irc/iroffer-dinoex/iroffer-dinoex-3.32-r1.ebuild118
1 files changed, 118 insertions, 0 deletions
diff --git a/net-irc/iroffer-dinoex/iroffer-dinoex-3.32-r1.ebuild b/net-irc/iroffer-dinoex/iroffer-dinoex-3.32-r1.ebuild
new file mode 100644
index 000000000000..8de5d34ef91b
--- /dev/null
+++ b/net-irc/iroffer-dinoex/iroffer-dinoex-3.32-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PLOCALES="de en fr it"
+PLOCALE_BACKUP="en"
+
+inherit l10n toolchain-funcs
+
+DESCRIPTION="IRC fileserver using DCC"
+HOMEPAGE="http://iroffer.dinoex.net/"
+SRC_URI="http://iroffer.dinoex.net/${P}.tar.gz
+ http://iroffer.dinoex.net/HISTORY/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+admin +blowfish +chroot curl debug geoip gnutls +http kqueue +memsave ruby ssl +telnet upnp"
+
+REQUIRED_USE="
+ admin? ( http )
+ gnutls? ( ssl )
+"
+
+RDEPEND="acct-user/iroffer
+ chroot? ( dev-libs/nss )
+ curl? (
+ net-misc/curl[ssl?]
+ gnutls? ( net-misc/curl[curl_ssl_gnutls] )
+ !gnutls? ( ssl? ( net-misc/curl[curl_ssl_openssl] ) )
+ )
+ geoip? ( dev-libs/geoip )
+ gnutls? ( net-libs/gnutls )
+ ruby? ( dev-lang/ruby:* )
+ ssl? ( !gnutls? ( dev-libs/openssl:0= ) )"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-3.31-config.patch"
+ eapply "${FILESDIR}/${PN}-Werror.patch"
+
+ eapply_user
+
+ l10n_find_plocales_changes "" 'help-admin-' '.txt'
+}
+
+do_configure() {
+ echo ./Configure $*
+ ./Configure $* || die "configure phase failed"
+}
+
+src_configure() {
+ do_configure \
+ PREFIX="${EPREFIX}/usr" \
+ CC="$(tc-getCC)" \
+ $(usex debug '-profiling' '' '' '')\
+ $(usex debug '-debug' '' '' '')\
+ $(usex geoip '-geoip' '' '' '')\
+ $(usex chroot '' '-no-chroot' '' '')\
+ $(usex curl '-curl' '' '' '' )\
+ $(usex gnutls '-tls' '' '' '' '')\
+ $(usex upnp '-upnp' '' '' '')\
+ $(usex ruby '-ruby' '' '' '')\
+ $(usex kqueue '-kqueue' '' '' '')\
+ $(usex blowfish '' '-no-blowfish' '' '')\
+ $(usex ssl '' '-no-openssl' '' '')\
+ $(usex http '' '-no-http' '' '')\
+ $(usex admin '' '-no-admin' '' '')\
+ $(usex telnet '' '-no-telnet' '' '')\
+ $(usex memsave '' '-no-memsave' '' '')
+}
+
+src_compile() {
+ # TODO: default compile targets always include chrooted target, which is not good
+ emake CC="$(tc-getCC)" $(l10n_get_locales)
+}
+
+myloc() {
+ emake DESTDIR="${D}" install-${1}
+
+ dodoc help-admin-${1}.txt
+ use http && dodoc doc/INSTALL-linux-${1}.html
+
+ insinto /etc/${PN}
+ case ${1} in
+ "de")
+ doins beispiel.config;;
+ "fr")
+ doins exemple.config;;
+ *)
+ doins sample.config;;
+ esac
+}
+
+src_install() {
+ l10n_for_each_locale_do myloc
+
+ dodoc README* THANKS TODO
+ doman iroffer.1 xdcc.7
+
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+ newconfd "${FILESDIR}/${PN}.conf" ${PN}
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ if use ruby; then
+ insinto /usr/share/${PN}
+ doins ruby-sample.rb
+ fi
+
+ if use http; then
+ insinto /usr/share/${PN}/htdocs
+ doins htdocs/*
+ fi
+}