summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2021-06-20 12:21:24 +1000
committerSam Jorna <wraeth@gentoo.org>2021-06-20 12:21:24 +1000
commit4b0526594b6e074e446ee00640aeaea48aad936d (patch)
tree19a0233704345e9a78e107e20a44d2b711677bda /net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210610.ebuild
parentnet-irc/limnoria-plugins-progval: bump to 20210616 (diff)
downloadgentoo-4b0526594b6e074e446ee00640aeaea48aad936d.tar.gz
gentoo-4b0526594b6e074e446ee00640aeaea48aad936d.tar.bz2
gentoo-4b0526594b6e074e446ee00640aeaea48aad936d.zip
net-irc/limnoria-plugins-jlu5: bump to 20200105_p20210610
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam Jorna <wraeth@gentoo.org>
Diffstat (limited to 'net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210610.ebuild')
-rw-r--r--net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210610.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210610.ebuild b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210610.ebuild
new file mode 100644
index 000000000000..09cf4219cae2
--- /dev/null
+++ b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210610.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="3ea070a8036e7262c6fdbd39bf2c7d6407a20f7c"
+
+DESCRIPTION="A collection of plugins for the Limnoria IRC bot."
+HOMEPAGE="https://github.com/jlu5/SupyPlugins"
+SRC_URI="https://github.com/jlu5/SupyPlugins/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="
+ net-irc/limnoria
+ dev-python/beautifulsoup
+"
+
+DOCS=(
+ "README.md"
+ "requirements.txt"
+)
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/jlu5
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before these plugins can be used, your bot will need to be told where to"
+ elog "load them from. To do this, add /usr/share/limnoria-extra-plugins/jlu5 when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/jlu5"
+}