summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2021-05-30 15:00:57 +1000
committerSam Jorna <wraeth@gentoo.org>2021-05-30 15:00:57 +1000
commit597992a7972a14d4636bd68ad3cad278d96e6248 (patch)
tree5d71735eb66f776388fd80e61423f439c75bcad8 /net-irc/limnoria-plugins-jlu5
parentnet-irc/limnoria: drop old (diff)
downloadgentoo-597992a7972a14d4636bd68ad3cad278d96e6248.tar.gz
gentoo-597992a7972a14d4636bd68ad3cad278d96e6248.tar.bz2
gentoo-597992a7972a14d4636bd68ad3cad278d96e6248.zip
net-irc/limnoria-plugins-jlu5: bump to 20210530
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Sam Jorna <wraeth@gentoo.org>
Diffstat (limited to 'net-irc/limnoria-plugins-jlu5')
-rw-r--r--net-irc/limnoria-plugins-jlu5/Manifest1
-rw-r--r--net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-jlu5/Manifest b/net-irc/limnoria-plugins-jlu5/Manifest
index c4db5f09be2d..5c680d297446 100644
--- a/net-irc/limnoria-plugins-jlu5/Manifest
+++ b/net-irc/limnoria-plugins-jlu5/Manifest
@@ -1 +1,2 @@
DIST limnoria-plugins-jlu5-20200105_p20210305.tar.gz 95273 BLAKE2B cfdea4fadbfa050c56dd0f307cf43506391d0e35e31b46a649aaf70cfd4c8979e14192d66af408e33b4cc8c0e1917fdb5d2d2cf86029a9b6b204a56936c22b76 SHA512 b031cd9be28989499ed063e8bd2af8079415075710be4dcfd73051eb325e2e321a1589c6d7adc69a0e5ce8b4a0a96c4bb6b1108c4ee479bc074b70738727dd64
+DIST limnoria-plugins-jlu5-20200105_p20210530.tar.gz 99973 BLAKE2B a67e53a75a99ed406782cc74cc93c19ad4e7298a4e9b47781559609c7ed77fed157febb646147254f0fb8e73627f1fdfa23e80cd1893d394c779ee54f93357d9 SHA512 03f537b7100a747c408a754d368e679ceea313747cd27dea9ca26cc7d3cf9b4319faf37656b0c7b5134d8ca6a94a9bbf4c345aa8015bcab2a99648d38dddc272
diff --git a/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild
new file mode 100644
index 000000000000..9d1174845dfb
--- /dev/null
+++ b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="7e695c00dfb665a16ff4f1d66ad3deb4598ea029"
+
+DESCRIPTION="A collection of plugins for the Limnoria IRC bot."
+HOMEPAGE="https://github.com/jlu5/SupyPlugins"
+SRC_URI="https://github.com/jlu5/SupyPlugins/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="
+ net-irc/limnoria
+ dev-python/beautifulsoup
+"
+
+DOCS=(
+ "README.md"
+ "requirements.txt"
+)
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/jlu5
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before these plugins can be used, your bot will need to be told where to"
+ elog "load them from. To do this, add /usr/share/limnoria-extra-plugins/jlu5 when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/jlu5"
+}