summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-04 21:50:39 +0100
committerSam James <sam@gentoo.org>2022-04-04 21:50:50 +0100
commitfdcf296d108e3bfa43a8aff8b8bad4eb13fff277 (patch)
tree80914a7d099028e9973e27d1778f80b916d56b0d /net-irc/quassel
parentnet-irc/quassel: fix unused warnings (diff)
downloadgentoo-fdcf296d108e3bfa43a8aff8b8bad4eb13fff277.tar.gz
gentoo-fdcf296d108e3bfa43a8aff8b8bad4eb13fff277.tar.bz2
gentoo-fdcf296d108e3bfa43a8aff8b8bad4eb13fff277.zip
net-irc/quassel: switch to USE=gui
As per QA policy. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc/quassel')
-rw-r--r--net-irc/quassel/quassel-0.14.0-r1.ebuild14
-rw-r--r--net-irc/quassel/quassel-9999.ebuild14
2 files changed, 14 insertions, 14 deletions
diff --git a/net-irc/quassel/quassel-0.14.0-r1.ebuild b/net-irc/quassel/quassel-0.14.0-r1.ebuild
index d6aa1c14902d..41f4015cd383 100644
--- a/net-irc/quassel/quassel-0.14.0-r1.ebuild
+++ b/net-irc/quassel/quassel-0.14.0-r1.ebuild
@@ -24,7 +24,7 @@ HOMEPAGE="https://quassel-irc.org/"
LICENSE="GPL-3"
SLOT="0"
-IUSE="bundled-icons crypt +dbus debug kde ldap monolithic oxygen postgres +server snorenotify spell syslog test urlpreview X"
+IUSE="bundled-icons crypt +dbus debug gui kde ldap monolithic oxygen postgres +server snorenotify spell syslog test urlpreview"
RESTRICT="!test? ( test )"
SERVER_DEPEND="acct-group/quassel
@@ -68,7 +68,7 @@ DEPEND=">=dev-libs/boost-1.54:=
)
!monolithic? (
server? ( ${SERVER_DEPEND} )
- X? ( ${GUI_DEPEND} )
+ gui? ( ${GUI_DEPEND} )
)"
RDEPEND="${DEPEND}"
BDEPEND="dev-qt/linguist-tools:5
@@ -78,13 +78,13 @@ DEPEND+=" test? ( dev-cpp/gtest dev-qt/qttest )"
DOCS=( AUTHORS ChangeLog README.md )
-REQUIRED_USE="|| ( X server monolithic )
+REQUIRED_USE="|| ( gui server monolithic )
crypt? ( || ( server monolithic ) )
kde? ( dbus spell )
ldap? ( || ( server monolithic ) )
postgres? ( || ( server monolithic ) )
- snorenotify? ( || ( X monolithic ) )
- spell? ( || ( X monolithic ) )
+ snorenotify? ( || ( gui monolithic ) )
+ spell? ( || ( gui monolithic ) )
syslog? ( || ( server monolithic ) )"
PATCHES=(
@@ -105,10 +105,10 @@ src_configure() {
-DWITH_OXYGEN_ICONS=$(usex oxygen)
-DWANT_CORE=$(usex server)
-DWITH_WEBENGINE=$(usex urlpreview)
- -DWANT_QTCLIENT=$(usex X)
+ -DWANT_QTCLIENT=$(usex gui)
)
- if use X || use monolithic ; then
+ if use gui || use monolithic ; then
# We can't always pass these (avoid "unused" warning)
# bug #830708
mycmakeargs+=(
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
index b00f930b98b5..ebbf78af53cb 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -24,7 +24,7 @@ HOMEPAGE="https://quassel-irc.org/"
LICENSE="GPL-3"
SLOT="0"
-IUSE="bundled-icons crypt +dbus debug kde ldap monolithic oxygen postgres +server snorenotify spell syslog test urlpreview X"
+IUSE="bundled-icons crypt +dbus debug gui kde ldap monolithic oxygen postgres +server snorenotify spell syslog test urlpreview"
RESTRICT="!test? ( test )"
SERVER_DEPEND="acct-group/quassel
@@ -68,7 +68,7 @@ DEPEND=">=dev-libs/boost-1.54:=
)
!monolithic? (
server? ( ${SERVER_DEPEND} )
- X? ( ${GUI_DEPEND} )
+ gui? ( ${GUI_DEPEND} )
)"
RDEPEND="${DEPEND}"
BDEPEND="dev-qt/linguist-tools:5
@@ -78,13 +78,13 @@ DEPEND+=" test? ( dev-cpp/gtest dev-qt/qttest )"
DOCS=( AUTHORS ChangeLog README.md )
-REQUIRED_USE="|| ( X server monolithic )
+REQUIRED_USE="|| ( gui server monolithic )
crypt? ( || ( server monolithic ) )
kde? ( dbus spell )
ldap? ( || ( server monolithic ) )
postgres? ( || ( server monolithic ) )
- snorenotify? ( || ( X monolithic ) )
- spell? ( || ( X monolithic ) )
+ snorenotify? ( || ( gui monolithic ) )
+ spell? ( || ( gui monolithic ) )
syslog? ( || ( server monolithic ) )"
src_configure() {
@@ -101,10 +101,10 @@ src_configure() {
-DWITH_OXYGEN_ICONS=$(usex oxygen)
-DWANT_CORE=$(usex server)
-DWITH_WEBENGINE=$(usex urlpreview)
- -DWANT_QTCLIENT=$(usex X)
+ -DWANT_QTCLIENT=$(usex gui)
)
- if use X || use monolithic ; then
+ if use gui || use monolithic ; then
# We can't always pass these (avoid "unused" warning)
# bug #830708
mycmakeargs+=(