summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/telepathy-idle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/telepathy-idle')
-rw-r--r--net-irc/telepathy-idle/Manifest1
-rw-r--r--net-irc/telepathy-idle/metadata.xml7
-rw-r--r--net-irc/telepathy-idle/telepathy-idle-0.2.0.ebuild38
3 files changed, 46 insertions, 0 deletions
diff --git a/net-irc/telepathy-idle/Manifest b/net-irc/telepathy-idle/Manifest
new file mode 100644
index 000000000000..7b8bb38ed0f6
--- /dev/null
+++ b/net-irc/telepathy-idle/Manifest
@@ -0,0 +1 @@
+DIST telepathy-idle-0.2.0.tar.gz 566492 SHA256 3013ad4b38d14ee630b8cc8ada5e95ccaa849b9a6fe15d2eaf6d0717d76f2fab SHA512 f5e36afc3ab4b52eb865f2c1e6565b99011a7540fc1a7783d3bbd7bbf50bc671a2147df6bde646c82059a466cc1df9bdb10e2500db5b7bb06d57a989a75c261b WHIRLPOOL 3ffe7a8fd6b06533ea5fba40733fb42072639d13c084e536f5eacf2af3385bea39e3e0193cfd6a287a4437255acb43c6807121c0eda57a75d2eabd61bb3643fb
diff --git a/net-irc/telepathy-idle/metadata.xml b/net-irc/telepathy-idle/metadata.xml
new file mode 100644
index 000000000000..8185e919f205
--- /dev/null
+++ b/net-irc/telepathy-idle/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <herd>net-im</herd>
+ <longdescription>Telepathy connection manager featuring IRC protocol.</longdescription>
+</pkgmetadata>
diff --git a/net-irc/telepathy-idle/telepathy-idle-0.2.0.ebuild b/net-irc/telepathy-idle/telepathy-idle-0.2.0.ebuild
new file mode 100644
index 000000000000..af9c2a64daf2
--- /dev/null
+++ b/net-irc/telepathy-idle/telepathy-idle-0.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Full-featured IRC connection manager for Telepathy"
+HOMEPAGE="http://cgit.freedesktop.org/telepathy/telepathy-idle"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-linux"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.51
+ >=dev-libs/glib-2.32:2
+ >=net-libs/telepathy-glib-0.21[${PYTHON_USEDEP}]
+ sys-apps/dbus
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/twisted-words )
+"
+
+src_prepare() {
+ # Failed in 0.1.16 and code has not moved since october
+ # Upstream is working on 1.0
+ sed -e 's:connect/server-quit-ignore.py::' \
+ -e 's:connect/server-quit-noclose.py::' \
+ -i tests/twisted/Makefile.{am,in} || die
+}