summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2016-12-18 09:46:28 +0000
committerSam Jorna <wraeth@gentoo.org>2016-12-23 14:17:04 +1100
commitf79ca92e4ed00c58a880b2932b81469b56b54a3b (patch)
tree33a07f5266cced2747fadd90d287588033b3abc0 /net-irc/znc/znc-1.6.4.ebuild
parentnet-irc/znc: fix URI to support older releases (diff)
downloadgentoo-f79ca92e4ed00c58a880b2932b81469b56b54a3b.tar.gz
gentoo-f79ca92e4ed00c58a880b2932b81469b56b54a3b.tar.bz2
gentoo-f79ca92e4ed00c58a880b2932b81469b56b54a3b.zip
net-irc/znc: hide zlib and icu behind global USE-flags
Closes: #3156
Diffstat (limited to 'net-irc/znc/znc-1.6.4.ebuild')
-rw-r--r--net-irc/znc/znc-1.6.4.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-irc/znc/znc-1.6.4.ebuild b/net-irc/znc/znc-1.6.4.ebuild
index d7516baeefdb..f8a3449fa206 100644
--- a/net-irc/znc/znc-1.6.4.ebuild
+++ b/net-irc/znc/znc-1.6.4.ebuild
@@ -21,13 +21,12 @@ KEYWORDS="~amd64 ~arm ~x86"
HOMEPAGE="http://znc.in"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="daemon debug ipv6 libressl perl python ssl sasl tcl test"
+IUSE="daemon debug ipv6 icu libressl perl python ssl sasl tcl test zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
- dev-libs/icu:=
- sys-libs/zlib
+ icu? ( dev-libs/icu:= )
perl? ( >=dev-lang/perl-5.10:= )
python? ( ${PYTHON_DEPS} )
sasl? ( >=dev-libs/cyrus-sasl-2 )
@@ -36,6 +35,7 @@ RDEPEND="
libressl? ( dev-libs/libressl:0= )
)
tcl? ( dev-lang/tcl:0= )
+ zlib? ( sys-libs/zlib )
"
DEPEND="
${RDEPEND}
@@ -67,12 +67,14 @@ src_configure() {
econf \
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
$(use_enable debug) \
+ $(use_enable icu charset) \
$(use_enable ipv6) \
$(use_enable perl) \
$(use_enable python) \
$(use_enable sasl cyrus) \
$(use_enable ssl openssl) \
$(use_enable tcl) \
+ $(use_enable zlib) \
$(use_with test gtest "${WORKDIR}/googletest-release-${GTEST_VER}")
}