summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-20 21:47:08 +0000
committerMarek Szuba <marecki@gentoo.org>2020-12-20 21:50:00 +0000
commit05e7700d3d24a15e9cfb66174a3d1a04b3805c3b (patch)
tree87e4a949f9feb84d87626998f1bce8874abe231b /net-irc
parentnet-print/cups-filters: Stabilize 1.28.3 arm64, #759631 (diff)
downloadgentoo-05e7700d3d24a15e9cfb66174a3d1a04b3805c3b.tar.gz
gentoo-05e7700d3d24a15e9cfb66174a3d1a04b3805c3b.tar.bz2
gentoo-05e7700d3d24a15e9cfb66174a3d1a04b3805c3b.zip
net-irc/hexchat: migrate to lua-single.eclass
Both the latest release and the live ebuild. Uses Meson + allows the user to directly specify the name of the pkgconfig module to use - in short, pretty much as easy as it gets. Builds and installs fine even with 5.4, does officially support LuaJIT. Closes: https://bugs.gentoo.org/752810 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/hexchat/hexchat-2.14.3-r100.ebuild135
-rw-r--r--net-irc/hexchat/hexchat-9999.ebuild13
2 files changed, 143 insertions, 5 deletions
diff --git a/net-irc/hexchat/hexchat-2.14.3-r100.ebuild b/net-irc/hexchat/hexchat-2.14.3-r100.ebuild
new file mode 100644
index 000000000000..850dd84f2ac3
--- /dev/null
+++ b/net-irc/hexchat/hexchat-2.14.3-r100.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit lua-single meson mono-env python-single-r1 xdg
+
+DESCRIPTION="Graphical IRC client based on XChat"
+HOMEPAGE="https://hexchat.github.io/"
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://dl.hexchat.net/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+fi
+
+LICENSE="GPL-2 plugin-fishlim? ( MIT )"
+SLOT="0"
+IUSE="dbus debug +gtk libcanberra libnotify libproxy libressl lua perl plugin-checksum plugin-fishlim plugin-sysinfo python ssl theme-manager"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dbus? ( dev-libs/dbus-glib )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ )
+ libcanberra? ( media-libs/libcanberra )
+ libproxy? ( net-libs/libproxy )
+ libnotify? ( x11-libs/libnotify )
+ lua? ( ${LUA_DEPS} )
+ perl? ( dev-lang/perl:= )
+ plugin-sysinfo? ( sys-apps/pciutils )
+ python? ( ${PYTHON_DEPS} )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ theme-manager? (
+ || (
+ ( dev-lang/mono[minimal] dev-dotnet/libgdiplus )
+ dev-lang/mono[-minimal]
+ )
+ )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ app-arch/xz-utils
+ app-text/iso-codes
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+ use python && python-single-r1_pkg_setup
+ if use theme-manager ; then
+ mono-env_pkg_setup
+ export XDG_CACHE_HOME="${T}/.cache"
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dwith-gtk="$(usex gtk true false)"
+ -Dwith-text="$(usex gtk false true)"
+ -Dwith-ssl="$(usex ssl true false)"
+ -Dwith-plugin=true
+ -Dwith-dbus="$(usex dbus true false)"
+ -Dwith-libproxy="$(usex libproxy true false)"
+ -Dwith-libnotify="$(usex libnotify true false)"
+ -Dwith-libcanberra="$(usex libcanberra true false)"
+ -Dwith-theme-manager="$(usex theme-manager true false)"
+ -Ddbus-service-use-appid=false
+ -Dwith-checksum="$(usex plugin-checksum true false)"
+ -Dwith-fishlim="$(usex plugin-fishlim true false)"
+ -Dwith-lua="$(usex lua ${ELUA} false)"
+ -Dwith-perl="$(usex perl "${EPREFIX}"/usr/bin/perl false)"
+ -Dwith-python="$(usex python "${EPYTHON/.*}" false)"
+ -Dwith-sysinfo="$(usex plugin-sysinfo true false)"
+ -Dwith-appdata=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc readme.md
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_preinst() {
+ if use gtk ; then
+ xdg_pkg_preinst
+ fi
+}
+
+pkg_postinst() {
+ if use gtk ; then
+ xdg_pkg_postinst
+ else
+ elog "You have disabled the gtk USE flag. This means you don't have"
+ elog "the GTK-GUI for HexChat but only a text interface called \"hexchat-text\"."
+ fi
+
+ if use theme-manager ; then
+ elog "Themes are available at:"
+ elog " https://hexchat.github.io/themes.html"
+ fi
+
+ elog
+ elog "optional dependencies:"
+ elog " media-sound/sox (sound playback if you don't have libcanberra"
+ elog " enabled)"
+ elog " x11-plugins/hexchat-javascript (javascript support)"
+ elog " x11-themes/sound-theme-freedesktop (default BEEP sound,"
+ elog " needs libcanberra enabled)"
+}
+
+pkg_postrm() {
+ if use gtk ; then
+ xdg_pkg_postrm
+ fi
+}
diff --git a/net-irc/hexchat/hexchat-9999.ebuild b/net-irc/hexchat/hexchat-9999.ebuild
index 0a64b4be026b..850dd84f2ac3 100644
--- a/net-irc/hexchat/hexchat-9999.ebuild
+++ b/net-irc/hexchat/hexchat-9999.ebuild
@@ -3,9 +3,10 @@
EAPI=7
+LUA_COMPAT=( lua5-{1..4} luajit )
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit meson mono-env python-single-r1 xdg
+inherit lua-single meson mono-env python-single-r1 xdg
DESCRIPTION="Graphical IRC client based on XChat"
HOMEPAGE="https://hexchat.github.io/"
@@ -16,13 +17,14 @@ if [[ "${PV}" == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
else
SRC_URI="https://dl.hexchat.net/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
fi
LICENSE="GPL-2 plugin-fishlim? ( MIT )"
SLOT="0"
IUSE="dbus debug +gtk libcanberra libnotify libproxy libressl lua perl plugin-checksum plugin-fishlim plugin-sysinfo python ssl theme-manager"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
dev-libs/glib:2
@@ -36,7 +38,7 @@ RDEPEND="
libcanberra? ( media-libs/libcanberra )
libproxy? ( net-libs/libproxy )
libnotify? ( x11-libs/libnotify )
- lua? ( dev-lang/lua:0= )
+ lua? ( ${LUA_DEPS} )
perl? ( dev-lang/perl:= )
plugin-sysinfo? ( sys-apps/pciutils )
python? ( ${PYTHON_DEPS} )
@@ -61,6 +63,7 @@ BDEPEND="
"
pkg_setup() {
+ use lua && lua-single_pkg_setup
use python && python-single-r1_pkg_setup
if use theme-manager ; then
mono-env_pkg_setup
@@ -82,7 +85,7 @@ src_configure() {
-Ddbus-service-use-appid=false
-Dwith-checksum="$(usex plugin-checksum true false)"
-Dwith-fishlim="$(usex plugin-fishlim true false)"
- -Dwith-lua="$(usex lua lua false)"
+ -Dwith-lua="$(usex lua ${ELUA} false)"
-Dwith-perl="$(usex perl "${EPREFIX}"/usr/bin/perl false)"
-Dwith-python="$(usex python "${EPYTHON/.*}" false)"
-Dwith-sysinfo="$(usex plugin-sysinfo true false)"