summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-30 00:57:45 +0000
committerSam James <sam@gentoo.org>2020-08-30 01:04:59 +0000
commit208a5389e42ceab67f66dc3a48b5d137eb205ab8 (patch)
treef952e475037d18a756ffff9e542ed76920582aff /net-irc
parentnet-irc/irssi-xmpp: fix musl build, respect CC (diff)
downloadgentoo-208a5389e42ceab67f66dc3a48b5d137eb205ab8.tar.gz
gentoo-208a5389e42ceab67f66dc3a48b5d137eb205ab8.tar.bz2
gentoo-208a5389e42ceab67f66dc3a48b5d137eb205ab8.zip
net-irc/irssi-xmpp: cleanup old
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irssi-xmpp/Manifest1
-rw-r--r--net-irc/irssi-xmpp/files/irssi-xmpp-0.53-irssi-1.0.patch57
-rw-r--r--net-irc/irssi-xmpp/irssi-xmpp-0.53.ebuild38
3 files changed, 0 insertions, 96 deletions
diff --git a/net-irc/irssi-xmpp/Manifest b/net-irc/irssi-xmpp/Manifest
index 8bdb1e6629e7..8591f0735720 100644
--- a/net-irc/irssi-xmpp/Manifest
+++ b/net-irc/irssi-xmpp/Manifest
@@ -1,3 +1,2 @@
-DIST irssi-xmpp-0.53.tar.gz 65649 BLAKE2B 69621ae0fadb3b3c1015b5ffa1f4b9e81cc3b92270c07582f5a4cefe83f9ed4e1735527900c6989127c8d70616b316ea42653ee57aa5a8b0e6e5c641cf064346 SHA512 09969db01b77e95248a080599d480b8271dcbe6d42bc90e5e2bb304a2d1b9695b70090ef0a6b7342bf6e17326e0f7a50c11c85e02e6ed742ec55820ffad655be
DIST irssi-xmpp-0.54-musl-build.patch 24443 BLAKE2B b0ed65a688d0db84f89bc65c429b4754cd4dcfb9de2c1cd5aa64f4e02badc82d26ab42b2a29a3658910dcdbf61b2d49eca4c1b4355b5566c5a3bd120e06340bb SHA512 1417c328867b59de41f71fa720cb00581352604acec9787db183820f1ffb77209623bc236aa5b6e4f661c3780ee5c3d407aecbc286176a4d850f6e40bebecd45
DIST irssi-xmpp-0.54.tar.gz 65618 BLAKE2B 5dd1f3a858cdb397351b93800fdd2050aa8e5764ac2e03008d629dee7d825b02bce4bfc627ab2d3249392efe43ceb1530a7ccefc3241c8ca101cc2963d28f872 SHA512 31ddd9e0147eec23d08b8bcbe242e831d612cb2d00f3b56776e9d0b87db9bd76d4bb147422cdf18c0567f0e0463ab828ab7a0ef80a2b35cfdc0a8be962b39f14
diff --git a/net-irc/irssi-xmpp/files/irssi-xmpp-0.53-irssi-1.0.patch b/net-irc/irssi-xmpp/files/irssi-xmpp-0.53-irssi-1.0.patch
deleted file mode 100644
index a92d4db4739b..000000000000
--- a/net-irc/irssi-xmpp/files/irssi-xmpp-0.53-irssi-1.0.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 0d9e5f7f1a0edaea0de312828ce47d11f74ee3dc Mon Sep 17 00:00:00 2001
-From: benaryorg <binary@benary.org>
-Date: Fri, 20 Jan 2017 06:31:28 +0100
-Subject: [PATCH] fix build with irssi 1.0
-
-use_ssl field of SERVER_CONNECT_REC has been renamed to use_tls.
-
-Original patch from darix.
-
-Signed-off-by: benaryorg <binary@benary.org>
----
- src/core/xmpp-servers.c | 11 ++++++++---
- 1 file changed, 8 insertions(+), 3 deletions(-)
-
-diff --git a/src/core/xmpp-servers.c b/src/core/xmpp-servers.c
-index 405ecd9..8d0b62d 100644
---- a/src/core/xmpp-servers.c
-+++ b/src/core/xmpp-servers.c
-@@ -32,6 +32,11 @@
- #include "rosters-tools.h"
- #include "tools.h"
-
-+/* IRSSI_ABI_VERSION was introduced in 0.8.18 */
-+#if !defined(IRSSI_ABI_VERSION) || IRSSI_ABI_VERSION < 6
-+# define use_tls use_ssl
-+#endif
-+
- static void
- channels_join(SERVER_REC *server, const char *data, int automatic)
- {
-@@ -151,7 +156,7 @@ xmpp_server_init_connect(SERVER_CONNECT_REC *connrec)
- server->connect_pid = -1;
-
- if (server->connrec->port <= 0)
-- server->connrec->port = (server->connrec->use_ssl) ?
-+ server->connrec->port = (server->connrec->use_tls) ?
- LM_CONNECTION_DEFAULT_PORT_SSL : LM_CONNECTION_DEFAULT_PORT;
-
- if (conn->real_jid == NULL)
-@@ -335,7 +340,7 @@ lm_open_cb(LmConnection *connection, gboolean success,
- g_free(host);
- } else
- signal_emit("server connecting", 1, server);
-- if (server->connrec->use_ssl)
-+ if (server->connrec->use_tls)
- signal_emit("xmpp server status", 2, server,
- "Using SSL encryption.");
- else if (lm_ssl_get_use_starttls(lm_connection_get_ssl(server->lmconn)))
-@@ -470,7 +475,7 @@ xmpp_server_connect(XMPP_SERVER_REC *server)
- return;
- error = NULL;
- err_msg = NULL;
-- if (server->connrec->use_ssl) {
-+ if (server->connrec->use_tls) {
- if (!set_ssl(server->lmconn, &error, server, FALSE)) {
- err_msg = "Cannot init ssl";
- goto err;
diff --git a/net-irc/irssi-xmpp/irssi-xmpp-0.53.ebuild b/net-irc/irssi-xmpp/irssi-xmpp-0.53.ebuild
deleted file mode 100644
index 897b1d37ddd4..000000000000
--- a/net-irc/irssi-xmpp/irssi-xmpp-0.53.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="An irssi plugin providing Jabber/XMPP support"
-HOMEPAGE="https://cybione.org/~irssi-xmpp/"
-SRC_URI="https://github.com/cdidier/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- >=net-irc/irssi-0.8.13
- >=net-libs/loudmouth-1.4.0"
-
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-irssi-1.0.patch" )
-
-src_prepare() {
- default
- sed -e "s/{MAKE} doc-install/{MAKE}/" \
- -i Makefile || die #322355
-}
-
-src_compile() {
- emake PREFIX=/usr CC="$(tc-getCC)"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX=/usr IRSSI_LIB=/usr/$(get_libdir)/irssi install
- dodoc README NEWS TODO docs/*
-}