summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-11-15 09:06:33 +0100
committerSam James <sam@gentoo.org>2022-11-22 07:04:02 +0000
commit55e4a023b11c654b43cc878ba3be7bc9ee4977e5 (patch)
tree1cf8c0fe6193479c0c29650a69854a6ece31ece4 /net-irc
parentapp-misc/splitvt: revbump, fix build with clang16, fix open bugs (diff)
downloadgentoo-55e4a023b11c654b43cc878ba3be7bc9ee4977e5.tar.gz
gentoo-55e4a023b11c654b43cc878ba3be7bc9ee4977e5.tar.bz2
gentoo-55e4a023b11c654b43cc878ba3be7bc9ee4977e5.zip
net-irc/scrollz: version bump to 2.3.1, patch for clang16
Version bump also closes this vulnerability from bug 777987. Bug: https://bugs.gentoo.org/777987 Closes: https://bugs.gentoo.org/731206 Closes: https://bugs.gentoo.org/861467 Closes: https://bugs.gentoo.org/870907 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/28284 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/scrollz/Manifest2
-rw-r--r--net-irc/scrollz/scrollz-2.3.1.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/net-irc/scrollz/Manifest b/net-irc/scrollz/Manifest
index 8c876bc6f271..eb352197e3ed 100644
--- a/net-irc/scrollz/Manifest
+++ b/net-irc/scrollz/Manifest
@@ -1 +1,3 @@
+DIST ScrollZ-2.3.1.tar.gz 980735 BLAKE2B 39cd79a3c1a77bef730ecfadc8a9e78243e34781cc66cc068be698d18decc24e1001b21302e2069eb4cc21de41b4fd24a4e20a1e7a8e1d0a776ad02e1f215444 SHA512 3fc8386a16ec8ef3cce178465e04485b6dd2d5a4fc93099a8af5a6127ec66357ce7b12173c59b33eeaddf142d17d3e979821ab0f30087806545afe1ecfc168d3
DIST ScrollZ-2.3.tar.gz 981707 BLAKE2B ee7c1955dbd2515204d805052d091274c3c7e08257a798c357c5a195c12d7ebc85a160cd40ddf1b2aa87a1b628bebf630c3b7428bde1f230bf9b372f74cc74d2 SHA512 cb3dc2f462452c605c688805ed5128e0197eb4daae895c03f00631c4e9a0994f89a9c55b7e0591588f3f313dab66fcbeb1683b42ef75c3b714185b40703b1979
+DIST scrollz-2.3.1-patches.tar.xz 71696 BLAKE2B a0408017a23492f056bf464fb4ed9c20d59ca1f545bbd6b4f8f9b3097f82086a53b099558a18e72042126357f5f508d80a30eabb2a58368c198e2d077be3eb99 SHA512 37b035d838d215186b67621aecfe1d12869f7883d266a418227a2e768f569c2992598eaf93b4e0846c2e33d3e1325b3f0d39a285a0de4c78f4aedb190907bed5
diff --git a/net-irc/scrollz/scrollz-2.3.1.ebuild b/net-irc/scrollz/scrollz-2.3.1.ebuild
new file mode 100644
index 000000000000..52ce5f27eb02
--- /dev/null
+++ b/net-irc/scrollz/scrollz-2.3.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic toolchain-funcs
+
+MY_P="ScrollZ-${PV}"
+
+DESCRIPTION="Advanced IRC client based on ircII"
+HOMEPAGE="https://www.scrollz.info/"
+SRC_URI="https://www.scrollz.info/download/${MY_P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-patches.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="gmp gnutls ipv6 ssl"
+REQUIRED_USE="gnutls? ( ssl )"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ sys-libs/ncurses:=
+ virtual/libcrypt:=
+ gmp? ( dev-libs/gmp:= )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # https://github.com/ScrollZ/ScrollZ/pull/30
+ "${WORKDIR}"/${P}-patches
+)
+
+src_configure() {
+ # Many -Wdeprecated-non-prototype warnings
+ append-cflags -std=gnu89
+
+ local _myssl
+
+ if use ssl; then
+ if use gnutls; then
+ _myssl="--with-ssl"
+ else
+ _myssl="--with-openssl"
+ fi
+ fi
+
+ tc-export CC #397441, ancient autoconf
+ econf \
+ --with-default-server="irc.gentoo.org" \
+ $(use_enable ipv6) \
+ --enable-regexp \
+ $(use_enable gmp fish) \
+ ${_myssl}
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ mandir="${EPREFIX}/usr/share/man/man1" \
+ install
+
+ dodoc ChangeLog* NEWS README* todo
+}