summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <dawid.weglinski@gmail.com>2018-03-20 22:04:00 +0000
committerPatrice Clement <monsieurp@gentoo.org>2018-03-21 23:09:55 +0100
commit5ef4f0b03df1ef0fbc7bf0c4976cfdc1faa559c2 (patch)
treec946f148295914545d1ce336997f1e342438743f /net-irc
parentnet-misc/ntp-4.2.8_p11: hppa stable, bug 649612 (diff)
downloadgentoo-5ef4f0b03df1ef0fbc7bf0c4976cfdc1faa559c2.tar.gz
gentoo-5ef4f0b03df1ef0fbc7bf0c4976cfdc1faa559c2.tar.bz2
gentoo-5ef4f0b03df1ef0fbc7bf0c4976cfdc1faa559c2.zip
net-irc/emech: version bump to 3.0.99_p3.
* Bump EAPI. * Fix buidling issue. * Add maintainer to metadata.xml. Closes: https://bugs.gentoo.org/651034
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/emech/Manifest1
-rw-r--r--net-irc/emech/emech-3.0.99_p3.ebuild89
-rw-r--r--net-irc/emech/files/emech-3.0.99_p3-buildfix.patch70
-rw-r--r--net-irc/emech/metadata.xml9
4 files changed, 168 insertions, 1 deletions
diff --git a/net-irc/emech/Manifest b/net-irc/emech/Manifest
index 6392da6ae1eb..30a0181692f2 100644
--- a/net-irc/emech/Manifest
+++ b/net-irc/emech/Manifest
@@ -1 +1,2 @@
DIST emech-3.0.3.tar.gz 228709 BLAKE2B 596c2d757438e1ed08ecb96927258cbd1afcc6105831c336b5df4b22716fdeb2a3215678589c6d9898ad39979d6039cccb12f0af88183ac5fa1c9c1ce86c5102 SHA512 ffe478c0c1800c8afb7afca62dbe08fce6af25a5878ca5fb44bb1271a302d11b96263c51a3848996db8f33f1cdab60d86c26d571d6342fe1505d4dcff83803a3
+DIST emech-3.0.99p3.tar.gz 249209 BLAKE2B 8ff0806275f7b1c9e49bb2eeda2afa0ac94b894426a2f56508492f970070e4141f14f88ffb3c1c46855817c405d29454cf85ebba53c85b4038d7d9d079f4dff6 SHA512 8ce6f8889e060791ab3af6fa63623469a457c436b4e23c51dcd1833fd09e7692270a324ad1d15beb4ad390e9d481267a8ea60eb17c9fd3195b5ad0daf7341165
diff --git a/net-irc/emech/emech-3.0.99_p3.ebuild b/net-irc/emech/emech-3.0.99_p3.ebuild
new file mode 100644
index 000000000000..f083ab026f89
--- /dev/null
+++ b/net-irc/emech/emech-3.0.99_p3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1 toolchain-funcs
+
+DESCRIPTION="UNIX compatible IRC bot programmed in the C language"
+HOMEPAGE="http://www.energymech.net/"
+SRC_URI="http://www.energymech.net/files/${P/_/}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="debug session tcl"
+S="${WORKDIR}/${P/_/}"
+
+DOC_CONTENTS="You can find a compressed sample config file at /usr/share/doc/${PF}"
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-buildfix.patch"
+
+ sed -i \
+ -e 's: "help/":"/usr/share/energymech/help/":' \
+ -e 's: "messages/":"/usr/share/energymech/messages/":' \
+ src/config.h.in || die
+ # Respect CFLAGS and LDFLAGS
+ sed -i \
+ -e '/^LFLAGS/s/\$(PIPEFLAG)/\0 \$(OPTIMIZE) \$(LDFLAGS)/' \
+ -e '/^GDBFLAG/d' \
+ -e '/^PIPEFLAG/d' \
+ src/Makefile.in || die
+
+ eapply_user
+}
+
+myconf() {
+ echo ./configure $*
+ ./configure $* || die "./configure failed"
+}
+
+src_configure() {
+ myconf \
+ --with-alias \
+ --with-botnet \
+ --with-bounce \
+ --with-ctcp \
+ --with-dccfile \
+ --with-dynamode \
+ --with-dyncmd \
+ --with-greet \
+ --with-ircd_ext \
+ --with-md5 \
+ --with-newbie \
+ --with-note \
+ --with-notify \
+ --with-rawdns \
+ --with-redirect \
+ --with-seen \
+ --with-stats \
+ --with-telnet \
+ --with-toybox \
+ --with-trivia \
+ --without-uptime \
+ --with-web \
+ --with-wingate \
+ --without-profiling \
+ $(use_with tcl) \
+ $(use_with session) \
+ $(use_with debug)
+}
+
+src_compile() {
+ emake -C src CC="$(tc-getCC)" OPTIMIZE="${CFLAGS}"
+}
+
+src_install() {
+ dobin src/energymech
+
+ insinto /usr/share/energymech
+ doins -r help
+
+ insinto /usr/share/energymech/messages
+ doins messages/*.txt
+
+ dodoc sample.* README* TODO VERSIONS CREDITS checkmech
+ readme.gentoo_create_doc
+}
diff --git a/net-irc/emech/files/emech-3.0.99_p3-buildfix.patch b/net-irc/emech/files/emech-3.0.99_p3-buildfix.patch
new file mode 100644
index 000000000000..de1dee6ed673
--- /dev/null
+++ b/net-irc/emech/files/emech-3.0.99_p3-buildfix.patch
@@ -0,0 +1,70 @@
+diff -Naur emech-3.0.99p3.org/src/gencmd.c emech-3.0.99p3/src/gencmd.c
+--- emech-3.0.99p3.org/src/gencmd.c 2009-05-13 08:51:09.000000000 -0000
++++ emech-3.0.99p3/src/gencmd.c 2018-03-16 22:52:42.591033854 -0000
+@@ -316,7 +316,7 @@
+ }
+ if (pass == __struct_acces)
+ {
+- printf("\t%i,\t/""* %s *""/\n",
++ printf("\t%li,\t/""* %s *""/\n",
+ pre_mcmd[wh].flags & CLEVEL,
+ pt);
+ }
+@@ -390,7 +390,7 @@
+ }
+ pass--;
+ }
+- printf("#define LOCALHOST_ULONG %lu\n",inet_addr("127.1"));
++ printf("#define LOCALHOST_ULONG %u\n",inet_addr("127.1"));
+ printf("#else /""* MAIN_C *""/\n\n");
+ printf("extern OnMsg mcmd[];\n");
+ printf("extern OnMsg_access acmd[];\n\n");
+@@ -404,29 +404,29 @@
+
+ #ifdef BOTNET
+ combo.comboflags = 0; combo.x.noshare = 1;
+- fprintf(of,"#define COMBO_NOSHARE\t0x%x\n",combo.comboflags);
++ fprintf(of,"#define COMBO_NOSHARE\t0x%lx\n",combo.comboflags);
+ combo.comboflags = 0; combo.x.readonly = 1;
+- fprintf(of,"#define COMBO_READONLY\t0x%x\n",combo.comboflags);
++ fprintf(of,"#define COMBO_READONLY\t0x%lx\n",combo.comboflags);
+ #endif /* BOTNET */
+
+ #ifdef GREET
+ combo.comboflags = 0; combo.x.greetfile = 1;
+- fprintf(of,"#define COMBO_GREETFILE\t0x%x\n",combo.comboflags);
++ fprintf(of,"#define COMBO_GREETFILE\t0x%lx\n",combo.comboflags);
+ combo.comboflags = 0; combo.x.randline = 1;
+- fprintf(of,"#define COMBO_RANDLINE\t0x%x\n",combo.comboflags);
++ fprintf(of,"#define COMBO_RANDLINE\t0x%lx\n",combo.comboflags);
+ #endif /* GREET */
+
+ #ifdef BOUNCE
+ combo.comboflags = 0; combo.x.bounce = 1;
+- fprintf(of,"#define COMBO_BOUNCE\t0x%x\n",combo.comboflags);
++ fprintf(of,"#define COMBO_BOUNCE\t0x%lx\n",combo.comboflags);
+ #endif /* BOUNCE */
+
+ combo.comboflags = 0; combo.x.echo = 1;
+- fprintf(of,"#define COMBO_ECHO\t0x%x\n",combo.comboflags);
++ fprintf(of,"#define COMBO_ECHO\t0x%lx\n",combo.comboflags);
+ combo.comboflags = 0; combo.x.aop = 1;
+- fprintf(of,"#define COMBO_AOP\t0x%x\n",combo.comboflags);
++ fprintf(of,"#define COMBO_AOP\t0x%lx\n",combo.comboflags);
+ combo.comboflags = 0; combo.x.avoice = 1;
+- fprintf(of,"#define COMBO_AVOICE\t0x%x\n",combo.comboflags);
++ fprintf(of,"#define COMBO_AVOICE\t0x%lx\n",combo.comboflags);
+
+ fclose(of);
+ return(0);
+diff -Naur emech-3.0.99p3.org/src/function.c emech-3.0.99p3/src/function.c
+--- emech-3.0.99p3.org/src/function.c 2009-05-17 20:25:29.000000000 -0000
++++ emech-3.0.99p3/src/function.c 2018-03-17 11:41:15.224075216 -0000
+@@ -26,6 +26,7 @@
+ #include "global.h"
+ #include "h.h"
+ #include "text.h"
++#include "linux/limits.h"
+
+ LS char timebuf[24]; /* max format lentgh == 20+1, round up to nearest longword -> 24 */
+ LS char idlestr[36]; /* max format lentgh == 24+1, round up to nearest longword -> 28 */
diff --git a/net-irc/emech/metadata.xml b/net-irc/emech/metadata.xml
index 6f49eba8f496..d376f2bcd4b1 100644
--- a/net-irc/emech/metadata.xml
+++ b/net-irc/emech/metadata.xml
@@ -1,5 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>dawid.weglinski@gmail.com</email>
+ <name>Dawid Węgliński</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
</pkgmetadata>