summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-03-09 10:41:38 +0100
committerHans de Graaff <graaff@gentoo.org>2021-03-09 10:41:46 +0100
commit6ec5bf128af36c9e6e95047f7e7c296ed1d3714c (patch)
tree7efa38d6a2d569fb90e9325a1bee98186931d5b8 /net-irc
parentapp-misc/dateutils: sync live ebuild (diff)
downloadgentoo-6ec5bf128af36c9e6e95047f7e7c296ed1d3714c.tar.gz
gentoo-6ec5bf128af36c9e6e95047f7e7c296ed1d3714c.tar.bz2
gentoo-6ec5bf128af36c9e6e95047f7e7c296ed1d3714c.zip
net-irc/rbot: add ruby26, ruby27; drop shorturl USE flag
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/rbot/metadata.xml5
-rw-r--r--net-irc/rbot/rbot-0.9.15_p20160325-r2.ebuild (renamed from net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild)16
2 files changed, 7 insertions, 14 deletions
diff --git a/net-irc/rbot/metadata.xml b/net-irc/rbot/metadata.xml
index 9be5ac250eb4..c24f8a726305 100644
--- a/net-irc/rbot/metadata.xml
+++ b/net-irc/rbot/metadata.xml
@@ -21,11 +21,6 @@
to enable the "translator" plugin for rbot. If the USE flag is
disabled the plugin is also disabled by default.
</flag>
- <flag name="shorturl">
- Add dependency over <pkg>dev-ruby/shorturl</pkg>, which is needed
- to enable the "shortenurl" plugin for rbot. If the USE flag is
- disabled the plugin is also disabled by default.
- </flag>
<flag name="nls">
Build and install translation for the messages coming from the bot
and its plugins (through <pkg>dev-ruby/ruby-gettext</pkg>).
diff --git a/net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild b/net-irc/rbot/rbot-0.9.15_p20160325-r2.ebuild
index 495f009bcfe2..d4bbfeb5e719 100644
--- a/net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild
+++ b/net-irc/rbot/rbot-0.9.15_p20160325-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-USE_RUBY="ruby23 ruby24 ruby25"
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
GITHUB_COMMIT="e358601cc521d8aced941eb928fae2d8c53cf0c2"
-inherit ruby-ng eutils user
+inherit ruby-ng l10n user
DESCRIPTION="A ruby IRC bot"
HOMEPAGE="https://ruby-rbot.org/"
@@ -14,13 +14,11 @@ SRC_URI="https://github.com/ruby-rbot/rbot/archive/${GITHUB_COMMIT}.tar.gz -> ${
LICENSE="|| ( feh GPL-2 )"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="spell aspell timezone translator shorturl nls figlet
+IUSE="spell aspell timezone translator nls figlet
fortune cal host sqlite toilet"
ILINGUAS="zh_CN zh_TW ru nl de fi fr it ja"
RUBY_S="${PN}-${GITHUB_COMMIT}"
-RUBY_PATCHES=( rbot-rakefile-gettext.patch )
-
RDEPEND+="
spell? (
aspell? ( app-text/aspell )
@@ -46,7 +44,6 @@ ruby_add_rdepend "
dev-ruby/tokyocabinet
timezone? ( dev-ruby/tzinfo:* )
translator? ( dev-ruby/mechanize )
- shorturl? ( dev-ruby/shorturl )
nls? ( dev-ruby/ruby-gettext >=dev-ruby/locale-2.0.5-r2 )
"
@@ -55,6 +52,8 @@ pkg_setup() {
}
all_ruby_prepare() {
+ eapply -p0 "${FILESDIR}"/rbot-rakefile-gettext.patch
+
# Avoid tests that are only compatible with ruby22
rm -f test/test_journal.rb || die
@@ -104,7 +103,6 @@ all_ruby_compile() {
use_rbot_plugin timezone time
use_rbot_plugin translator translator
- use_rbot_plugin shorturl shortenurls
use_rbot_plugin fortune fortune
use_rbot_conf_path fortune fortune.path /usr/bin/fortune