summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2021-12-13 20:15:55 +1100
committerSam Jorna <wraeth@gentoo.org>2021-12-13 20:26:51 +1100
commit74c94ae37d7e7c71d911b315781f943999efc794 (patch)
treec3c61d98f664c74e37ce43a48ccef688e060ed27 /net-irc
parentdev-python/pandas: Bump to 1.3.5 (diff)
downloadgentoo-74c94ae37d7e7c71d911b315781f943999efc794.tar.gz
gentoo-74c94ae37d7e7c71d911b315781f943999efc794.tar.bz2
gentoo-74c94ae37d7e7c71d911b315781f943999efc794.zip
net-irc/limnoria: bump to 20211118
Build system changed to setuptools per upstream. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Sam Jorna <wraeth@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/limnoria/Manifest1
-rw-r--r--net-irc/limnoria/limnoria-20211118.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/net-irc/limnoria/Manifest b/net-irc/limnoria/Manifest
index 8e5be245f5cc..35f526dcf856 100644
--- a/net-irc/limnoria/Manifest
+++ b/net-irc/limnoria/Manifest
@@ -1,2 +1,3 @@
DIST limnoria-20210527.tar.gz 1092017 BLAKE2B 1c01ecbb47927d62e30e1768bb8e4574bad7422fea379ddd3d6700351a2f8dd006370a24aeeb7a5b10003e53f1010c8fb3998ecf1ef4f11a2ce48f9145605d30 SHA512 2e09415931cb3bdc358d4a243be3f1abccd569f2371d5d2b2c67e856492475affa473c8c32c77cb2c973b64202f9c6657397fa35b5b16086fbaf4e5b44706184
DIST limnoria-20210617.tar.gz 1094438 BLAKE2B 3253af8ad764acfaadf90ce49d0f40a47f32554d75c3860079284f98373eb3bc8f60f1f308b501265973c0e6c2a552211415f4f9c3044ce78f818d305b598cbe SHA512 25dddf843e22967a95c769c62f9398129830f63e23d506f0a9abaf7044fa9ffbeca95138c494caf3b36813919c7b1f0880b0715a06bc519de1a87837a948a039
+DIST limnoria-20211118.tar.gz 1094394 BLAKE2B cf3f10b0e489b16afba96b6f9dcc64e0f86007cb601f7cdaca66ec80f5ce01f31795d513ee5d55687902b3a65e114e841c07d5ef34e016140f93d5d8f420f73f SHA512 f0f7d632f4de837663e69df8892191f3ee20a586e073fa9f382852f2e2146b6d82556827ef68d27831938a43fa32185d11a53e1810f7e1834d08b5aeff903b70
diff --git a/net-irc/limnoria/limnoria-20211118.ebuild b/net-irc/limnoria/limnoria-20211118.ebuild
new file mode 100644
index 000000000000..76618cf0e3a9
--- /dev/null
+++ b/net-irc/limnoria/limnoria-20211118.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_IN_SOURCE_BUILD=yes # needed for tests
+inherit distutils-r1
+
+MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PN="Limnoria"
+MY_P="${MY_PN}-${MY_PV}"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/ProgVal/${MY_PN}.git"
+ EGIT_BRANCH="testing"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ProgVal/${MY_PN}/archive/master-${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-master-${MY_PV}"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Python based extensible IRC infobot and channel bot"
+HOMEPAGE="https://docs.limnoria.net"
+LICENSE="BSD GPL-2 GPL-2+"
+SLOT="0"
+IUSE="crypt ssl test"
+RESTRICT=" !test? ( test )"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ crypt? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+ !net-irc/supybot
+ !net-irc/supybot-plugins"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # replace "installed on ${timestamp}" with real version
+ echo "version='${MY_PV//-/.}'" > "${S}"/src/version.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd "${T}" > /dev/null || die
+ PLUGINS_DIR="${BUILD_DIR}"/lib/supybot/plugins
+ EXCLUDE_PLUGINS=()
+ # intermittent failure due to issues loading libsandbox.so from LD_PRELOAD
+ # runs successfully when running the tests on the installed system
+ EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Unix" )
+ "${EPYTHON}" "${BUILD_DIR}"/scripts/supybot-test "${BUILD_DIR}/../test" \
+ --plugins-dir="${PLUGINS_DIR}" --no-network \
+ --disable-multiprocessing "${EXCLUDE_PLUGINS[@]}" \
+ || die "Tests failed under ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/*
+}
+
+pkg_postinst() {
+ elog "Complete user documentation is available at https://limnoria-doc.readthedocs.org/"
+ elog ""
+ elog "Use supybot-wizard to create a configuration file."
+ elog "Run supybot </path/to/config> to use the bot."
+}