summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2023-03-13 21:25:38 +0100
committerLouis Sautier <sbraz@gentoo.org>2023-03-13 21:28:07 +0100
commit8ddffbaae428093638655a772994bf52bc77a2a9 (patch)
tree255ea9a5e7fd12d242c24818075044523951e8ee /net-irc
parentdev-python/sqlalchemy: Stabilize 2.0.4 ppc, #901065 (diff)
downloadgentoo-8ddffbaae428093638655a772994bf52bc77a2a9.tar.gz
gentoo-8ddffbaae428093638655a772994bf52bc77a2a9.tar.bz2
gentoo-8ddffbaae428093638655a772994bf52bc77a2a9.zip
net-irc/eggdrop: add 1.9.5
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/eggdrop/Manifest1
-rw-r--r--net-irc/eggdrop/eggdrop-1.9.5.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/net-irc/eggdrop/Manifest b/net-irc/eggdrop/Manifest
index 8d09716059f3..2edd3f8dcab7 100644
--- a/net-irc/eggdrop/Manifest
+++ b/net-irc/eggdrop/Manifest
@@ -1,3 +1,4 @@
DIST eggdrop-1.9.1.tar.gz 2271120 BLAKE2B 73fadeddcebeba5de42328f6f02c05e850e47c19812bc1a868da09f55fd1d297e3596c5a4b167806237554966e7dfbebadcee6215932c56a76b3e67a77d5ee47 SHA512 d8907d265f7e22f3bcd3e28b256c5788d5959ad11cc1425d59eb4411ebbc172fe8d90c31fd9f033369ab80cd29a36a5856f6bd32bc6c9cdfedea1d6509ea7f3b
DIST eggdrop-1.9.3.tar.gz 2046726 BLAKE2B 979190536c3c0718ef4b030d8f6df817b8ee823854c104b7d6f9009c10a7f8394d59afca40fc5c9778f130788fac7e14458d62d30a55413dea4653ca00c83f0a SHA512 67d6d0f798222e54e09acb319aa4926181c34b6e4cdc2cbb4fc7a8433915a7d6281904fd190fe2ee92bcc2cb99943e3fb5b9d99831cc0bfd930205e63e33d1a1
DIST eggdrop-1.9.4.tar.gz 2065217 BLAKE2B f9d1e6c0491d6c7959e3b67e8186082d074d648497cd66f244dfb4c919a566d81fdce83d034f0cc1e5247bc924022faf56004cdd8a6cc174fe8d0f44af5e2a9a SHA512 ed3145411a1832d1a6d4f191c6ff30e64aa45f803df00585c1c69f6bbc8a16d07e9608c57e31fb723f7a9c66a24422e5080aab7746e562ac5b6a678a08c7b2a4
+DIST eggdrop-1.9.5.tar.gz 2109996 BLAKE2B 80d7b44356f0c5750c276f15412fdb847bc7583c7d1e990735ad4aec1b6bec9822124b089654dfb4dfbd393127804da1019d184d01b867b0dd84ba0342167d94 SHA512 863e6f94a92ac02e135c306000379ce516d9c9381eb5ca249e7656f4f0f504a159ddf1f658016d05e422d8036e808664101ab4f8944a42438c273f71b676189b
diff --git a/net-irc/eggdrop/eggdrop-1.9.5.ebuild b/net-irc/eggdrop/eggdrop-1.9.5.ebuild
new file mode 100644
index 000000000000..a174ad7aeb29
--- /dev/null
+++ b/net-irc/eggdrop/eggdrop-1.9.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+MY_P="${PN}-${PV/_rc/rc}"
+DESCRIPTION="An IRC bot extensible with C or TCL"
+HOMEPAGE="https://www.eggheads.org/"
+SRC_URI="https://ftp.eggheads.org/pub/eggdrop/source/${PV:0:3}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~riscv ~sparc ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug doc ssl static"
+
+DEPEND="
+ dev-lang/tcl:0=
+ ssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="
+ sys-apps/gentoo-functions
+ ${DEPEND}
+"
+
+DOCS=( AUTHORS FEATURES INSTALL NEWS README THANKS UPGRADING )
+
+src_configure() {
+ econf --enable-ipv6 \
+ $(use_enable ssl tls)
+
+ emake config
+}
+
+src_compile() {
+ local target
+
+ if use static && use debug; then
+ target="sdebug"
+ elif use static; then
+ target="static"
+ elif use debug; then
+ target="debug"
+ fi
+
+ emake ${target}
+}
+
+src_install() {
+ emake DEST="${D}"/opt/eggdrop install
+
+ use doc && HTML_DOCS=( doc/html/. )
+ rm -r "${D}"/opt/eggdrop/doc/html || die
+ DOC_CONTENTS="
+ Additional documentation can be found
+ in ${EPREFIX}/opt/eggdrop/doc
+ "
+ readme.gentoo_create_doc
+ einstalldocs
+
+ dobin "${FILESDIR}"/eggdrop-installer
+ doman doc/man1/eggdrop.1
+}
+
+pkg_postinst() {
+ # Only display this for new installs
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please run ${EPREFIX}/usr/bin/eggdrop-installer to install your eggdrop bot."
+ fi
+}