summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWade Cline <wadecline@hotmail.com>2021-03-07 15:52:35 -0800
committerSam James <sam@gentoo.org>2021-03-09 12:05:20 +0000
commita1550aff5a0b68c69f21ec20e5b9bcbbae389e63 (patch)
tree4a57c1698384229bd9cf3c601291d7c936fd8303 /net-irc
parentnet-irc/atheme-services: Add 7.2.11 (diff)
downloadgentoo-a1550aff5a0b68c69f21ec20e5b9bcbbae389e63.tar.gz
gentoo-a1550aff5a0b68c69f21ec20e5b9bcbbae389e63.tar.bz2
gentoo-a1550aff5a0b68c69f21ec20e5b9bcbbae389e63.zip
net-irc/atheme-services: Drop 7.2.10_p2-r2
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Wade Cline <wadecline@hotmail.com> Closes: https://github.com/gentoo/gentoo/pull/19824 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/atheme-services/Manifest1
-rw-r--r--net-irc/atheme-services/atheme-services-7.2.10_p2-r2.ebuild94
-rw-r--r--net-irc/atheme-services/files/atheme-services-7.2.10_p2-fix-backtrace-compat-detection.patch12
3 files changed, 0 insertions, 107 deletions
diff --git a/net-irc/atheme-services/Manifest b/net-irc/atheme-services/Manifest
index a2d8327a3582..77a13813677c 100644
--- a/net-irc/atheme-services/Manifest
+++ b/net-irc/atheme-services/Manifest
@@ -1,2 +1 @@
-DIST atheme-services-7.2.10_p2.tar.xz 21061364 BLAKE2B e02ea3b9b55c0a02bfd354da65ed45318c2f0a5d5d35cabe7984760cfe1683b9856cc779754f1de8861816b5b2d2323c898100697e8d365ffed039e90b42cde6 SHA512 c7e6654ddbf515b1565b77f0659cd9a77787d004fb532ecdee638189e823ec65afc283cbeafc6d7625ed6c210835e5546c5e33718e08ad0b280ccc7a2df7be48
DIST atheme-services-7.2.11.tar.xz 1051436 BLAKE2B 99624c21adf820c8ef8e33aa9ae9036c701c4a9218e225e7871717c86010fbed56d00da43cd2ffb79a46074a5602260fabbbaf769407a00175b5127c18913c1c SHA512 adcc189b61efe295997a7456022a7595df5b14b55c2139794d380e57fe77efd42221316558391b5440f077fd951143905454b0e9893deec89108fa671b44ef2f
diff --git a/net-irc/atheme-services/atheme-services-7.2.10_p2-r2.ebuild b/net-irc/atheme-services/atheme-services-7.2.10_p2-r2.ebuild
deleted file mode 100644
index 820dfd3bd2f6..000000000000
--- a/net-irc/atheme-services/atheme-services-7.2.10_p2-r2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic perl-functions
-
-MY_PN="atheme"
-MY_PV="7.2.10-r2"
-
-DESCRIPTION="A portable and secure set of open-source and modular IRC services"
-HOMEPAGE="https://github.com/atheme/atheme"
-SRC_URI="https://github.com/atheme/atheme/releases/download/v${MY_PV}/${MY_PN}-v${MY_PV}.tar.xz -> ${P}.tar.xz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="cracklib largenet ldap nls +pcre perl profile ssl"
-S="${WORKDIR}/${MY_PN}-v${MY_PV}"
-
-RDEPEND="
- acct-group/atheme-services
- acct-user/atheme-services
- >=dev-libs/libmowgli-2.1.0:2
- cracklib? ( sys-libs/cracklib )
- ldap? ( net-nds/openldap )
- perl? ( dev-lang/perl )
- pcre? ( dev-libs/libpcre )
- ssl? ( dev-libs/openssl:0= )"
-DEPEND="${RDEPEND}"
-# 'dev-vcs/git' required as per bug #665802
-BDEPEND="
- dev-vcs/git
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${P}-configure-logdir.patch
- "${FILESDIR}"/${P}-fix-backtrace-compat-detection.patch)
-
-src_configure() {
- # perl scriping module support is also broken in 7.0.0. Yay for QA failures.
- econf \
- --sysconfdir="${EPREFIX}"/etc/${PN} \
- --localstatedir="${EPREFIX}"/var \
- --enable-fhs-paths \
- --disable-warnings \
- --enable-contrib \
- $(use_enable largenet large-net) \
- $(use_with cracklib) \
- $(use_with ldap) \
- $(use_enable nls) \
- $(use_enable profile) \
- $(use_with pcre) \
- $(use_with perl) \
- $(use_enable ssl)
-}
-
-src_compile() {
- emake V=1
-}
-
-src_install() {
- default
-
- insinto /etc/${PN}
- for conf in dist/*.example; do
- # The .cron file isn't meant to live in /etc/${PN}, so only
- # install a .example version.
- [[ ${conf} == *cron* ]] && continue
-
- local confdest=${conf##*/}
- newins ${conf} ${confdest%.example}
- done
-
- fowners -R 0:${PN} /etc/${PN}
- keepdir /var/{lib,log}/atheme
- fowners ${PN}:${PN} /var/{lib,log}/atheme
- fperms -R go-w,o-rx /etc/${PN}
- fperms 750 /etc/${PN} /var/{lib,log}/atheme
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- mv "${ED}"/usr/bin/{,atheme-}dbverify || die
-
- # contributed scripts and such:
- docinto contrib
- dodoc contrib/*.{c,pl,php,py,rb}
-
- use perl && perl_domodule -r contrib/Atheme{,.pm}
-
- rm "${ED}/usr/share/doc/${PF}/WINDOWS" || die
-
- # Bug #454840 #520490
- rm -rf "${ED}/var/run" || die
-}
diff --git a/net-irc/atheme-services/files/atheme-services-7.2.10_p2-fix-backtrace-compat-detection.patch b/net-irc/atheme-services/files/atheme-services-7.2.10_p2-fix-backtrace-compat-detection.patch
deleted file mode 100644
index b6f448163aac..000000000000
--- a/net-irc/atheme-services/files/atheme-services-7.2.10_p2-fix-backtrace-compat-detection.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/modules/contrib/backtrace.c b/modules/contrib/backtrace.c
-index 8c4eeb2..064e88e 100644
---- a/modules/contrib/backtrace.c
-+++ b/modules/contrib/backtrace.c
-@@ -1,6 +1,6 @@
- #include "atheme-compat.h"
-
--#if defined( __linux__) || defined(__Linux__)
-+#if (defined( __linux__) || defined(__Linux__)) && defined(__GLIBC__)
- #include <execinfo.h>
-
- DECLARE_MODULE_V1