summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-19 17:40:20 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-19 18:15:39 +0100
commitc6025e149e391ba136c3ce88b89f44749c569c21 (patch)
tree74f0b4071d0ea38e9c359a336255ff63a2113437 /net-irc
parentapp-text/highlight: Drop old Qt4-based (diff)
downloadgentoo-c6025e149e391ba136c3ce88b89f44749c569c21.tar.gz
gentoo-c6025e149e391ba136c3ce88b89f44749c569c21.tar.bz2
gentoo-c6025e149e391ba136c3ce88b89f44749c569c21.zip
net-irc/konversation: Fix build with Qt 5.11
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/konversation/files/konversation-1.7.4-qt-5.11.patch27
-rw-r--r--net-irc/konversation/konversation-1.7.4.ebuild4
2 files changed, 30 insertions, 1 deletions
diff --git a/net-irc/konversation/files/konversation-1.7.4-qt-5.11.patch b/net-irc/konversation/files/konversation-1.7.4-qt-5.11.patch
new file mode 100644
index 000000000000..46508bf20a23
--- /dev/null
+++ b/net-irc/konversation/files/konversation-1.7.4-qt-5.11.patch
@@ -0,0 +1,27 @@
+From 5740a0fdb6805c2e26dce20555a946da8485fe50 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Mon, 19 Mar 2018 17:13:30 +0100
+Subject: [PATCH] Fix build with Qt 5.11 (missing QTabWidget)
+
+Reviewers: #konversation
+
+Differential Revision: https://phabricator.kde.org/D11490
+---
+ src/dcc/transferdetailedinfopanel.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/dcc/transferdetailedinfopanel.h b/src/dcc/transferdetailedinfopanel.h
+index e8debbc0..0e7391de 100644
+--- a/src/dcc/transferdetailedinfopanel.h
++++ b/src/dcc/transferdetailedinfopanel.h
+@@ -16,6 +16,7 @@
+ #include "ui_transferdetailedinfopanelui.h"
+ #include "ui_transferdetailedtimeinfopanelui.h"
+
++#include <QTabWidget>
+
+ class QTimer;
+
+--
+2.16.2
+
diff --git a/net-irc/konversation/konversation-1.7.4.ebuild b/net-irc/konversation/konversation-1.7.4.ebuild
index bedb2f5c384a..e86de80e985e 100644
--- a/net-irc/konversation/konversation-1.7.4.ebuild
+++ b/net-irc/konversation/konversation-1.7.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -54,6 +54,8 @@ RDEPEND="${DEPEND}
crypt? ( app-crypt/qca:2[ssl] )
"
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package crypt Qca-qt5)