summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /net-libs/NativeThread
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/NativeThread')
-rw-r--r--net-libs/NativeThread/NativeThread-0_pre20190914.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-libs/NativeThread/NativeThread-0_pre20190914.ebuild b/net-libs/NativeThread/NativeThread-0_pre20190914.ebuild
index ccecbccb7bc7..a13407892c05 100644
--- a/net-libs/NativeThread/NativeThread-0_pre20190914.ebuild
+++ b/net-libs/NativeThread/NativeThread-0_pre20190914.ebuild
@@ -23,10 +23,10 @@ S="${WORKDIR}"
src_compile() {
append-flags -fPIC
tc-export CC
- emake || die
+ emake
}
src_install() {
- dolib.so lib${PN}.so || die
- dosym lib${PN}.so /usr/$(get_libdir)/libnative.so || die
+ dolib.so lib${PN}.so
+ dosym lib${PN}.so /usr/$(get_libdir)/libnative.so
}