summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Efremov <efremov@linux.com>2019-06-27 12:19:01 +0300
committerMichał Górny <mgorny@gentoo.org>2019-07-15 19:24:36 +0200
commit642bd16ea2a851674532713bfac5c5e6b027bd2a (patch)
tree764372f9788706b2da51f1e0489fc162eaec3d8c /net-libs/ccnet
parentnet-dns/pdns-recursor: Version bump (diff)
downloadgentoo-642bd16ea2a851674532713bfac5c5e6b027bd2a.tar.gz
gentoo-642bd16ea2a851674532713bfac5c5e6b027bd2a.tar.bz2
gentoo-642bd16ea2a851674532713bfac5c5e6b027bd2a.zip
net-libs/ccnet: version bump to 6.1.8
Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Denis Efremov <efremov@linux.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/ccnet')
-rw-r--r--net-libs/ccnet/Manifest1
-rw-r--r--net-libs/ccnet/ccnet-6.1.8.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/ccnet/Manifest b/net-libs/ccnet/Manifest
index 3422d48f2f3b..ea49a378f65a 100644
--- a/net-libs/ccnet/Manifest
+++ b/net-libs/ccnet/Manifest
@@ -1 +1,2 @@
DIST ccnet-6.1.7.tar.gz 179364 BLAKE2B 214284a5b04ee2c8a51f8479bee5bcc3d5b044ed0cd622b56ae5caf4fb2757bf28191ffedca9f76fce80b5c6da5a489207e1bdef3436e44dbe1841a69a82c448 SHA512 bac93c9987f434915f9d5b5f0cfc44d88471ae27896e89059f3c924182255d938fb6c87dec31354f256807d5e4274b6af2e3325e753d06cd8a5ea91caba9490d
+DIST ccnet-6.1.8.tar.gz 179374 BLAKE2B 8eb05a9d2c8830c501b63f939df56cb72a6b03f7dbdf511adf1a89eff86bdc85ad804de04a2ed57f235f76e95fe1a4ab317f415be0051024bfcd7d099e9e2cad SHA512 5eb3765969edd471a43575545f92f6317741a2099bb7af82851bfe726b0715420e5b946c63435c334c4447888f1454d7cd0703f29818571eaabc2250046c45f3
diff --git a/net-libs/ccnet/ccnet-6.1.8.ebuild b/net-libs/ccnet/ccnet-6.1.8.ebuild
new file mode 100644
index 000000000000..74947e965f55
--- /dev/null
+++ b/net-libs/ccnet/ccnet-6.1.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="Ccnet is a framework for writing networked applications in C"
+HOMEPAGE="https://github.com/haiwen/ccnet http://seafile.com/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ net-libs/libsearpc[${PYTHON_USEDEP}]
+ dev-libs/glib:2
+ dev-libs/libevent:0
+ dev-libs/openssl:0
+ dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ $(vala_depend)"
+
+src_prepare() {
+ default
+ sed -i -e "s/(DESTDIR)//" libccnet.pc.in || die
+ sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
+ eautoreconf
+ vala_src_prepare
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files, as recommended by ltprune.eclass
+ find "${ED}" -name '*.la' -delete || die
+}