summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMoritz Schlarb <schlarbm@uni-mainz.de>2017-03-13 14:57:37 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-04-13 23:20:34 +0200
commit8ef0296fa0aaf5bcdc894349747f2dd42c980ca9 (patch)
treef5000fb4bd2402fea2ef557a52ee1cd9c1a086a9 /net-libs/ccnet
parentnet-libs/libsearpc: new ebuild. (diff)
downloadgentoo-8ef0296fa0aaf5bcdc894349747f2dd42c980ca9.tar.gz
gentoo-8ef0296fa0aaf5bcdc894349747f2dd42c980ca9.tar.bz2
gentoo-8ef0296fa0aaf5bcdc894349747f2dd42c980ca9.zip
net-libs/ccnet: new ebuild.
Ccnet is a framework for writing networked applications in C Gentoo-Bug: https://bugs.gentoo.org/499698 Closes: https://github.com/gentoo/gentoo/pull/4198
Diffstat (limited to 'net-libs/ccnet')
-rw-r--r--net-libs/ccnet/Manifest1
-rw-r--r--net-libs/ccnet/ccnet-6.0.4.ebuild33
-rw-r--r--net-libs/ccnet/metadata.xml11
3 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/ccnet/Manifest b/net-libs/ccnet/Manifest
new file mode 100644
index 000000000000..dbf9c8dc9572
--- /dev/null
+++ b/net-libs/ccnet/Manifest
@@ -0,0 +1 @@
+DIST ccnet-6.0.4.tar.gz 178939 SHA256 2156787fc9ae1e4293493f0ce398aa8b97d84b9f0201d2fd6986b736bd249b04 SHA512 be44b1654ee641fdbd48b288b1b04f9aeb6f441225ddc52532e5f81145657f79241555132b848a57a241eacc4bb7149ad27b930ca532ab74615d4babb4027c2c WHIRLPOOL f49294b8c819a69cbbc9878e32382e2f3f65bf5e0af3da7a8590f206a9dc98e45ef9360f8044d021975c8b67a2d2d7c5ebe3f383855e5d0a98a8b6da3e4baa3e
diff --git a/net-libs/ccnet/ccnet-6.0.4.ebuild b/net-libs/ccnet/ccnet-6.0.4.ebuild
new file mode 100644
index 000000000000..bb48a189883e
--- /dev/null
+++ b/net-libs/ccnet/ccnet-6.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="Ccnet is a framework for writing networked applications in C"
+HOMEPAGE="https://github.com/haiwen/ccnet http://seafile.com/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ net-libs/libsearpc[${PYTHON_USEDEP}]
+ >=dev-libs/glib-2.16.0:2
+ >=dev-libs/libevent-2.0
+ dev-libs/openssl:0=
+ dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ $(vala_depend)"
+
+src_prepare() {
+ default
+ sed -i -e "s/(DESTDIR)//" libccnet.pc.in || die
+ sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
+ eautoreconf
+ vala_src_prepare
+}
diff --git a/net-libs/ccnet/metadata.xml b/net-libs/ccnet/metadata.xml
new file mode 100644
index 000000000000..5b95006282eb
--- /dev/null
+++ b/net-libs/ccnet/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>moschlar@metalabs.de</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>