summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-05-06 12:49:34 +0200
committerHanno Böck <hanno@gentoo.org>2020-05-06 12:49:34 +0200
commit248c9c3b05ace8fa299cdd02eee9091889590e4b (patch)
treea0efae177f5ea2baf52341b1130041ddadebe594 /net-libs/courier-authlib
parentmail-filter/zdkimfilter: Version bump (diff)
downloadgentoo-248c9c3b05ace8fa299cdd02eee9091889590e4b.tar.gz
gentoo-248c9c3b05ace8fa299cdd02eee9091889590e4b.tar.bz2
gentoo-248c9c3b05ace8fa299cdd02eee9091889590e4b.zip
net-libs/courier-authlib: Version bump
Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'net-libs/courier-authlib')
-rw-r--r--net-libs/courier-authlib/Manifest1
-rw-r--r--net-libs/courier-authlib/courier-authlib-0.70.0.ebuild148
2 files changed, 149 insertions, 0 deletions
diff --git a/net-libs/courier-authlib/Manifest b/net-libs/courier-authlib/Manifest
index b6a8568a808b..49e9f8d3886f 100644
--- a/net-libs/courier-authlib/Manifest
+++ b/net-libs/courier-authlib/Manifest
@@ -2,3 +2,4 @@ DIST courier-authlib-0.66.4.tar.bz2 2192331 BLAKE2B 8fd68153b2defb63bbafb44b34c0
DIST courier-authlib-0.67.0.tar.bz2 2194546 BLAKE2B 2ccb6ed15c2f02d206606f8bba04c9f2da415da3d739e456914e44010c955c9aaeae1f1c0746c8812f5165eb8db1997284e1c378132a6144da2b8f77d77a6eff SHA512 6e3da28d555761177727c44b1422bf5baf6ffbf28f53cea89a4a8e13daa5433803deba1614295d9679c41b5be4750f464e7869a2d3ecbfd91ae84e7281c4f3ef
DIST courier-authlib-0.68.0.tar.bz2 2194982 BLAKE2B e463390b49bb3ca147467d3054a83d5a8ce96b604bde0b624c4d7ce81235c6f747e5d847dde794c81c4ad36aeef49bdd27cf904142b4542df833484c5eb7a57e SHA512 5c4adaf0fd69f4b9e780962aa3f9eeac6b15cea3f302288ff4549ce2b0be9ea0808b4501670ef3c4e0419c3d27505c256c082f795dea4683dd5265fd7dcab93b
DIST courier-authlib-0.69.0.tar.bz2 2197718 BLAKE2B 63c273a85983ce7bd57496eeefac51107e3132dc9eb372f199530dbf6c5a5ddde7f8ee285aa54a096002f9058dc7e1cd9eb1194e3d512ea19882f93b1147345a SHA512 c3806aa50d7ff13f75536064ec46028db3d5e1f4ef64692b5ece64810b4042ae0840bb346c73ae9d36f6113173f0e5e922356a178c10815640a26caa921e1614
+DIST courier-authlib-0.70.0.tar.bz2 2183323 BLAKE2B ebf58f8c4e7b58766edc684ced590ea7bfa692eff19a483f4ab7748a73e96e1c66858985ac89e281205838660a72e9a33e3b3c28fce3f94d981b61ca56b1e2b1 SHA512 61ce62860cc7ceb51f255a0659bf9b8f4172d0c1c8aee06d9821144330f9526f54e6bdb0158f2fd754d6ad92fd4cc84306b949d46c92e8aed47a397023b36b65
diff --git a/net-libs/courier-authlib/courier-authlib-0.70.0.ebuild b/net-libs/courier-authlib/courier-authlib-0.70.0.ebuild
new file mode 100644
index 000000000000..b76a874e6b5b
--- /dev/null
+++ b/net-libs/courier-authlib/courier-authlib-0.70.0.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+DESCRIPTION="Courier authentication library"
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+HOMEPAGE="https://www.courier-mta.org/authlib/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="berkdb crypt debug gdbm ldap libressl mysql pam postgres sqlite static-libs"
+
+RESTRICT="!berkdb? ( test )"
+
+DEPEND="net-mail/mailbase
+ >=net-libs/courier-unicode-2.1
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( sys-libs/db:= )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ mysql? ( dev-db/mysql-connector-c )
+ pam? ( sys-libs/pam )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite:3 )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! has_version 'dev-tcltk/expect' ; then
+ ewarn 'The dev-tcltk/expect package is not installed.'
+ ewarn 'Without it, you will not be able to change system login passwords.'
+ ewarn 'However non-system authentication modules (LDAP, MySQL, PostgreSQL,'
+ ewarn 'and others) will work just fine.'
+ fi
+}
+
+src_configure() {
+ filter-flags -fomit-frame-pointer
+ local myconf
+ if use berkdb ; then
+ if use gdbm ; then
+ ewarn "Both gdbm and berkdb selected. Using gdbm."
+ else
+ myconf="--with-db=db"
+ fi
+ fi
+ use gdbm && myconf="--with-db=gdbm"
+ use debug && myconf+=" debug=true"
+ use sqlite && myconf+=" --with-sqlite-libs"
+
+ econf \
+ --sysconfdir=/etc/courier \
+ --datadir=/usr/share/courier \
+ --localstatedir=/var/lib/courier \
+ --sharedstatedir=/var/lib/courier/com \
+ --with-authdaemonvar=/var/lib/courier/authdaemon \
+ --with-authshadow \
+ --without-redhat \
+ --with-mailuser=mail \
+ --with-mailgroup=mail \
+ --cache-file="${S}/configuring.cache" \
+ $(use_with pam authpam) \
+ $(use_with ldap authldap) \
+ $(use_with mysql authmysql) \
+ $(use_with postgres authpgsql) \
+ $(use_with sqlite authsqlite) \
+ ${myconf}
+}
+
+orderfirst() {
+ file="${D}/etc/courier/authlib/${1}" ; option="${2}" ; param="${3}"
+ if [[ -e "${file}" ]] ; then
+ orig="$(grep ^${option}= ${file} | cut -d\" -f 2)"
+ new="${option}=\"${param} `echo ${orig} | sed -e\"s/${param}//g\" -e\"s/ / /g\"`\""
+ sed -i -e "s/^${option}=.*$/${new}/" "${file}" || die
+ fi
+}
+
+finduserdb() {
+ for dir in \
+ /etc/courier/authlib /etc/courier /etc/courier-imap \
+ /usr/lib/courier/etc /usr/lib/courier-imap/etc \
+ /usr/local/etc /usr/local/etc/courier /usr/local/courier/etc \
+ /usr/local/lib/courier/etc /usr/local/lib/courier-imap/etc \
+ /usr/local/share/sqwebmail /usr/local/etc/courier-imap ; do
+ if [[ -e "${dir}/userdb" ]] ; then
+ einfo "Found userdb at: ${dir}/userdb"
+ cp -fR "${dir}/userdb" "${D}/etc/courier/authlib/" || die
+ chmod go-rwx "${D}/etc/courier/authlib/userdb" || die
+ continue
+ fi
+ done
+}
+
+src_install() {
+ diropts -o mail -g mail
+ dodir /etc/courier
+ keepdir /var/lib/courier/authdaemon
+ keepdir /etc/courier/authlib
+ emake DESTDIR="${D}" install
+ [[ ! -e "${D}/etc/courier/authlib/userdb" ]] && finduserdb
+ emake DESTDIR="${D}" install-configure
+ rm -f "${D}"/etc/courier/authlib/*.bak
+ chown mail:mail "${D}"/etc/courier/authlib/* || die
+ for y in "${D}"/etc/courier/authlib/*.dist ; do
+ [[ ! -e "${y%%.dist}" ]] && cp -f "${y}" "${y%%.dist}"
+ done
+ use pam && orderfirst authdaemonrc authmodulelist authpam
+ use ldap && orderfirst authdaemonrc authmodulelist authldap
+ use sqlite && orderfirst authdaemonrc authmodulelist authsqlite
+ use postgres && orderfirst authdaemonrc authmodulelist authpgsql
+ use mysql && orderfirst authdaemonrc authmodulelist authmysql
+
+ DOCS=( AUTHORS ChangeLog* INSTALL NEWS README )
+ HTML_DOCS=( README.html README_authlib.html NEWS.html INSTALL.html README.authdebug.html )
+ if use mysql ; then
+ DOCS+=( README.authmysql.myownquery )
+ HTML_DOCS+=( README.authmysql.html )
+ fi
+ if use postgres ; then
+ HTML_DOCS+=( README.authpostgres.html README.authmysql.html )
+ fi
+ if use ldap ; then
+ DOCS+=( README.ldap )
+ dodir /etc/openldap/schema
+ cp -f authldap.schema "${D}/etc/openldap/schema/" || die
+ fi
+ if use sqlite ; then
+ HTML_DOCS+=( README.authsqlite.html README.authmysql.html )
+ fi
+ einstalldocs
+
+ newinitd "${FILESDIR}/${PN}-r2" "${PN}"
+
+ use static-libs || find "${D}" -name "*.a" -delete
+}
+
+pkg_postinst() {
+ if [[ -e /etc/courier/authlib/userdb ]] ; then
+ einfo "Running makeuserdb ..."
+ chmod go-rwx /etc/courier/authlib/userdb || die
+ makeuserdb
+ fi
+}