summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2019-03-13 16:08:56 +0100
committerGuilherme Amadio <amadio@gentoo.org>2019-03-13 17:30:55 +0100
commitb588a0cd399a1937a8416215e8753dd6908d6529 (patch)
tree9e835efee6d2ff481133acd532ec0a7e3464fe7b /net-libs/davix
parentwww-client/firefox: fix building with cbindgen-0.8.2 (diff)
downloadgentoo-b588a0cd399a1937a8416215e8753dd6908d6529.tar.gz
gentoo-b588a0cd399a1937a8416215e8753dd6908d6529.tar.bz2
gentoo-b588a0cd399a1937a8416215e8753dd6908d6529.zip
net-libs/davix: bump to 0.7.2
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'net-libs/davix')
-rw-r--r--net-libs/davix/Manifest1
-rw-r--r--net-libs/davix/davix-0.7.2.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/davix/Manifest b/net-libs/davix/Manifest
index 267666160a2c..0fd510eea0db 100644
--- a/net-libs/davix/Manifest
+++ b/net-libs/davix/Manifest
@@ -1,2 +1,3 @@
DIST davix-0.6.7.tar 3346429 BLAKE2B 7510c628cd1d346ed5f4dca6100207e5e2efa3a98d0caf63dbe3ba39f58a9b11c330c95cd2d40d60d8f2497355d4cb2f2d7537babfef287a5905f32322363d90 SHA512 5cb830e415a4ab87b7b046fbd8ba615379766f4fa4b886a271b0c248c05968b9a3cb144751b44d5fd62f5e07bdb7610c0505e44f2702147f6f006b49a4b3d8ce
DIST davix-0.7.1.tar 4336124 BLAKE2B 5db4f8f03fef38feedb0f0a9dfce763ff53ba9b1aa19d09f0af979e111d9f52226222e7b00e48aa3589070e9bf857e000f297d1a162aac83fe877ce3cd2984e1 SHA512 a4408960c4e16011de5e6cea1470d7fa487fd0b9c462082d8fb800bcaa812cab10a92643c9eeb66dda506d177903917176e6310c2a10042a848a52b858f4eb4e
+DIST davix-0.7.2.tar 4338425 BLAKE2B 9a09d2d702b8d9767ac6b0a5e04170d3f7e930b4c9c0cd8127bee2eae99978f5fdbed7be09875c1bbdcd38c29aede1b8f74a56cc15d31ab5ffa3e1f92fb26990 SHA512 207cf290aa4dedfa8c37cf7e7d8fd2162ecd04421abef55f7ade23193e6ca18942d1fb0d611a63fbeed45d9ba5eab8f9957efcdad7f6296b9ac9a69b07c9c339
diff --git a/net-libs/davix/davix-0.7.2.ebuild b/net-libs/davix/davix-0.7.2.ebuild
new file mode 100644
index 000000000000..b80ff8a2e7e7
--- /dev/null
+++ b/net-libs/davix/davix-0.7.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="High-performance file management over WebDAV/HTTP"
+HOMEPAGE="https://dmc.web.cern.ch/projects/davix"
+SRC_URI="http://grid-deployment.web.cern.ch/grid-deployment/dms/lcgutil/tar/${PN}/${PV}/${P}.tar.gz -> ${P}.tar"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipv6 kernel_linux test tools"
+
+CDEPEND="
+ dev-libs/libxml2:2=
+ dev-libs/openssl:0=
+ kernel_linux? ( sys-apps/util-linux )
+"
+
+DEPEND="${CDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ dev-python/sphinx
+ )
+ virtual/pkgconfig
+"
+
+RDEPEND="${CDEPEND}"
+
+REQUIRED_USE="test? ( tools )"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ for x in doc test; do
+ if ! use $x; then
+ sed -i -e "/add_subdirectory ($x)/d" CMakeLists.txt
+ fi
+ done
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DDOC_INSTALL_DIR="${EPREFIX}/usr/share/doc/${P}"
+ -DENABLE_HTML_DOCS=$(usex doc)
+ -DENABLE_IPV6=$(usex ipv6)
+ -DENABLE_TOOLS=$(usex tools)
+ -DHTML_INSTALL_DIR="${EPREFIX}/usr/share/doc/${P}/html"
+ -DSOUND_INSTALL_DIR="${EPREFIX}/usr/share/${PN}/sounds"
+ -DSTATIC_LIBRARY=OFF
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}/etc"
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ cmake-utils_src_compile doc
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if ! use tools; then
+ rm -rf "${ED}/usr/share/man/man1"
+ fi
+
+ if use test; then
+ rm -rf "${ED}/usr/bin/davix-unit-tests"
+ fi
+}