summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/farstream/farstream-0.1.2-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/farstream/farstream-0.1.2-r2.ebuild')
-rw-r--r--net-libs/farstream/farstream-0.1.2-r2.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/net-libs/farstream/farstream-0.1.2-r2.ebuild b/net-libs/farstream/farstream-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..0e6440e6b082
--- /dev/null
+++ b/net-libs/farstream/farstream-0.1.2-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="Audio/video conferencing framework specifically designed for instant messengers"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/Farstream"
+SRC_URI="http://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+
+IUSE="+introspection python test upnp"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+SLOT="0.1"
+
+# Tests need shmsink from gst-plugins-bad, which isn't packaged
+RESTRICT="test"
+
+COMMONDEPEND="
+ >=media-libs/gstreamer-0.10.33:0.10
+ >=media-libs/gst-plugins-base-0.10.33:0.10
+ >=dev-libs/glib-2.30:2
+ >=net-libs/libnice-0.1.0
+ introspection? ( >=dev-libs/gobject-introspection-0.10.11 )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.16:2[${PYTHON_USEDEP}]
+ >=dev-python/gst-python-0.10.10:0.10[${PYTHON_USEDEP}] )
+ upnp? ( net-libs/gupnp-igd )
+"
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-good-0.10.17:0.10
+ >=media-libs/gst-plugins-bad-0.10.17:0.10
+ || (
+ >=media-plugins/gst-plugins-libnice-0.1.0:0.10
+ <=net-libs/libnice-0.1.3[gstreamer] )
+ !net-libs/farsight2
+"
+# This package is just a rename from farsight2
+
+MAKEOPTS="${MAKEOPTS} -j1" # Parallel is completely broken on this slot, bug #434618
+
+DEPEND="${COMMONDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? (
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-vorbis:0.10 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# FIXME: do an out-of-tree build for tests if USE=-msn
+RESTRICT="test"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fix building with gobject-introspection-1.33.x, bug #425096
+ epatch "${FILESDIR}/${P}-introspection-tag-order.patch"
+}
+
+src_configure() {
+ plugins="fsrawconference,fsrtpconference,fsfunnel,fsrtcpfilter,fsvideoanyrate"
+ econf --disable-static \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_enable upnp gupnp) \
+ --with-plugins=${plugins}
+}
+
+src_install() {
+ # Parallel install fails, bug #434618 (fixed in latest slot)
+ emake -j1 install DESTDIR="${D}"
+ dodoc AUTHORS README ChangeLog
+
+ # Remove .la files since static libs are no longer being installed
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
+}