summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-10 07:09:51 +0000
committerSam James <sam@gentoo.org>2020-10-10 07:09:51 +0000
commit22c4cf9c6d295da8b1cda4a5eff7053ef6ee931f (patch)
treef2f44e9babc0910b23ebab9b21f53040577a9de4 /net-libs/gloox
parentnet-libs/enet: port to EAPI 7 (diff)
downloadgentoo-22c4cf9c6d295da8b1cda4a5eff7053ef6ee931f.tar.gz
gentoo-22c4cf9c6d295da8b1cda4a5eff7053ef6ee931f.tar.bz2
gentoo-22c4cf9c6d295da8b1cda4a5eff7053ef6ee931f.zip
net-libs/gloox: bump to 1.0.24
Closes: https://bugs.gentoo.org/713224 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/gloox')
-rw-r--r--net-libs/gloox/Manifest1
-rw-r--r--net-libs/gloox/files/gloox-1.0.24-Makefile.patch36
-rw-r--r--net-libs/gloox/files/gloox-1.0.24-musl.patch13
-rw-r--r--net-libs/gloox/gloox-1.0.24.ebuild59
4 files changed, 109 insertions, 0 deletions
diff --git a/net-libs/gloox/Manifest b/net-libs/gloox/Manifest
index 37de0cfbb35e..90396725d723 100644
--- a/net-libs/gloox/Manifest
+++ b/net-libs/gloox/Manifest
@@ -1 +1,2 @@
DIST gloox-1.0.22.tar.bz2 722653 BLAKE2B e029930ae51053772d4f7bb0cb0933cb260aacc571a6fab6b78c0e12cb7e119938c742afcc0e1af037a97c293f03b423a626c9b01dc9ce974b922c7e9054bcf2 SHA512 89b51dbee338ef8b234d934a5536a2e5d83d8121fa624e933b63bd15017d60f941781a1045884d0d125f50370ed7857cf4131242d39f6703e72c9cf064691416
+DIST gloox-1.0.24.tar.bz2 727442 BLAKE2B 57e8916ddf057c115350e005a027e3a81684269f688dd80126bf3753a8dd71a8d64a86e1eb59de2886a6657ad1dac5f9431549db79f314173f49233044b52cb5 SHA512 e3ddb331a57e635b8da5d8cd36a89fa9521599301d1108a025a3526a02df5bf73555d54bccd3706fdffd857134716b23df6bf57a59a17be4f6a7873a810268ee
diff --git a/net-libs/gloox/files/gloox-1.0.24-Makefile.patch b/net-libs/gloox/files/gloox-1.0.24-Makefile.patch
new file mode 100644
index 000000000000..40fed6900f0d
--- /dev/null
+++ b/net-libs/gloox/files/gloox-1.0.24-Makefile.patch
@@ -0,0 +1,36 @@
+Call make with the current instance if possible.
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -17,12 +17,12 @@ apidox:
+ check: test
+
+ test:
+- make -C src test
++ $(MAKE) -C src test
+
+ leakcheck: leaktest
+
+ leaktest:
+- make -C src leaktest
++ $(MAKE) -C src leaktest
+
+ includetest:
+- make -C src includetest
++ $(MAKE) -C src includetest
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -117,12 +117,12 @@ noinst_HEADERS = config.h prep.h dns.h nonsaslauth.h mucmessagesession.h stanzae
+ EXTRA_DIST = version.rc
+
+ test:
+- make -C tests test
++ $(MAKE) -C tests test
+
+ check: test
+
+ leaktest:
+- make -C tests leaktest
++ $(MAKE) -C tests leaktest
+
+ leakcheck: leaktest
+
diff --git a/net-libs/gloox/files/gloox-1.0.24-musl.patch b/net-libs/gloox/files/gloox-1.0.24-musl.patch
new file mode 100644
index 000000000000..041841ef345e
--- /dev/null
+++ b/net-libs/gloox/files/gloox-1.0.24-musl.patch
@@ -0,0 +1,13 @@
+https://raw.githubusercontent.com/void-linux/void-packages/master/srcpkgs/gloox/patches/gloox-musl.patch
+https://bugs.gentoo.org/713224
+--- a/src/connectiontcpserver.cpp
++++ b/src/connectiontcpserver.cpp
+@@ -51,7 +51,7 @@
+ #endif
+
+ #include <cstdlib>
+-#include <string>
++#include <string.h>
+
+ #ifndef _WIN32_WCE
+ # include <sys/types.h>
diff --git a/net-libs/gloox/gloox-1.0.24.ebuild b/net-libs/gloox/gloox-1.0.24.ebuild
new file mode 100644
index 000000000000..4a083e0af497
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.24.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${P/_/-}"
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="https://camaya.net/gloox/"
+SRC_URI="https://camaya.net/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+# Check upstream changelog: https://camaya.net/gloox/changelog/
+SLOT="0/18"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gnutls idn libressl ssl static-libs test zlib"
+
+DEPEND="
+ idn? ( net-dns/libidn:= )
+ gnutls? ( net-libs/gnutls:= )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ zlib? ( sys-libs/zlib )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.24-musl.patch"
+ "${FILESDIR}/${PN}-1.0.24-Makefile.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Examples are not installed anyway, so - why should we build them?
+ local myeconfargs=(
+ --without-examples
+ $(usex debug "--enable-debug" '')
+ $(use_enable static-libs static)
+ $(use_with idn libidn)
+ $(use_with gnutls)
+ $(use_with ssl openssl)
+ $(use_with test tests)
+ $(use_with zlib)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}