summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-31 12:01:46 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-31 12:06:05 +0100
commit63004184a7c800760f5cd721437a735d9d907aea (patch)
tree31e725bb5160b24f43ebce1ffc2b612a10729430 /net-libs/gnome-online-accounts
parentgames-puzzle/gnome-klotski: version bump 3.20.2 → 3.22.0 (diff)
downloadgentoo-63004184a7c800760f5cd721437a735d9d907aea.tar.gz
gentoo-63004184a7c800760f5cd721437a735d9d907aea.tar.bz2
gentoo-63004184a7c800760f5cd721437a735d9d907aea.zip
net-libs/gnome-online-accounts: version bump 3.20.4 → 3.22.1
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-libs/gnome-online-accounts')
-rw-r--r--net-libs/gnome-online-accounts/Manifest1
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.22.1.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
index 12c770cd48c1..3abb70de31fb 100644
--- a/net-libs/gnome-online-accounts/Manifest
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -1,2 +1,3 @@
DIST gnome-online-accounts-3.18.6.tar.xz 1478544 SHA256 7e7c581b19b213d04c56a080ed7240a90999d7be2daca27d4aa054d205b48fa5 SHA512 1261596888c0704be8707d58aad381bb715d14a5f1ffd3c2db37b34289343f43feadacf1728dfe57b0ef1a1897dbd3471817f565bf0187b8bc042dd81d40b849 WHIRLPOOL 3c31fff5394f8ad65f8fcc230b8dde658ca64b36e48e744281df28f9f1e4ce470d3a2256f0b92a6c99616abcd82bbf5d96f4cb23d03afe84a58829c617bcf67d
DIST gnome-online-accounts-3.20.4.tar.xz 1387928 SHA256 d5ca22404d1ef671a99f6b76ee09d4d4377ce9c86748fd1577b0a95a5129fa3f SHA512 584f7b40006ea55958e8750c0bc1dca5ac014ff4920350d3de5df2a3717fc8845d235dd6ef7fc394b7f07a82b9092486832b7f594bb21b9b53ba23c321bbd5cd WHIRLPOOL 24e2c72e67030682ab80a6570a8bf4056120fda27978eca3bf10a5714691b294be348d8e35a8cb97cd7ee90ecf6dde9ee7f0c6b5c92d056c38b790080b2cb746
+DIST gnome-online-accounts-3.22.1.tar.xz 1408072 SHA256 83c2b707c0a7908c6fe93db1c415fa45bffb2b1d9fb4648badc749ce69cda50e SHA512 454e2ff35e186f89dae14a720e4a89691d7161f41b622668fbb32181758211974cf104a45c86ffe3e5caf51a5f6ea9ffa8f1646d8719f96294d95efc9c03d63f WHIRLPOOL 13ee0576fad15eba00271830466736d8aa05d50cbcc689541097cab5b5df261174db8a66f3d99af4f9f1ef65934817de8c86c292e664e478e21efb75cad2f93b
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.22.1.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.22.1.ebuild
new file mode 100644
index 000000000000..87efca6ec351
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.22.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+IUSE="debug gnome +introspection kerberos" # telepathy"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/json-glib-0.16
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ net-libs/telepathy-glib
+ >=net-libs/webkit-gtk-2.7.2:4
+ >=x11-libs/gtk+-3.19.12:3
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+ kerberos? (
+ app-crypt/gcr:0=
+ app-crypt/mit-krb5 )
+"
+# telepathy? ( net-libs/telepathy-glib )
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf needs gobject-introspection-common, gnome-common
+
+# Due to sub-configure
+QA_CONFIGURE_OPTIONS=".*"
+
+src_prepare() {
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+ # telepathy optional support is really a badly one, bug #494456
+ gnome2_src_configure \
+ --disable-static \
+ --enable-backend \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-flickr \
+ --enable-foursquare \
+ --enable-imap-smtp \
+ --enable-lastfm \
+ --enable-media-server \
+ --enable-owncloud \
+ --enable-pocket \
+ --enable-telepathy \
+ --enable-windows-live \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable kerberos)
+ #$(use_enable telepathy)
+ # gudev & cheese from sub-configure is overriden
+ # by top level configure, and disabled so leave it like that
+}