summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-01-17 22:12:24 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2018-01-17 22:12:44 +0200
commitf3de3fe4b7b665c5152d13fc0adb7923dca9b7de (patch)
tree7c672fe2aa0ea09c466dbc642333f5a7e19b37e6 /net-libs/gnutls
parentapp-portage/repoman: amd64 stable wrt bug #644880 (diff)
downloadgentoo-f3de3fe4b7b665c5152d13fc0adb7923dca9b7de.tar.gz
gentoo-f3de3fe4b7b665c5152d13fc0adb7923dca9b7de.tar.bz2
gentoo-f3de3fe4b7b665c5152d13fc0adb7923dca9b7de.zip
net-libs/gnutls: version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'net-libs/gnutls')
-rw-r--r--net-libs/gnutls/Manifest1
-rw-r--r--net-libs/gnutls/gnutls-3.5.17.ebuild137
2 files changed, 138 insertions, 0 deletions
diff --git a/net-libs/gnutls/Manifest b/net-libs/gnutls/Manifest
index 508509e0a0a3..961874e7111c 100644
--- a/net-libs/gnutls/Manifest
+++ b/net-libs/gnutls/Manifest
@@ -1,4 +1,5 @@
DIST gnutls-3.5.15.tar.xz 7238928 BLAKE2B d9a081ec0f956cabe0e0a240c6f20bd2f2855ca8b692b22322f4c80b521cfc8a9bf45da32518225550f289bb0db7010f40a3b371a9e79e394c6ec88004a15fab SHA512 046cf3adf6cc3d38fd431f2ff28ddabb65f3c13379516d105316a04c7128be89c5f7ed3df6a034fc06e9ab2e154c2cde2f5cbe8530a1e58cc4b4fb72e158134b
DIST gnutls-3.5.16.tar.xz 7559812 BLAKE2B 5b2fded412823b3f947c000f71bb816e2e248c8f740c2e678ec1e8289dd0b4af73a4f4ab46012c7430aa2a5c57dc7fed532eb1666c13328ec90ed159d1ee48a8 SHA512 451d3167be599ed8e0333dd7c9f8501fcb47b7aa871aeb461c368381c0b7ecd7e2026ec35dbbb2aa685cb2c3a22e9296e0a0699409e3744b731c1bb7e7e69f07
+DIST gnutls-3.5.17.tar.xz 7261864 BLAKE2B 3b7cbdda3763f05c769c020c517afced3fe27e8b1ec03754d44ef0c183e7985cf0a71f1d176bbcda8aa9bb814a6c53d7da3f2193e084f6d9eea214edbdeba1f2 SHA512 0cb3405dee64737e314bfa9eed6afa57a8951190fe576122aecaf587c07ec1a5df1ac4819078bff0d292271639019c76d9a708027b502e3f55e2cf6576555ea6
DIST gnutls-3.6.0.tar.xz 8024972 BLAKE2B 754ec0c097430ef0d5c8c998b94e85c53ac6d34ec0e8b47c83c55f5e6235f783013572040998eb4a163e46ff569827c7c20c81f4e02a129b65e8b0c5d6d59f99 SHA512 e5f36d7e8d64e8432098e30549c321745d3605eeb85aba2a04bfa92146ca771961f0e2f3682bcae36be5b6095acd25996104a4213ce7b3466d61332a5188dc03
DIST gnutls-3.6.1.tar.xz 8064408 BLAKE2B 1a573f476261532d516ec7a2c4640cbf8aaaebbbdd129ccfeb1b88d3a66f919ff0eed142a91df19ca9c2f69f90c8c65b965c5659024d54db03606aae811bbc14 SHA512 1f2bd3203ea96844c531be700b44623b79f46743143edf97011aab07895ca18d62f1659c7fafc5e1c4b0686fde490836f00358bdd60d6ac0b842526db002da23
diff --git a/net-libs/gnutls/gnutls-3.5.17.ebuild b/net-libs/gnutls/gnutls-3.5.17.ebuild
new file mode 100644
index 000000000000..bd0df06f98b6
--- /dev/null
+++ b/net-libs/gnutls/gnutls-3.5.17.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit libtool ltprune multilib-minimal versionator
+
+DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+SRC_URI="mirror://gnupg/gnutls/v$(get_version_component_range 1-2)/${P}.tar.xz"
+
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0/30" # libgnutls.so number
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+cxx dane doc examples guile +idn nls openpgp +openssl pkcs11 seccomp sslv2 sslv3 static-libs test test-full +tls-heartbeat tools valgrind zlib"
+
+REQUIRED_USE="
+ test-full? ( guile pkcs11 openpgp openssl idn seccomp tools zlib )"
+
+# NOTICE: sys-devel/autogen is required at runtime as we
+# use system libopts
+RDEPEND=">=dev-libs/libtasn1-4.9:=[${MULTILIB_USEDEP}]
+ dev-libs/libunistring:=[${MULTILIB_USEDEP}]
+ >=dev-libs/nettle-3.1:=[gmp,${MULTILIB_USEDEP}]
+ >=dev-libs/gmp-5.1.3-r1:=[${MULTILIB_USEDEP}]
+ tools? ( sys-devel/autogen )
+ dane? ( >=net-dns/unbound-1.4.20[${MULTILIB_USEDEP}] )
+ guile? ( >=dev-scheme/guile-1.8:=[networking] )
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ pkcs11? ( >=app-crypt/p11-kit-0.23.1[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+ idn? ( >=net-dns/libidn2-0.16-r1[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )
+ valgrind? ( dev-util/valgrind )
+ test? (
+ seccomp? ( sys-libs/libseccomp )
+ )
+ test-full? (
+ guile? ( >=dev-scheme/guile-2 )
+ app-crypt/dieharder
+ app-misc/datefudge
+ dev-libs/softhsm:2[-bindist]
+ net-dialup/ppp
+ net-misc/socat
+ )"
+
+DOCS=(
+ README.md
+ doc/certtool.cfg
+)
+
+HTML_DOCS=()
+
+pkg_setup() {
+ # bug#520818
+ export TZ=UTC
+
+ use doc && HTML_DOCS+=(
+ doc/gnutls.html
+ )
+}
+
+src_prepare() {
+ default
+
+ # force regeneration of autogen-ed files
+ local file
+ for file in $(grep -l AutoGen-ed src/*.c) ; do
+ rm src/$(basename ${file} .c).{c,h} || die
+ done
+
+ # Use sane .so versioning on FreeBSD.
+ elibtoolize
+}
+
+multilib_src_configure() {
+ LINGUAS="${LINGUAS//en/en@boldquot en@quot}"
+
+ # remove magic of library detection
+ # bug#438222
+ local libconf=($("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g'))
+
+ # TPM needs to be tested before being enabled
+ libconf+=( --without-tpm )
+
+ # hardware-accell is disabled on OSX because the asm files force
+ # GNU-stack (as doesn't support that) and when that's removed ld
+ # complains about duplicate symbols
+ [[ ${CHOST} == *-darwin* ]] && libconf+=( --disable-hardware-acceleration )
+
+ # Cygwin as does not understand these asm files at all
+ [[ ${CHOST} == *-cygwin* ]] && libconf+=( --disable-hardware-acceleration )
+
+ ECONF_SOURCE=${S} econf \
+ $(multilib_native_enable manpages) \
+ $(multilib_native_use_enable doc gtk-doc) \
+ $(multilib_native_use_enable doc) \
+ $(multilib_native_use_enable guile) \
+ $(multilib_native_use_enable seccomp seccomp-tests) \
+ $(multilib_native_use_enable test tests) \
+ $(multilib_native_use_enable test-full full-test-suite) \
+ $(multilib_native_use_enable tools) \
+ $(multilib_native_use_enable valgrind valgrind-tests) \
+ $(use_enable cxx) \
+ $(use_enable dane libdane) \
+ $(use_enable nls) \
+ $(use_enable openpgp openpgp-authentication) \
+ $(use_enable openssl openssl-compatibility) \
+ $(use_enable sslv2 ssl2-support) \
+ $(use_enable sslv3 ssl3-support) \
+ $(use_enable static-libs static) \
+ $(use_enable tls-heartbeat heartbeat-support) \
+ $(use_with idn libidn2) \
+ $(use_with idn) \
+ $(use_with pkcs11 p11-kit) \
+ $(use_with zlib) \
+ --with-unbound-root-key-file="${EPREFIX}/etc/dnssec/root-anchors.txt" \
+ --without-included-libtasn1 \
+ "${libconf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}